indicator-sound-service crashed with SIGABRT in pa_cvolume_set()

Bug #900117 reported by J Cord on 2011-12-05
70
This bug affects 8 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
Critical
Conor Curran
indicator-sound (Ubuntu)
Medium
Conor Curran

Bug Description

I did not knowingly have any sounds playing, was using Chrome web browser and had just opened my emai, inbox. When I was presented with the crash notification. I have been installing software using the terminal , but nothing that was using the audio system that I can think of at present. My ubuntu software system is in fail. I was installing apps like gdebi, some gtk themes, gparted, etc. mostly system apps. Sorry not more help. Thank you.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: indicator-sound 0.8.0.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-2.6-generic 3.2.0-rc3
Uname: Linux 3.2.0-2-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Sun Dec 4 20:03:13 2011
ExecutablePath: /usr/lib/indicator-sound/indicator-sound-service
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
ProcCmdline: /usr/lib/indicator-sound/indicator-sound-service
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
Signal: 6
SourcePackage: indicator-sound
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 pa_cvolume_set () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
 ?? ()
 dbusmenu_menuitem_handle_event () from /usr/lib/x86_64-linux-gnu/libdbusmenu-glib.so.4
Title: indicator-sound-service crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to precise on 2011-12-04 (0 days ago)
UserGroups:

Related branches

J Cord (j7cord) wrote :

This crash has the same stack trace characteristics as bug #850662. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: added: regression-retracer

StacktraceTop:
 pa_cvolume_set (a=<optimized out>, channels=<optimized out>, v=<optimized out>) at pulse/volume.c:76
 slider_menu_item_update_volume (percent=0.70422535211267612, self=<optimized out>) at /build/buildd/indicator-sound-0.8.0.0/./src/slider-menu-item.c:163
 handle_event (mi=<optimized out>, name=<optimized out>, value=<optimized out>, timestamp=<optimized out>) at /build/buildd/indicator-sound-0.8.0.0/./src/slider-menu-item.c:115
 dbusmenu_menuitem_handle_event (mi=0xf041a0, name=0x7f1d0c007c20 "change-value", variant=0xf346c0, timestamp=0) at /build/buildd/libdbusmenu-0.5.1/./libdbusmenu-glib/menuitem.c:1707
 event_local_handler (user_data=0x7f1d0c005d50) at /build/buildd/libdbusmenu-0.5.1/./libdbusmenu-glib/server.c:1530

Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
summary: - indicator-sound-service crashed with SIGABRT in raise()
+ indicator-sound-service crashed with SIGABRT in pa_cvolume_set()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
visibility: private → public
Conor Curran (cjcurran) on 2012-01-11
Changed in indicator-sound:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → charles (charlesk)
Conor Curran (cjcurran) on 2012-02-14
Changed in indicator-sound:
assignee: charles (charlesk) → Conor Curran (cjcurran)
status: Confirmed → Triaged
milestone: none → 0.8.2.0
Conor Curran (cjcurran) wrote :

I have applied some defensive code around the setting of volumes to see if we can prevent this.
Not so sure why this doesn't happen everytime.
Hopefully fixed in today's release.

Changed in indicator-sound:
status: Triaged → Fix Committed
Changed in indicator-sound (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Conor Curran (cjcurran)
Conor Curran (cjcurran) wrote :

Those affected by this bug please check with 0.8.2.0 release today if it resolves this.
I spent sometime on this today ...

Questions

1. Does it happen everytime you change the volume ?
2. How many channels are on your setup when the crash occurs.
    Two => stereo or more than two => surround of some sort or mono even ?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.8.2.0-0ubuntu1

---------------
indicator-sound (0.8.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - crashed with SIGABRT in pa_cvolume_set (LP: #900117)
    - Mouse on coverart flushes the sound menu (LP: #927733)
    - album artwork misaligned and not visible (LP: #933359)
    - unity-panel-service crashed with SIGSEGV in
      transport_widget_is_selected (LP: #882109)
  * -debian/patches/correct_ldflags_use.patch
    - fixed upstream
 -- Ken VanDine <email address hidden> Wed, 22 Feb 2012 16:41:12 -0500

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
Conor Curran (cjcurran) on 2012-02-28
Changed in indicator-sound:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers