indicator-sound-service assert failure: *** glibc detected *** /usr/lib/indicator-sound/indicator-sound-service: munmap_chunk(): invalid pointer: 0x0976cd68 ***

Bug #897218 reported by etab3ta on 2011-11-28
224
This bug affects 29 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
High
Conor Curran
indicator-sound (Ubuntu)
Medium
Conor Curran

Bug Description

I have opened a .mp3 file with vlc 1.1.12 and I have this error.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: indicator-sound 0.7.9.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-1.3-generic-pae 3.2.0-rc2
Uname: Linux 3.2.0-1-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.90-0ubuntu1
Architecture: i386
AssertionMessage: *** glibc detected *** /usr/lib/indicator-sound/indicator-sound-service: munmap_chunk(): invalid pointer: 0x0976cd68 ***
Date: Mon Nov 28 14:14:40 2011
ExecutablePath: /usr/lib/indicator-sound/indicator-sound-service
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcCmdline: /usr/lib/indicator-sound/indicator-sound-service
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
Signal: 6
SourcePackage: indicator-sound
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
Title: indicator-sound-service assert failure: *** glibc detected *** /usr/lib/indicator-sound/indicator-sound-service: munmap_chunk(): invalid pointer: 0x0976cd68 ***
UpgradeStatus: Upgraded to precise on 2011-11-22 (5 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers
XsessionErrors:
 (gedit:3815): Gtk-WARNING **: Unable to retrieve the file info for `file:///home/enzo/Scrivania/Lettera%20logatto': Errore nell'eseguire lo stat del file "/home/enzo/Scrivania/Lettera logatto": File o directory non esistente
 (nautilus:4492): Eel-WARNING **: "nautilus-directory.c: directories" hash table still has 2 elements at quit time (keys above)
 (process:11801): Gtk-WARNING **: Locale not supported by C library.

Related branches

etab3ta (i6qkl) wrote :

StacktraceTop:
 __libc_message (do_abort=2, fmt=0xb72c9080 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
 malloc_printerr (action=<optimized out>, str=<optimized out>, ptr=0x976cd68) at malloc.c:6283
 munmap_chunk (p=<optimized out>) at malloc.c:3540
 standard_free (mem=0x976cd68) at /build/buildd/glib2.0-2.30.1/./glib/gmem.c:101
 g_free (mem=0x976cd68) at /build/buildd/glib2.0-2.30.1/./glib/gmem.c:263

Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
visibility: private → public
tags: added: bugpattern-needed
Conor Curran (cjcurran) on 2012-02-14
Changed in indicator-sound:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Conor Curran (cjcurran)
Conor Curran (cjcurran) on 2012-02-27
Changed in indicator-sound:
importance: Medium → High
milestone: none → 0.8.3.0
milestone: 0.8.3.0 → none
Conor Curran (cjcurran) wrote :

How frequent is this for people ?
One stack trace points to the C generated vala playlist code ...
Very hard to tell. Any more information would be very useful.

Changed in indicator-sound:
status: Confirmed → Incomplete
Martijn vdS (martijn) wrote :

Could it be related to uninstalling rhythmbox? I did that and I got this message when I started banshee.

In my case, I did not touch Rhytmbox. The bug (indicator-related,
marked as duplicate to this one) occured during installation of
daily-build Banshee from ppa (it was "fresh" installation, not an
update). As there was no visible breakdowns in my system's workflow, I
guess it could have been false alert. (but I don't know a thing about
programming, so just sent a report, like computer advised...).

W dniu 27 lutego 2012 19:05 użytkownik Martijn vdS
<email address hidden> napisał:
> Could it be related to uninstalling rhythmbox? I did that and I got this
> message when I started banshee.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (941576).
> https://bugs.launchpad.net/bugs/897218
>
> Title:
>  indicator-sound-service assert failure: *** glibc detected ***
>  /usr/lib/indicator-sound/indicator-sound-service: munmap_chunk():
>  invalid pointer: 0x0976cd68 ***
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/indicator-sound/+bug/897218/+subscriptions

Conor Curran (cjcurran) on 2012-02-28
Changed in indicator-sound (Ubuntu):
status: Confirmed → Incomplete
Alistair Buxton (a-j-buxton) wrote :

I got this crash when I did "delete from drive" on an MP3 in banshee. It wasn't the currently playing track, but it was on the same album, and so would have played at some point in the future.

Alistair Buxton (a-j-buxton) wrote :

(If it wasn't obvious, an earlier track from same album was playing when I did the delete.)

Conor Curran (cjcurran) wrote :

Thanks Alistair, trying to reproduce here with no success ...

Changed in indicator-sound:
status: Incomplete → Triaged
status: Triaged → Confirmed
Conor Curran (cjcurran) wrote :

Can anyone reproduce this everytime ?

Alistair Buxton (a-j-buxton) wrote :

I can't reproduce it now. Perhaps it's a one time per reboot thing? I've only seen it once, and I only reboot every week or so.

Conor Curran (cjcurran) wrote :

Yeah it's a real random memory corruption but I think we may have identified something in the C generated vala code, report back in a bit.

Conor Curran (cjcurran) on 2012-03-01
Changed in indicator-sound:
status: Confirmed → In Progress
milestone: none → 0.8.3.0
Changed in indicator-sound (Ubuntu):
status: Incomplete → In Progress
assignee: nobody → Conor Curran (cjcurran)
Conor Curran (cjcurran) on 2012-03-01
Changed in indicator-sound:
status: In Progress → Fix Committed
Conor Curran (cjcurran) on 2012-03-01
Changed in indicator-sound:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.8.3.0-0ubuntu1

---------------
indicator-sound (0.8.3.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Fixed memory corruption issue (LP: #897218)
    - crashed with SIGABRT in pa_operation_unref (LP: #908682)
    - Banshee shown in sound menu after removal until reboot (LP: #771202)
    - Coverity PASS_BY_VALUE - CID 10620 (LP: #937451)
    - App icon and name are not aligned (LP: #939929)
 -- Ken VanDine <email address hidden> Fri, 02 Mar 2012 11:26:41 -0500

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.