Unable to use arrow keys to adjust the volume control in the sound menu.

Bug #886335 reported by Luke Yelavich on 2011-11-04
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Indicator Display Objects
Fix Released
High
Charles Kerr
indicator-sound (Ubuntu)
Undecided
Unassigned

Bug Description

 affects ubuntu/indicator-sound

 affects indicator-sound

In natty and earlier, it was possible to navigate to the volume control widget in the sound menu using the keyboard, and change the volume using the arrow keys. This is no longer possible in Oneiric, likely due to the move to GTK3.

Related branches

Adolfo Jayme (fitojb) on 2011-11-05
Changed in indicator-sound:
status: New → Confirmed
Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Conor Curran (cjcurran) on 2011-11-10
Changed in indicator-sound:
assignee: nobody → Conor Curran (cjcurran)
status: Confirmed → Triaged
Conor Curran (cjcurran) on 2011-11-10
Changed in indicator-sound:
milestone: none → 0.7.9.2
importance: Undecided → Medium
Conor Curran (cjcurran) on 2011-11-15
Changed in indicator-sound:
assignee: Conor Curran (cjcurran) → Robert Carr (robertcarr)
Conor Curran (cjcurran) on 2011-12-01
Changed in indicator-sound:
milestone: 0.7.9.2 → none
Changed in ido:
assignee: nobody → Alberto Ruiz (alberto.ruiz)
Conor Curran (cjcurran) on 2012-02-28
Changed in indicator-sound:
status: Triaged → Invalid
Conor Curran (cjcurran) wrote :

This bug is because I'm not getting the key events when the IDO is hightlighted in the indicator. Key press to the right or left and the IDO automatically pushes the selection up or down on the menu. IDO should not consume those events and give me a chance in the indicator to query if it's a left or right arrow key and act accordingly.

That is what I'm presuming, can't be certain. It worked fine before we move to GTK3 over a year ago.

Changed in ido:
status: New → Triaged
importance: Undecided → High
Conor Curran (cjcurran) on 2012-02-28
no longer affects: indicator-sound
Charles Kerr (charlesk) on 2012-02-28
Changed in ido:
assignee: Alberto Ruiz (alberto.ruiz) → charles (charlesk)
Charles Kerr (charlesk) on 2012-03-09
Changed in ido:
status: Triaged → In Progress
Charles Kerr (charlesk) on 2012-03-12
Changed in ido:
status: In Progress → Fix Committed
Charles Kerr (charlesk) on 2012-03-13
Changed in ido:
milestone: none → 0.3.3
Ted Gould (ted) on 2012-03-21
Changed in ido:
status: Fix Committed → Fix Released
Robert Roth (evfool) wrote :

Setting the Ubuntu task to Fix Released, as Volume can be changed on Precise using the arrow keys.

Changed in indicator-sound (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers