unity-panel-service crashed with SIGSEGV in transport_widget_is_selected()

Bug #882109 reported by Cristian Aravena Romero on 2011-10-26
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
Medium
Conor Curran
indicator-sound (Ubuntu)
Medium
Unassigned

Bug Description

Click in menuSound.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: indicator-sound 0.7.9-0ubuntu1
Uname: Linux 3.1.0-030100-generic x86_64
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Wed Oct 26 12:51:01 2011
ExecutablePath: /usr/lib/unity/unity-panel-service
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110531.1)
ProcCmdline: /usr/lib/unity/unity-panel-service
SegvAnalysis:
 Segfault happened at: 0x7f8153ac4e95 <transport_widget_is_selected+21>: mov 0x20(%rax),%eax
 PC (0x7f8153ac4e95) ok
 source "0x20(%rax)" (0x00000020) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: indicator-sound
StacktraceTop:
 transport_widget_is_selected () from /usr/lib/indicators3/6/libsoundmenu.so
 ?? () from /usr/lib/indicators3/6/libsoundmenu.so
 _gtk_marshal_BOOLEAN__BOXED (closure=0x1d03690, return_value=0x7fff1d86cfd0, n_param_values=<optimized out>, param_values=0x314c000, invocation_hint=<optimized out>, marshal_data=<optimized out>) at /build/buildd/gtk+3.0-3.2.0/./gtk/gtkmarshalers.c:85
 g_closure_invoke (closure=0x1d03690, return_value=0x7fff1d86cfd0, n_param_values=2, param_values=0x314c000, invocation_hint=<optimized out>) at /build/buildd/glib2.0-2.30.0/./gobject/gclosure.c:774
 signal_emit_unlocked_R (node=<optimized out>, detail=0, instance=0x1cfe4f0, emission_return=0x7fff1d86d130, instance_and_params=0x314c000) at /build/buildd/glib2.0-2.30.0/./gobject/gsignal.c:3272
Title: unity-panel-service crashed with SIGSEGV in transport_widget_is_selected()
UpgradeStatus: Upgraded to oneiric on 2011-10-04 (22 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

StacktraceTop:
 transport_widget_is_selected (widget=<optimized out>) at /build/buildd/indicator-sound-0.7.9/./src/transport-widget.c:306
 key_press_cb (widget=<optimized out>, event=0x7f814c166d90, data=<optimized out>) at /build/buildd/indicator-sound-0.7.9/./src/indicator-sound.c:608
 _gtk_marshal_BOOLEAN__BOXED (closure=0x1d03690, return_value=0x7fff1d86cfd0, n_param_values=<optimized out>, param_values=0x314c000, invocation_hint=<optimized out>, marshal_data=<optimized out>) at /build/buildd/gtk+3.0-3.2.0/./gtk/gtkmarshalers.c:85
 g_closure_invoke (closure=0x1d03690, return_value=0x7fff1d86cfd0, n_param_values=2, param_values=0x314c000, invocation_hint=<optimized out>) at /build/buildd/glib2.0-2.30.0/./gobject/gclosure.c:774
 signal_emit_unlocked_R (node=<optimized out>, detail=0, instance=0x1cfe4f0, emission_return=0x7fff1d86d130, instance_and_params=0x314c000) at /build/buildd/glib2.0-2.30.0/./gobject/gsignal.c:3272

Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Conor Curran (cjcurran) on 2011-10-26
Changed in indicator-sound:
assignee: nobody → Conor Curran (cjcurran)
importance: Undecided → Medium
Conor Curran (cjcurran) wrote :

hmmm, the priv seems to be null. Odd, will protect against this in next release.
Thanks for the detailed bug report.

Changed in indicator-sound:
milestone: none → 0.7.9.2
status: New → Triaged
Conor Curran (cjcurran) on 2011-11-11
Changed in indicator-sound:
status: Triaged → In Progress
Changed in indicator-sound (Ubuntu):
status: New → In Progress
Conor Curran (cjcurran) wrote :

I have had only one report of this bug already. Never before has this happened so I will not merge this 'fix' but wait to see if others like this show up. My hunch is that there was something unstable beneath i-sound at the time this bug was reported which caused the panel and it's indicators to be freed.

Changed in indicator-sound:
milestone: 0.7.9.2 → none
status: In Progress → Triaged
Changed in indicator-sound (Ubuntu):
status: In Progress → Confirmed
Changed in indicator-sound:
status: Triaged → Confirmed
Conor Curran (cjcurran) wrote :

I have put some defensive code in place to check that the pointer passed in is a Transport Widget. Unsure why this would occur.

Changed in indicator-sound:
milestone: none → 0.8.2.0
status: Confirmed → Fix Committed
Changed in indicator-sound (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.8.2.0-0ubuntu1

---------------
indicator-sound (0.8.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - crashed with SIGABRT in pa_cvolume_set (LP: #900117)
    - Mouse on coverart flushes the sound menu (LP: #927733)
    - album artwork misaligned and not visible (LP: #933359)
    - unity-panel-service crashed with SIGSEGV in
      transport_widget_is_selected (LP: #882109)
  * -debian/patches/correct_ldflags_use.patch
    - fixed upstream
 -- Ken VanDine <email address hidden> Wed, 22 Feb 2012 16:41:12 -0500

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
Conor Curran (cjcurran) on 2012-02-28
Changed in indicator-sound:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers