Ubuntu

indicator-sound-service crashed with SIGABRT in pa_cvolume_set()

Reported by Artur Wyszyński on 2011-09-15
308
This bug affects 34 people
Affects Status Importance Assigned to Milestone
The Sound Menu
High
Antti Kaijanmäki
Unity Foundations
High
Antti Kaijanmäki
indicator-sound (Ubuntu)
High
Antti Kaijanmäki
Oneiric
High
Antti Kaijanmäki
Precise
High
Antti Kaijanmäki
pulseaudio (Ubuntu)
Undecided
Antti Kaijanmäki
Oneiric
Undecided
Antti Kaijanmäki
Precise
Undecided
Antti Kaijanmäki

Bug Description

just crashed

TEST CASE:
1. Open a terminal and kill pulseaudio
 -> The sound applet in the tray will change to '---'
2. Open the sound indicator and move the slider to change the volume

Expected result:
No crash

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: indicator-sound 0.7.7.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.17-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Thu Sep 15 08:45:33 2011
ExecutablePath: /usr/lib/indicator-sound/indicator-sound-service
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
ProcCmdline: /usr/lib/indicator-sound/indicator-sound-service
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
Signal: 6
SourcePackage: indicator-sound
StacktraceTop:
 pa_cvolume_set () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
 ?? ()
 dbusmenu_menuitem_handle_event () from /usr/lib/libdbusmenu-glib.so.4
 ?? () from /usr/lib/libdbusmenu-glib.so.4
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: indicator-sound-service crashed with SIGABRT in pa_cvolume_set()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout disk lpadmin plugdev sambashare

Artur Wyszyński (aljen) wrote :

StacktraceTop:
 pa_cvolume_set (a=<optimized out>, channels=<optimized out>, v=<optimized out>) at pulse/volume.c:76
 slider_menu_item_update_volume (percent=<optimized out>, self=<optimized out>) at /build/buildd/indicator-sound-0.7.7.0/./src/slider-menu-item.c:162
 handle_event (mi=<optimized out>, name=<optimized out>, value=<optimized out>, timestamp=<optimized out>) at /build/buildd/indicator-sound-0.7.7.0/./src/slider-menu-item.c:115
 dbusmenu_menuitem_handle_event (mi=0x16fd190, name=0x1705b80 "change-value", variant=0x17122d0, timestamp=0) at /build/buildd/libdbusmenu-0.4.93/./libdbusmenu-glib/menuitem.c:1707
 event_local_handler (user_data=0x16f90e0) at /build/buildd/libdbusmenu-0.4.93/./libdbusmenu-glib/server.c:1528

Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Jean-Baptiste Lallement (jibel) wrote :

marking as high due to the number of duplicates

visibility: private → public
Changed in indicator-sound (Ubuntu):
importance: Medium → High
milestone: none → ubuntu-11.10
Changed in indicator-sound (Ubuntu):
milestone: ubuntu-11.10 → oneiric-updates
Changed in indicator-sound (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → High
tags: added: rls-mgr-p-tracking
tags: added: rls-mgr-o-tracking
Changed in indicator-sound (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
description: updated
Changed in indicator-sound (Ubuntu Precise):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
tags: added: testcase
Sebastien Bacher (seb128) wrote :

Doing "also affect pulseaudio", shouldn't pulseaudio respawn automatically or being dbus activated or something?

Changed in indicator-sound (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → Canonical Desktop Experience Team (canonical-dx-team)
Changed in indicator-sound (Ubuntu Precise):
assignee: Canonical Desktop Team (canonical-desktop-team) → Canonical Desktop Experience Team (canonical-dx-team)
David Barth (dbarth) wrote :

I can reproduce the crash. Pulse was restarted automatically when i reproduced the issue.

David Barth (dbarth) wrote :

Most proabably a pointer to the old PA instance that is not invalidated automatically in the callback.

Changed in indicator-sound (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Conor Curran (cjcurran)
Changed in unity-foundations:
assignee: nobody → Conor Curran (cjcurran)
milestone: none → oneiric-backlog
importance: Undecided → High
Changed in unity-foundations:
assignee: Conor Curran (cjcurran) → Antti Kaijanmäki (kaijanmaki)
Changed in indicator-sound (Ubuntu Oneiric):
assignee: Conor Curran (cjcurran) → Antti Kaijanmäki (kaijanmaki)
Changed in indicator-sound (Ubuntu Precise):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Antti Kaijanmäki (kaijanmaki)
Changed in pulseaudio (Ubuntu Oneiric):
assignee: nobody → Antti Kaijanmäki (kaijanmaki)
Changed in pulseaudio (Ubuntu Precise):
assignee: nobody → Antti Kaijanmäki (kaijanmaki)
Martin Pitt (pitti) wrote :

Wrote a bug pattern, as we get duplicates hourly, Launchpad oopses when trying to mark bugs as a duplicate.

tags: added: bugpattern-written
removed: bugpattern-needed
Changed in indicator-sound (Ubuntu Oneiric):
status: Confirmed → In Progress
David Henningsson (diwic) wrote :

If it helps,

the pulse client API crashes on

    pa_assert(channels > 0);

called from:

  pa_cvolume_set(&priv->volume, priv->channel_map.channels, new_volume_value);

I'm guessing priv->channel_map.channels is zero because it has not been initialized, i e slider_menu_item_update_volume is called before slider_menu_item_populate or slider_menu_item_update.

Antti Kaijanmäki (kaijanmaki) wrote :

I have a pending merge request for the package maintainer.
https://code.launchpad.net/~kaijanmaki/indicator-sound/lp-850662/+merge/78817

Should be merged today.

Changed in pulseaudio (Ubuntu Precise):
status: New → Invalid
Changed in pulseaudio (Ubuntu Oneiric):
status: New → Invalid
Changed in indicator-sound (Ubuntu Precise):
status: Confirmed → In Progress
Ted Gould (ted) on 2011-10-12
Changed in indicator-sound:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Antti Kaijanmäki (kaijanmaki)
Changed in unity-foundations:
status: New → Fix Committed
Changed in indicator-sound:
milestone: none → 0.7.7
milestone: 0.7.7 → 0.7.9
Ted Gould (ted) on 2011-10-13
Changed in indicator-sound:
status: Fix Committed → Fix Released
Changed in indicator-sound (Ubuntu Oneiric):
status: In Progress → Confirmed
Changed in indicator-sound (Ubuntu Precise):
status: In Progress → Confirmed

Hello Artur, or anyone else affected,

Accepted indicator-sound into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in indicator-sound (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
description: updated

SRU verification for Oneiric:
I have reproduced the problem with indicator-sound 0.7.8-0ubuntu1 in oneiric and have verified that the version of indicator-sound 0.7.9-0ubuntu1 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.7.9-0ubuntu1

---------------
indicator-sound (0.7.9-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    - Protect against source indexes that are lower than 0 (LP: #850662)
 -- Ken VanDine <email address hidden> Thu, 13 Oct 2011 13:53:21 -0400

Changed in indicator-sound (Ubuntu Precise):
status: Confirmed → Fix Released
Changed in indicator-sound (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Conor Curran (cjcurran) on 2011-10-21
Changed in unity-foundations:
status: Fix Committed → Fix Released
Anand Kumria (wildfire) wrote :

I have:

indicator-sound (0.7.9-0ubuntu2.1) oneiric-proposed; urgency=low

installed, and apport came up and directed me to this error.

Unhelpfully, it has not offered a bug pattern or core dump or anything.

However this occurred when I plugged in an external keyboard and used the sound control keys on the external keyboard rather than my laptop.

Chris George (christopher-geo) wrote :

Same as #17

To post a comment you must log in.