unity-panel-service crashed with SIGSEGV in g_variant_type_info_unref()

Bug #819116 reported by Petter Flensburg on 2011-08-01
150
This bug affects 27 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Invalid
Critical
Conor Curran
indicator-sound (Ubuntu)
Critical
Charles Kerr

Bug Description

while running unity-2d

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-services 4.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-7.8-generic 3.0.0
Uname: Linux 3.0.0-7-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unitydialog,unityshell]
CrashCounter: 1
Date: Mon Aug 1 06:16:20 2011
ExecutablePath: /usr/lib/unity/unity-panel-service
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
ProcCmdline: /usr/lib/unity/unity-panel-service
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x84164e: movzbl 0x4(%eax),%edx
 PC (0x0084164e) ok
 source "0x4(%eax)" (0x00000004) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_variant_type_info_unref () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_variant_unref () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/libdbusmenu-glib.so.4
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: unity-panel-service crashed with SIGSEGV in g_variant_type_info_unref()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Petter Flensburg (petterf) wrote :

StacktraceTop:
 g_variant_type_info_check (info=0x0, container_class=<value optimized out>) at /build/buildd/glib2.0-2.29.14/./glib/gvarianttypeinfo.c:164
 g_variant_type_info_unref (info=0x0) at /build/buildd/glib2.0-2.29.14/./glib/gvarianttypeinfo.c:831
 g_variant_unref (value=0xb6b05b60) at /build/buildd/glib2.0-2.29.14/./glib/gvariant-core.c:625
 _g_variant_unref (data=0xb6b05b60) at /build/buildd/libdbusmenu-0.4.90/./libdbusmenu-glib/menuitem.c:317
 g_hash_table_insert_node (hash_table=0x9436010, node_index=<value optimized out>, key_hash=265827749, key=0x98145a0, value=0x97897b0, keep_new_key=0) at /build/buildd/glib2.0-2.29.14/./glib/ghash.c:868

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-08-02
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-08-02
Changed in unity (Ubuntu):
importance: Medium → Critical
Omer Akram (om26er) wrote :

Facing the second time today, this time it happened when I scrolled over the sound icon to change the volume level.

visibility: private → public
Gary Martin (gm795367-gmail) wrote :

I tried to turn the volume up and then I received the error

BertN45 (lammert-nijhof) wrote :

Happened during first start up of Banshee

Neil J. Patel (njpatel) on 2011-09-13
affects: unity → indicator-sound
affects: unity (Ubuntu) → indicator-sound (Ubuntu)

It is perhaps worth mentioning that while this bug looks superficially like bug 825673, the stack traces reveal that they are different crashes.

Conor Curran (cjcurran) on 2011-10-20
Changed in indicator-sound:
assignee: nobody → Conor Curran (cjcurran)
Ted Gould (ted) wrote :

Yeah, it seems that dbusmenu thinks it has a reference to the variant, but someone else has already unref'd it. It looks like the variant in particular is the one for "label" -- so I'd look in indicator sound for where that value is gotten and ensure that the reffing is correct and it's not being unexpectedly unref'd. In general, probably label should always be gotten with dbusmenu_menuitem_property_get() which returns a string. Also, any callbacks shouldn't unref() a variant in their parameter list unless they take a reference.

Conor Curran (cjcurran) on 2011-10-21
Changed in indicator-sound:
status: Confirmed → In Progress
importance: Undecided → Critical
milestone: none → 0.7.10
Conor Curran (cjcurran) wrote :

I think can see a problem with how valac is generating the C in relation to what Ted mentions above. In current trunk the generated C for playlists-menuitem.vala free's the strings that are used for playlist items. The patch below attempts to duplicate the labels when passing them to dbusmenu.

It would make sense that the culprit is the playlist menuitem. It is the only vala written widget that uses default dbusmenu ui rendering.

I cannot reproduce this here.

Conor Curran (cjcurran) wrote :

That patch should actually be the other way around ..whoops.

Conor Curran (cjcurran) wrote :
Conor Curran (cjcurran) wrote :

A closer look at this makes me believe this is a corrupt stack trace. I'm not calling dbusmenu_menuitem_property_set_variant on the indicators .so therefore I don't have a clue still where this is coming from.

Conor Curran (cjcurran) wrote :

Please submit a new stack trace.

Changed in indicator-sound:
status: In Progress → Triaged
Conor Curran (cjcurran) on 2011-10-26
Changed in indicator-sound:
milestone: 0.7.9.1 → none
Petter Flensburg (petterf) wrote :

Hi Conor! I want to help with this, however, I do not know how to submit a new stack strace to this bug, apport only adds stuff when a new bug is reported. How do I do this?

Of course, I need to reproduce the bug, but first thing is first. Don't know how to submit the data you require.

@Petter Flensburg
To make your new stack trace (also called a backtrace) maximally helpful, it would be good if you were to install some debug symbol packages. Some of the applicable packages are only available in the -dbgsym (rather than -dbg) variety, so first follow the instructions at https://wiki.ubuntu.com/DebuggingProgramCrash to enable the ddebs repositories. Then run "sudo apt-get update; sudo apt-get install indicator-sound-dbgsym libglib2.0-0-dbg libdbusmenu-glib4-dbgsym libgtk-3-0-dbg unity-services-dbgsym unity-dbgsym" (all on one line, without the quotes) to install the debug symbol packages that are most clearly useful to this bug. Then you'll need to reproduce the crash and get a stack trace. Probably the easiest way to do that is to let Apport create a new bug report and indicate which bug it is here (as there are already some duplicates). Conor Curran may have a different way he'd prefer for you to do it (such as manually with gdb, see https://wiki.ubuntu.com/Backtrace), so whatever he says should be taken to supersede this suggestion.

Conor Curran (cjcurran) wrote :

Perfect Eliah, thank you.

Conor

Charles Kerr (charlesk) wrote :

Does anyone affected by this bug have a recipe that can be used to trigger it?

Peter, is this crash still occurring for you?

Petter Flensburg (petterf) wrote :

Hi Charles. I have tried to reproduce it to create this bug to create this new backtrace, however it doesn't happen...

Before it would occur "by itself" like once every couple of days, but it does not happen anymore. I have no idea why.

Conor Curran (cjcurran) wrote :

Has this bug been fixed by some lower level update ?
Anyone experienced this recently ?

Charles Kerr (charlesk) on 2012-01-09
Changed in indicator-sound (Ubuntu):
assignee: nobody → charles (charlesk)
Charles Kerr (charlesk) wrote :

Hi Pettr,

Pettr, when you compare `before' to now -- as per Conor's question, I notice this bug was filed in late July; are you running a release version of Oneiric now? Have you upgraded your system, either overall or specific packages?

Charles Kerr (charlesk) wrote :

Excuse me, that should read Petter...

Conor Curran (cjcurran) on 2012-01-11
Changed in indicator-sound:
status: Triaged → Incomplete
Conor Curran (cjcurran) on 2012-01-12
Changed in indicator-sound (Ubuntu):
status: Confirmed → Incomplete
Petter Flensburg (petterf) wrote :

Hi!

Charles, of course I update my system, still running Oneiric though.

I think that if no one else is still having these problems I think we should assume that it's fixed somehow, and close the bug. This bug was nerv vrecki'n when it occured but it does not happen any longer.

So if anyone has something against this, shout out loud ;)

Olli Ries (ories) wrote :

closing as per last comment

Changed in indicator-sound:
status: Incomplete → Invalid
Changed in indicator-sound (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints