sound indicator not working

Bug #791183 reported by Fabio Marconi on 2011-06-01
60
This bug affects 6 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
Undecided
Conor Curran
indicator-sound (Ubuntu)
Medium
Canonical Desktop Team
Oneiric
Medium
Canonical Desktop Team

Bug Description

Binary package hint: pulseaudio

Hello
using hotkeys to control the volume when I decrease it the indicator (black rectangle with loudspeaker icon and level bar) show the loudspaker with the red cross and the level bar empty, if i raise the volume it show the maximum level. Pratically has only two stages, but the volume is controlled fine.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: pulseaudio 1:0.9.22+stable-queue-69-gf8e8-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.39-3.10-generic 2.6.39
Uname: Linux 2.6.39-3-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: njin 1475 F.... pulseaudio
 /dev/snd/pcmC0D0p: njin 1475 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfbff8000 irq 42'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:10ec0887,1458a102,00100202 HDA:80862804,80860101,00100000'
   Controls : 42
   Simple ctrls : 22
Date: Wed Jun 1 13:27:01 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110531.1)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: pulseaudio
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/20/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F7
dmi.board.name: H55M-S2H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF7:bd08/20/2010:svnGigabyteTechnologyCo.,Ltd.:pnH55M-S2H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnH55M-S2H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: H55M-S2H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Fabio Marconi (fabiomarconi) wrote :
tags: added: iso-testing
Luke Yelavich (themuso) wrote :

Thanks for your bug report. What desktop environment are you running when you see this behavior? Does the volume icon behave correctly if you change the volume from within the dropdown that you get when you click the icon?

Changed in pulseaudio (Ubuntu):
status: New → Incomplete
Fabio Marconi (fabiomarconi) wrote :

Hello Luke
Using the mouse everythings is ok.
Using the hotkeys the appears receive the command but don't draw correctly, if i raise the volume from 0 of one pression of the key it show immediatly the top of the volume, but the regulation of the sound is correct.
Same thing happens decreasing, it start showing the maximum level, then pressing one time the hotkey it show the loudspeaker icon with red cross, but the volume is rightly decreased.
I'm talking about these, look the attached screenshot ( the music is playing and the levels vary regularry)

Fabio Marconi (fabiomarconi) wrote :

You can see that the volume on the applet indicator is hight, but theblck rectangle (sorry i don't know it's name) is not the same (has a red cross), for the rest the black rectangle show it's things without problems, so I think that pulseaudio don't send the right output to this black rectangle.
Thanks
Fabio

Fabio Marconi (fabiomarconi) wrote :

Is also true that the other things that this rectangle shows are static images, not dinamic as the volume regulation

Jean-Baptiste Lallement (jibel) wrote :

I confirm this on an Oneiric up to date system

Changed in pulseaudio (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
description: updated
description: updated
description: updated

I very much doubt this is a pulse issue; the "traditional" volume
indicator using the classic GNOME (no effects) session option works
correctly.

Well, isn't a kernel issue because the hotkey do well it's works, it's just a problem in the OSD

Fabio Marconi (fabiomarconi) wrote :

screencast from oneiric updated at 20110619

tags: added: screencast
Changed in notify-osd:
status: New → Confirmed

Same bug affects me, am using a Oneiric desktop environment. I only see this behavior on Ubuntu session, but works well when im on GNOME.

affects: pulseaudio (Ubuntu) → indicator-sound (Ubuntu)
Changed in indicator-sound (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
summary: - volume indicator not working
+ sound indicator not working
Changed in notify-osd:
status: Confirmed → Invalid
affects: notify-osd → indicator-sound
Changed in indicator-sound:
assignee: nobody → Conor Curran (cjcurran)
status: Invalid → Confirmed
Conor Curran (cjcurran) wrote :

weird, Will take a look once I get my system moved over.

Fabio Marconi (fabiomarconi) wrote :

Hello
This seems to be fixed actually.
Everithings working as expected.
Thanks
Fabio

Fabio Marconi (fabiomarconi) wrote :

I'm waiting few day's of testing before close it

Evan Huus (eapache) wrote :

I recall seeing something similar-sounding in an update changelog yesterday, but it didn't have a bug link. Most likely is fixed.

Fabio Marconi (fabiomarconi) wrote :

Well I cannot reproduce the issue, so I close this report
Thanks
Fabio

Changed in indicator-sound (Ubuntu Oneiric):
status: Confirmed → Fix Released
Changed in indicator-sound:
status: Confirmed → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/791183

tags: added: laptop-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers