Ubuntu

Multimedia keys non-functional when sound menu open

Reported by Andy Buchanan on 2011-01-10
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Low
Conor Curran
indicator-sound (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: indicator-sound

Multimedia keys on keyboard (play/pause, back, forward, volume up and volume down) work correctly normally, but when sound menu is open (menu accessed through speaker icon in panel; https://wiki.ubuntu.com/SoundMenu), they do not function.

I would expect them to work anyway, and the changes to be shown immediately.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: indicator-sound 0.5.0.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-23.41-generic 2.6.35.7
Uname: Linux 2.6.35-23-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon Jan 10 12:10:24 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: indicator-sound

Andy Buchanan (andy-buchanans) wrote :
Conor Curran (cjcurran) on 2011-02-07
Changed in indicator-sound:
milestone: none → 0.5.9
status: New → In Progress
assignee: nobody → Conor Curran (cjcurran)
importance: Undecided → Low
Conor Curran (cjcurran) on 2011-02-07
Changed in indicator-sound (Ubuntu):
status: New → In Progress
Conor Curran (cjcurran) on 2011-02-10
Changed in indicator-sound:
milestone: 0.5.9 → none
Conor Curran (cjcurran) on 2011-02-10
Changed in indicator-sound:
milestone: none → 0.6.0
Omer Akram (om26er) on 2011-02-10
Changed in indicator-sound (Ubuntu):
importance: Undecided → Low
status: In Progress → Triaged
Conor Curran (cjcurran) on 2011-02-18
Changed in indicator-sound:
milestone: 0.6.0 → 0.6.1
Conor Curran (cjcurran) on 2011-02-24
Changed in indicator-sound:
milestone: 0.6.1 → 0.6.2
Conor Curran (cjcurran) on 2011-03-03
Changed in indicator-sound:
milestone: 0.6.2 → 0.6.3
Conor Curran (cjcurran) on 2011-03-08
Changed in indicator-sound:
status: In Progress → Won't Fix
Conor Curran (cjcurran) wrote :

I have investigated this thoroughly and It turns out that this is not as easy as first anticipated. The indicator steals the grab from the gnome settings daemon. So by even trying to grab the media keys from its dbus api it doesn't make a difference because the key event never gets to the daemon. One other approach is to grab the X11 key and release events from the daemon but this by all accounts will break GSD after which I will be in for a plethora of grief :)

Conor Curran (cjcurran) wrote :

My attempts are recorded in the attached branch if anybody would like a good :)

Conor Curran (cjcurran) on 2011-03-09
Changed in indicator-sound:
milestone: 0.6.3 → none
kirill (kirill578) wrote :

It doesn't work either when you open "right click menu" on any program

bruno (nitrobruno) wrote :

Or when global menu is open.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers