always show unmuted at startup

Bug #648238 reported by u-foka on 2010-09-26
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
Medium
Conor Curran
indicator-sound (Ubuntu)
Medium
Conor Curran
Maverick
Medium
Conor Curran

Bug Description

Binary package hint: indicator-sound

after startup, the sound indicator always shows an unmuted startup, even when the sound is actually muted...
On the menu, it shows unmute (what's right) when the icon is invalid through...

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: indicator-sound 0.4.7-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic-pae 2.6.35.4
Uname: Linux 2.6.35-22-generic-pae i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sun Sep 26 18:27:01 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901.1)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: indicator-sound

Related branches

u-foka (ufooka) wrote :
Conor Curran (cjcurran) wrote :

Hi,

Thanks for the taking the time to report this. One question is pulse audio running on your system ?

 Conor

 Hy!

Yes, as the default installation comes with it :)

u-foka

On 09/27/2010 11:40 AM, Conor Curran wrote:
> Hi,
>
> Thanks for the taking the time to report this. One question is pulse
> audio running on your system ?
>
> Conor
>
>
> ** Also affects: indicator-sound
> Importance: Undecided
> Status: New
>

Conor Curran (cjcurran) wrote :

Hi,

I can't reproduce this. Just checking but is 'autospawn' definitely set to true in your pulse client.conf, in /etc/pulse/ ?

Conor

u-foka (ufooka) wrote :

Hy!

I have autospawn commented out in my config file: "; autospawn = yes" but it's suggesting that it's on by default (I never touched that)

Now as a quick test, i've muted the sound, logged out, and back in, and the sound indicator showed an unmuted state...

Can I post any other config file or anything to track down the problem?

Conor Curran (cjcurran) wrote :

Hi again,

I just cannot reproduce this. On either 32bit or 64bit. And nobody else seems to have this issue :(.
If you go use gnome-volume-settings does this show the device as being muted ?

Conor Curran (cjcurran) on 2010-10-01
Changed in indicator-sound:
status: New → Triaged
Changed in indicator-sound (Ubuntu):
assignee: nobody → Conor Curran (cjcurran)
Changed in indicator-sound:
assignee: nobody → Conor Curran (cjcurran)
u-foka (ufooka) wrote :

Hy!

The thing is I don't know what caused this bug only for me, because I didn't
do anything with pulse... I would appreciate, if you can point me the right
direction, how can I find what is the cause of this bug...

Bdw, I've thinking if it can be a driver problem or not? I have a Dell
Vostro 1310 with an integrated intel soundcard:
00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio
Controller [8086:284b] (rev 03)

I've also made a short video on what's happening (I kill the
indicator-applet, but the result is the same after logging in with muted
audio)
http://www.eisenberger.hu/~u-foka/indicator-sound-bug.ogv

Thanks for your help!

On Fri, Oct 1, 2010 at 6:16 PM, Conor Curran <email address hidden>wrote:

> ** Changed in: indicator-sound
> Status: New => Triaged
>
> ** Changed in: indicator-sound (Ubuntu)
> Assignee: (unassigned) => Conor Curran (cjcurran)
>
> ** Changed in: indicator-sound
> Assignee: (unassigned) => Conor Curran (cjcurran)
>
> --
> always show unmuted at startup
> https://bugs.launchpad.net/bugs/648238
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Conor Curran (cjcurran) wrote :

looks like a bug alright but if only I could reproduce this on any of my 3 test machines...

Nate Wiebe (natew) wrote :

Installed 10.10 RC amd64 using VMWare and I can confirm that this problem exists.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Nate Wiebe (natew) wrote :

Also, as soon as a sound is played when muted, the icon properly updates to the red muted volume icon. But until a status update, it shows as being unmuted.

Arthur Rilke (arthurrilke) wrote :

This problem also occurs on my system. 64-bit Maverick, fully updated as of 2010-10-05.

Conor Curran (cjcurran) on 2010-10-05
Changed in indicator-sound:
status: Triaged → In Progress
importance: Undecided → Medium
milestone: none → 0.4.8
Conor Curran (cjcurran) wrote :

Bug fixed, will be merged into 0.4.8 and released with the SRU next week sometime.

Changed in indicator-sound:
status: In Progress → Fix Committed
Vish (vish) on 2010-10-06
Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
milestone: none → maverick-updates
status: Confirmed → Fix Committed
Conor Curran (cjcurran) on 2010-10-07
Changed in indicator-sound:
status: Fix Committed → Fix Released

Accepted indicator-sound into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
lores (lores000) wrote :

I used to have this problem; Ubuntu 10.10 Desktop, Asus Eeepc 1005P. After installing the update from -proposed, it seems fixed. Thank you.

Conor Curran (cjcurran) wrote :

Thanks for the feedback Lores !

SRU verification for Maverick:
I have reproduced the problem with indicator-sound 0.4.7-0ubuntu2 in maverick and have verified that the version of indicator-sound 0.4.8-0ubuntu1 in -proposed fixes the issue.

Thanks to all the testers.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 0.4.9-0ubuntu1

---------------
indicator-sound (0.4.9-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release.
    - fixes tranlation mpris name regression (LP: #654140)

indicator-sound (0.4.8-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release.
    - indicator-sound-service eating CPU on second user login (LP: #581173)
    - Right border of transport control is different colour while using
      Ambiance (LP: #632774)
    - Incorrect ellipsing (LP: #637580)
    - always show unmuted at startup (LP: #648238)
    - click or enter on metadata widget does not copy contents to
      clipboard (LP: #651246)
    - Sound menu has two Rhythmbox elements when using
      translations (LP: #654140)
 -- Ken VanDine <email address hidden> Thu, 14 Oct 2010 10:40:13 -0400

Changed in indicator-sound (Ubuntu Maverick):
status: Fix Committed → Fix Released
Conor Curran (cjcurran) on 2010-10-22
Changed in indicator-sound (Ubuntu):
status: Fix Committed → Fix Released

Problem solved, thanks!

On Thu, Oct 21, 2010 at 11:50 AM, Launchpad Bug Tracker <
<email address hidden>> wrote:

> This bug was fixed in the package indicator-sound - 0.4.9-0ubuntu1
>
> ---------------
> indicator-sound (0.4.9-0ubuntu1) maverick-proposed; urgency=low
>
> * New upstream release.
> - fixes tranlation mpris name regression (LP: #654140)
>
> indicator-sound (0.4.8-0ubuntu1) maverick-proposed; urgency=low
>
> * New upstream release.
> - indicator-sound-service eating CPU on second user login (LP: #581173)
> - Right border of transport control is different colour while using
> Ambiance (LP: #632774)
> - Incorrect ellipsing (LP: #637580)
> - always show unmuted at startup (LP: #648238)
> - click or enter on metadata widget does not copy contents to
> clipboard (LP: #651246)
> - Sound menu has two Rhythmbox elements when using
> translations (LP: #654140)
> -- Ken VanDine <email address hidden> Thu, 14 Oct 2010 10:40:13
> -0400
>
> ** Changed in: indicator-sound (Ubuntu Maverick)
> Status: Fix Committed => Fix Released
>
> --
> always show unmuted at startup
> https://bugs.launchpad.net/bugs/648238
> You received this bug notification because you are a direct subscriber
> of the bug.
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers