Build-depends on qt5-default which is obsolete and dropped in hirsute

Bug #1921781 reported by Steve Langasek
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
indicator-sound (Ubuntu)
Fix Released
High
Unassigned
libqofono (Ubuntu)
Fix Released
High
Unassigned
poppler-qml-plugin (Ubuntu)
Fix Released
High
Unassigned
qtpowerd (Ubuntu)
Fix Released
High
Unassigned
qtubuntu-cameraplugin-fake (Ubuntu)
Fix Released
High
Unassigned
signon-keyring-extension (Ubuntu)
Fix Released
High
Unassigned
signon-plugin-sasl (Ubuntu)
Fix Released
High
Unassigned
signon-ui (Ubuntu)
Fix Released
High
Unassigned
unity-api (Ubuntu)
Fix Released
High
Unassigned
unity-control-center (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

These packages build-depend on the qt5-default package, which has been dropped upstream in Debian and will not be available in the hirsute release.

These packages should either be updated to not require this build-dependency, or be removed from hirsute.

Tags: ftbfs
Steve Langasek (vorlon)
Changed in indicator-sound (Ubuntu):
importance: Undecided → High
Changed in libqofono (Ubuntu):
importance: Undecided → High
Changed in qtpowerd (Ubuntu):
importance: Undecided → High
Changed in poppler-qml-plugin (Ubuntu):
importance: Undecided → High
Changed in qtubuntu-cameraplugin-fake (Ubuntu):
importance: Undecided → High
Changed in signon-keyring-extension (Ubuntu):
importance: Undecided → High
Changed in signon-plugin-sasl (Ubuntu):
importance: Undecided → High
Changed in signon-ui (Ubuntu):
importance: Undecided → High
Changed in unity-api (Ubuntu):
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-api - 8.7+17.04.20170404-0ubuntu5

---------------
unity-api (8.7+17.04.20170404-0ubuntu5) hirsute; urgency=medium

  * Remove build dependency on qt5-default, which no longer exists
    (LP: #1921781).

 -- Logan Rosen <email address hidden> Mon, 05 Apr 2021 23:20:17 -0400

Changed in unity-api (Ubuntu):
status: New → Fix Released
Revision history for this message
Khurshid Alam (khurshid-alam) wrote :

What is alternet meta package which pulls default version of qt hirsute?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package signon-plugin-sasl - 0.1+16.04.20151203-0ubuntu2

---------------
signon-plugin-sasl (0.1+16.04.20151203-0ubuntu2) hirsute; urgency=medium

  * Remove build dependency on qt5-default, which no longer exists
    (LP: #1921781).

 -- Logan Rosen <email address hidden> Tue, 06 Apr 2021 23:54:01 -0400

Changed in signon-plugin-sasl (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package signon-ui - 0.17+18.04.20171027+really20160406-0ubuntu3

---------------
signon-ui (0.17+18.04.20171027+really20160406-0ubuntu3) hirsute; urgency=medium

  * Remove build dependency on qt5-default, which no longer exists
    (LP: #1921781).

 -- Logan Rosen <email address hidden> Tue, 06 Apr 2021 23:43:03 -0400

Changed in signon-ui (Ubuntu):
status: New → Fix Released
Logan Rosen (logan)
tags: added: ftbfs
Revision history for this message
Steve Langasek (vorlon) wrote : Re: [Bug 1921781] Re: Build-depends on qt5-default which is obsolete and dropped in hirsute

On Tue, Apr 06, 2021 at 10:56:02AM -0000, Khurshid Alam wrote:
> What is alternet meta package which pulls default version of qt hirsute?

There is none. There is no longer any non-default qt version supported, so
the qtchooser logic is no longer needed. Build-Depend on the relevant qt5
devel packages instead.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package signon-keyring-extension - 0.6+14.10.20140513-0ubuntu3

---------------
signon-keyring-extension (0.6+14.10.20140513-0ubuntu3) hirsute; urgency=medium

  * Remove build dependency on qt5-default, which no longer exists
    (LP: #1921781).

 -- Logan Rosen <email address hidden> Wed, 07 Apr 2021 15:44:36 -0400

Changed in signon-keyring-extension (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libqofono - 0.90+16.10.20160901-0ubuntu3

---------------
libqofono (0.90+16.10.20160901-0ubuntu3) hirsute; urgency=medium

  * Remove build dependency on qt5-default, which no longer exists
    (LP: #1921781).

 -- Logan Rosen <email address hidden> Wed, 07 Apr 2021 15:32:59 -0400

Changed in libqofono (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

indicator-sound has reverse-dependencies, so this probably needs fixed rather than removed.

Changed in poppler-qml-plugin (Ubuntu):
status: New → Fix Released
Changed in qtpowerd (Ubuntu):
status: New → Fix Released
Changed in qtubuntu-cameraplugin-fake (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

unity-control-center depends on indicator-sound. Either:

- indicator-sound needs its build-dependency fixed; or
- unity-control-center needs to drop its dependency on indicator-sound; or
- both of these packages need to be removed for impish.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Changed in unity-control-center (Ubuntu):
status: New → Confirmed
Revision history for this message
Khurshid Alam (khurshid-alam) wrote (last edit ):

Unity-control-center is the integral part of Unity, so it can't be removed. I can simply remove indicator-sound from dependency of indicator-sond.

But I will ask ~mitya57 if the build dependency can be fixed.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

@Khurshid: indicator-sound was last built several cycles ago. When trying to build in impish, I met problems which I think go beyond that qt5-default b-d. (Over my head - gave up.)

Revision history for this message
Khurshid Alam (khurshid-alam) wrote :

@Gunnar: Th tests are failing...but we can disable the tests for now....they are mostly phone related anyway...A few vala related fix may be needed. We can ask @ricotz.

Changed in unity-control-center (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Khurshid Alam (khurshid-alam) wrote :

@Gunnar, regarding indicator-sound, My merge requests is here https://code.launchpad.net/~khurshid-alam/indicator-sound/fix-build-impish/+merge/409379 & build-recipe (https://code.launchpad.net/~khurshid-alam/+recipe/indicator-sound-ftbfs-hirsuit), I have disabled the failing tests for now as most are related to phone or works on phone environment. I have no way to debug that. As per my testing this doesn't hamper functionality on desktop, indicator-sound works as expected but perhaps more testing requires on different hardware. These tests can be enabled for desktop later if someone able to fix those...may be ask 3v1n0 ?

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

@Khurshid: Please see comment on the merge request.

Changed in indicator-sound (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+18.10.20180612-0ubuntu4

---------------
indicator-sound (12.10.2+18.10.20180612-0ubuntu4) impish; urgency=medium

  * Fix build against vala > 48 & vala >= 50

  * Add symbolic icons to the tests

  * Avoid possible null value in Greeterlist and GreeterBroadcast object.
    See https://github.com/AyatanaIndicators/ayatana-indicator-sound/commit/8df9168f

  * Fix build against GLib > 2.64: Replace HashTable with GenericSet

  * Fix static member access

  * Drop deprecated DBusProxy.create_for_bus

  * Add libdbustest-1 include path

  * Unit Tests: Unset environment variable and session bus in teardown

  * debian/control: Remove qt5-default & add libgmock-dev in build
    depends (LP: #1921781).

  * Unit Tests: The desktop pulseaudio daemon also needs the
    stream-restore module these days

  * Unit Tests: Disable notification tests that can not be fixed now.
    Most of them are phone related and depends on liburl-dispatcher
    library which was dropped from code since it is no longer in the
    universe repository. See
    https://bazaar.launchpad.net/~indicator-applet-developers/indicator-sound/trunk.16.10/revision/564

  * Unit Tests: Disable indicator tests that can not be fixed now.
    These tests needs to be re-enabled later
   - tests/indicator-test.cc:PhoneMenu
   - tests/indicator-test.cc:DesktopMenu
   - tests/indicator-test.cc:BaseActions
   - tests/integration/test-indicator.cpp:All tests
   - tests/volume-control-test.cc:BasicObject

  * debian/rules: Re-enable live tests logs

 -- Khurshid Alam <email address hidden> Thu, 30 Sep 2021 02:12:26 +0530

Changed in indicator-sound (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers