[FTBFS] indicator-sound fails to build, test failures

Bug #1737834 reported by Jeremy Bicha on 2017-12-12
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
indicator-sound (Ubuntu)
High
Marco Trevisan (Treviño)

Bug Description

indicator-sound fails to build from source in current bionic. Full build log at

https://launchpad.net/~jbicha/+archive/ubuntu/dev/+build/13847857

Build log excerpt
=================

13/13 Test #13: integration-tests ...................***Failed 152.14 sec
[==========] Running 10 tests from 1 test case.
[----------] Global test environment set-up.
[----------] 10 tests from TestIndicator
[ RUN ] TestIndicator.PhoneCheckRootIcon
pulseaudio(): Process [pulseaudio] for service [org.PulseAudio1] failed to appear on bus
/<<BUILDDIR>>/indicator-sound-12.10.2+17.10.20170829.1/tests/integration/test-indicator.cpp:41: Failure
Expected: startPulsePhone() doesn't throw an exception.
  Actual: it throws.
[ FAILED ] TestIndicator.PhoneCheckRootIcon (16032 ms)
[ RUN ] TestIndicator.PhoneTestExternalMicInOut
pulseaudio(): Process [pulseaudio] for service [org.PulseAudio1] failed to appear on bus
/<<BUILDDIR>>/indicator-sound-12.10.2+17.10.20170829.1/tests/integration/test-indicator.cpp:103: Failure
Expected: startPulsePhone() doesn't throw an exception.
  Actual: it throws.
[ FAILED ] TestIndicator.PhoneTestExternalMicInOut (14982 ms)
[ RUN ] TestIndicator.DesktopTestExternalMicInOut
pulseaudio(): Process [pulseaudio] for service [org.PulseAudio1] failed to appear on bus
/<<BUILDDIR>>/indicator-sound-12.10.2+17.10.20170829.1/tests/integration/test-indicator.cpp:187: Failure
Expected: startPulseDesktop() doesn't throw an exception.
  Actual: it throws.
[ FAILED ] TestIndicator.DesktopTestExternalMicInOut (15008 ms)
[ RUN ] TestIndicator.PhoneBasicInitialVolume
pulseaudio(): Process [pulseaudio] for service [org.PulseAudio1] failed to appear on bus
/<<BUILDDIR>>/indicator-sound-12.10.2+17.10.20170829.1/tests/integration/test-indicator.cpp:380: Failure
Expected: startPulsePhone() doesn't throw an exception.
  Actual: it throws.
[ FAILED ] TestIndicator.PhoneBasicInitialVolume (15030 ms)
[ RUN ] TestIndicator.PhoneAddMprisPlayer
pulseaudio(): Process [pulseaudio] for service [org.PulseAudio1] failed to appear on bus
/<<BUILDDIR>>/indicator-sound-12.10.2+17.10.20170829.1/tests/integration/test-indicator.cpp:415: Failure
Expected: startPulsePhone() doesn't throw an exception.
  Actual: it throws.
[ FAILED ] TestIndicator.PhoneAddMprisPlayer (15984 ms)
[ RUN ] TestIndicator.DesktopBasicInitialVolume
pulseaudio(): Process [pulseaudio] for service [org.PulseAudio1] failed to appear on bus
/<<BUILDDIR>>/indicator-sound-12.10.2+17.10.20170829.1/tests/integration/test-indicator.cpp:495: Failure
Expected: startPulseDesktop() doesn't throw an exception.
  Actual: it throws.
[ FAILED ] TestIndicator.DesktopBasicInitialVolume (14998 ms)
[ RUN ] TestIndicator.DesktopAddMprisPlayer
pulseaudio(): Process [pulseaudio] for service [org.PulseAudio1] failed to appear on bus
/<<BUILDDIR>>/indicator-sound-12.10.2+17.10.20170829.1/tests/integration/test-indicator.cpp:548: Failure
Expected: startPulseDesktop() doesn't throw an exception.
  Actual: it throws.
[ FAILED ] TestIndicator.DesktopAddMprisPlayer (15014 ms)
[ RUN ] TestIndicator.DesktopMprisPlayersPlaybackControls
pulseaudio(): Process [pulseaudio] for service [org.PulseAudio1] failed to appear on bus
/<<BUILDDIR>>/indicator-sound-12.10.2+17.10.20170829.1/tests/integration/test-indicator.cpp:637: Failure
Expected: startPulseDesktop() doesn't throw an exception.
  Actual: it throws.
[ FAILED ] TestIndicator.DesktopMprisPlayersPlaybackControls (14983 ms)
[ RUN ] TestIndicator.DesktopMprisPlayerButtonsState
pulseaudio(): Process [pulseaudio] for service [org.PulseAudio1] failed to appear on bus
/<<BUILDDIR>>/indicator-sound-12.10.2+17.10.20170829.1/tests/integration/test-indicator.cpp:1227: Failure
Expected: startPulseDesktop() doesn't throw an exception.
  Actual: it throws.
[ FAILED ] TestIndicator.DesktopMprisPlayerButtonsState (15010 ms)
[ RUN ] TestIndicator.DesktopChangeRoleVolume
pulseaudio(): Process [pulseaudio] for service [org.PulseAudio1] failed to appear on bus
/<<BUILDDIR>>/indicator-sound-12.10.2+17.10.20170829.1/tests/integration/test-indicator.cpp:1396: Failure
Expected: startPulseDesktop() doesn't throw an exception.
  Actual: it throws.
[ FAILED ] TestIndicator.DesktopChangeRoleVolume (15032 ms)
[----------] 10 tests from TestIndicator (152077 ms total)

[----------] Global test environment tear-down
[==========] 10 tests from 1 test case ran. (152097 ms total)
[ PASSED ] 0 tests.
[ FAILED ] 10 tests, listed below:
[ FAILED ] TestIndicator.PhoneCheckRootIcon
[ FAILED ] TestIndicator.PhoneTestExternalMicInOut
[ FAILED ] TestIndicator.DesktopTestExternalMicInOut
[ FAILED ] TestIndicator.PhoneBasicInitialVolume
[ FAILED ] TestIndicator.PhoneAddMprisPlayer
[ FAILED ] TestIndicator.DesktopBasicInitialVolume
[ FAILED ] TestIndicator.DesktopAddMprisPlayer
[ FAILED ] TestIndicator.DesktopMprisPlayersPlaybackControls
[ FAILED ] TestIndicator.DesktopMprisPlayerButtonsState
[ FAILED ] TestIndicator.DesktopChangeRoleVolume

10 FAILED TESTS
  YOU HAVE 8 DISABLED TESTS

Related branches

Khurshid Alam (khurshid-alam) wrote :

This is related pulseaudio not appearing on dbus. Not sure if this a problem in indicator-sound.

summary: - indicator-sound fails to build, test failures
+ [FTBFS] indicator-sound fails to build, test failures
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Simon Quigley (tsimonq2) wrote :

There is nothing for the Ubuntu Sponsors Team to act on at this moment. When there is, please resubscribe us.

Changed in indicator-sound (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+18.04.20180420.3-0ubuntu1

---------------
indicator-sound (12.10.2+18.04.20180420.3-0ubuntu1) bionic; urgency=medium

  * tests, integration: set environment variables to work headless (LP:
    #1737834)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 20 Apr 2018 21:44:30 +0000

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers