indicator-sound creates many syslog messages if accountsservice-ubuntu-schemas is not installed

Bug #1700680 reported by Leonardo Müller on 2017-06-27
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
indicator-sound (Ubuntu)
Undecided
Khurshid Alam

Bug Description

Hi

I am using Xubuntu 17.04 and I have noticed that every time I changed the volume or toggled mute,
a syslog messages appeared. As a result, changing the volume from a higher or lower value can make many messages appear on syslog. They look like:

Jun 26 23:01:39 usuario-Lenovo-ideapad-310-14ISK indicator-sound[20433]: accounts-service-access.vala:218: unable to sync volume 0,100000 to AccountsService: GDBus.Error:org.freedesktop.DBus.Error.InvalidArgs: Nenhuma interface “com.ubuntu.AccountsService.Sound”
Jun 26 23:01:39 usuario-Lenovo-ideapad-310-14ISK indicator-sound[20433]: accounts-service-access.vala:230: unable to sync mute false to AccountsService: GDBus.Error:org.freedesktop.DBus.Error.InvalidArgs: Nenhuma interface “com.ubuntu.AccountsService.Sound”

I have accountsservice installed, but hadn't accountsservice-ubuntu-schemas. Apparently, installing accountsservice-ubuntu-schemas and rebooting (I wasn't sure if I should restart pulseaudio or lightdm, so I rebooted) solved it.

As accountsservice-ubuntu-schemas apparently don't come installed on a default Xubuntu 17.04 installation, then this problem happens. Maybe accountsservice-ubuntu-schemas should be suggested, recommended or even be a dependency of indicator-sound?

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: indicator-sound 12.10.2+17.04.20170328.1-0ubuntu1
Uname: Linux 4.11.7-041107-generic x86_64
ApportVersion: 2.20.4-0ubuntu4.1
Architecture: amd64
CurrentDesktop: XFCE
Date: Mon Jun 26 23:20:09 2017
InstallationDate: Installed on 2017-06-13 (13 days ago)
InstallationMedia: Xubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
SourcePackage: indicator-sound
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Khurshid Alam (khurshid-alam) wrote :

Indicator-sound should have recommended accountsservice-ubuntu-schemas. I will make it optional in 18.10.

tags: added: artful bionic
Changed in indicator-sound (Ubuntu):
assignee: nobody → Khurshid Alam (khurshid-alam)
summary: - indicator-sound creates many syslog messages if accountsservice-ubuntu-
- schemas is not installed
+ [FFE] indicator-sound creates many syslog messages if accountsservice-
+ ubuntu-schemas is not installed

There is nothing for the Ubuntu Sponsors Team to act on at this moment. When there is, please resubscribe us.

tags: added: cosmic
removed: artful
summary: - [FFE] indicator-sound creates many syslog messages if accountsservice-
- ubuntu-schemas is not installed
+ indicator-sound creates many syslog messages if accountsservice-ubuntu-
+ schemas is not installed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+18.10.20180612-0ubuntu1

---------------
indicator-sound (12.10.2+18.10.20180612-0ubuntu1) cosmic; urgency=medium

  [ Khurshid Alam ]
  * Recommend accountsservice-ubuntu-schemas. (LP: #1700680)

 -- Simon Quigley <email address hidden> Tue, 12 Jun 2018 20:42:54 +0000

Changed in indicator-sound (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers