MPRIS controls don't reflect the current player state

Bug #1488569 reported by Jim Hodapp on 2015-08-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Alejandro J. Cura
Ubuntu UX
Critical
Jouni Helminen
indicator-sound (Ubuntu)
Critical
Xavi Garcia

Bug Description

The MPRIS controls (play/pause, next, previous) should reflect the current state of the current media player in media-hub. The following are what I would expect:

1. When media-hub reports that CanGoNext/Previous are false, the next and previous buttons in the indicator are disabled and visually greyed out or something to this effect.

2. The play button should show when media-hub reports that the current player is stopped or pause.

3. The pause button should show instead of the play button when media-hub reports that the current player is playing.

Related branches

Jim Hodapp (jhodapp) on 2015-08-25
Changed in indicator-sound (Ubuntu):
assignee: nobody → Xavi Garcia (xavi-garcia-mena)
Jim Hodapp (jhodapp) on 2015-09-11
Changed in indicator-sound (Ubuntu):
importance: Undecided → Critical
Changed in canonical-devices-system-image:
assignee: nobody → Alejandro J. Cura (alecu)
milestone: none → ww40-2015
importance: Undecided → Critical
John McAleely (john.mcaleely) wrote :

I understand the fixes for this bug belong in silo 55 for testing with the media-hub changes

John McAleely (john.mcaleely) wrote :

This bug blocks bug #1373313 from landing.

Xavi Garcia (xavi-garcia-mena) wrote :

Hi,

I've installed silo 055 and check the result with the new code of the indicator-sound from branch:
lp:~xavi-garcia-mena/indicator-sound/next-play-prev-buttons-bug-1373313

The code instead of setting the MPRIS controls by default reads the CanPlay, CanGoNext and CanGoPrevous properties.

The MPRIS player always return true to CanPlay, but returns always false for CanGoNext and CanGoPrevious, the result is obviously that the play control is the only only one showing as active.

I've also noticed that the player is not emiting any signal when the properties change.
The indicator-sound is subscribed to the PropertiesChanged signal with the following code:

/* Connecting to GDBusProxy's "g-properties-changed" signal here, because vala's dbus objects don't
    emit notify signals */
var gproxy = this.proxy as DBusProxy;
gproxy.g_properties_changed.connect (this.proxy_properties_changed);

To debug the code I'm listing all the properties that changed.
The method proxy_properties_changed is never called.

This works fine on the desktop, but not on the phone with silo 55.

Should we register to the signal in a different way? or should we consider the above issues as a bug?

In relation with the play/pause button: the desktop changes from the play to the pause button correctly with the current indicator-sound code, but not on the phone. (could this be a bug in the UI?)

We can maybe set a different value for the play property in the indicator menu, but as I said the PropertiesChanged signal is not working...

Changed in ubuntu-ux:
assignee: nobody → Jouni Helminen (jounihelminen)
importance: Undecided → Critical
status: New → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Changed in indicator-sound (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: New → In Progress
Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Alejandro J. Cura (alecu) wrote :

This needs to land together with the MPRIS silo, and it has been postponed to OTA-8.

Changed in canonical-devices-system-image:
milestone: ww40-2015 → ww46-2015
Jouni Helminen (jounihelminen) wrote :

Does't look like there is design input required. Let me know if otherwise

Changed in ubuntu-ux:
status: Triaged → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in indicator-sound (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers