Spurious volume notification when changing output role with headphones

Bug #1484589 reported by Matthew Paul Thomas on 2015-08-13
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Alejandro J. Cura
indicator-sound (Ubuntu)
Undecided
Xavi Garcia
indicator-sound (Ubuntu RTM)
Undecided
Unassigned

Bug Description

Ubuntu 15.04 r90

1. Install the "Maroon in Trouble" game.
2. With headphones connected, start a new game.
3. After a while, disconnect the headphones.

What happens:
2. There's a volume notification each time a sound plays.
3. There are no more volume notifications.

What should happen:
2. There are no volume notifications, because neither the sound output nor the volume is changing.

<https://wiki.ubuntu.com/Sound#notification>: "When the primary sound output changes for any reason except an app request, or when the sound volume changes for any reason, a confirmation bubble should appear ... There should be no special notification when the active output role changes."

This could be a side-effect of bug 1418210, but probably not, since it is idempotent: the notifications keep happening even if you don't change the volume in the meantime.

[Split off bug 1478506.]

Related branches

summary: - Changing audio output role shows a notification
+ Spurious volume notification when changing output role with headphones
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Changed in indicator-sound (Ubuntu):
assignee: nobody → Xavi Garcia (xavi-garcia-mena)
Xavi Garcia (xavi-garcia-mena) wrote :

I've fixed some changes to notify the user when the active output changes.... [bug 1382548]

What happens for the Marron game is what describes bug 1485522.
We have the notification because everytime we play a sound the audio role changes from the ringtone to multimedia.

Changed in indicator-sound (Ubuntu):
status: Confirmed → Fix Committed
Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Alejandro J. Cura (alecu)
milestone: none → ww46-2015
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
milestone: ww46-2015 → ww02-2016
Changed in canonical-devices-system-image:
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+16.04.20151103.2-0ubuntu1

---------------
indicator-sound (12.10.2+16.04.20151103.2-0ubuntu1) xenial; urgency=medium

  [ Xavi Garcia ]
  * Added OSD notifications to show output source when the volume or
    source change (LP: #1382548, LP: #1415480, LP: #1484589)

  [ CI Train Bot ]
  * New rebuild forced.

 -- Xavi Garcia <email address hidden> Tue, 03 Nov 2015 17:47:10 +0000

Changed in indicator-sound (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Released → Fix Committed
Changed in indicator-sound (Ubuntu):
status: Fix Released → In Progress
Changed in canonical-devices-system-image:
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pulseaudio (Ubuntu):
status: New → Confirmed
Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package indicator-sound 12.10.2+15.04.20151223-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

indicator-sound (12.10.2+15.04.20151223-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * No-change rebuild.

indicator-sound (12.10.2+16.04.20151222-0ubuntu1) xenial; urgency=medium

  [ Xavi Garcia Mena ]
  * Very simple change to make upstart try to respawn the process 30
    times (instead of 2). This is a workaround for the case when dbus
    session is not ready yet at startup.

  [ Timo Jyrinki ]
  * Note: this release was reverted on 20151223, ignore this changelog entry.

indicator-sound (12.10.2+16.04.20151103.2-0ubuntu1) xenial; urgency=medium

  [ Xavi Garcia ]
  * Added OSD notifications to show output source when the volume or
    source change (LP: #1382548, LP: #1415480, LP: #1484589)

  [ CI Train Bot ]
  * New rebuild forced.

  [ Timo Jyrinki ]
  * Note: this release was reverted on 20151223, ignore this changelog entry.

indicator-sound (12.10.2+15.10.20151019-0ubuntu1) wily; urgency=medium

  [ Xavi Garcia Mena ]
  * Wily branch for MPRIS controls (LP: #1373313)

indicator-sound (12.10.2+15.10.20150915-0ubuntu1) wily; urgency=medium

  [ Sebastien Bacher ]
  * under unity8 start system-settings instead unity-control-center (LP:
    #1489427)

  [ Xavi Garcia Mena ]
  * Merged lp:~xavi-garcia-mena/indicator-sound/icon-volume-zero

indicator-sound (12.10.2+15.10.20150812.3-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Charles Kerr ]
  * When showing a "Loud volumes can damage your hearing" confirmation
    warning, clamp the volume until the user hits "OK". (LP: #1481913)

indicator-sound (12.10.2+15.10.20150807.6-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Charles Kerr ]
  * Revised UI volume warnings to comply with EU requirements. (LP:
    #1481913)

indicator-sound (12.10.2+15.10.20150605-0ubuntu1) wily; urgency=medium

  *

indicator-sound (12.10.2+15.10.20150507+eventually4-0ubuntu1) wily; urgency=medium

  * Using eventually to avoid arbitrary timeouts in tests

indicator-sound (12.10.2+15.10.20150507-0ubuntu1) wily; urgency=medium

  [ Charles Kerr ]
  * Use the BusWatcher to look for org.freedesktop.Notifications
    ownership changes on the bus. (LP: #1432446)

 -- Xavi Garcia <email address hidden> Wed, 23 Dec 2015 12:54:33 +0000

Changed in indicator-sound (Ubuntu RTM):
status: New → Fix Released
no longer affects: pulseaudio (Ubuntu)
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Alejandro J. Cura (alecu) wrote :

This has not yet landed, the fix is being tested in silo 51.

Changed in canonical-devices-system-image:
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :
Download full text (3.8 KiB)

This bug was fixed in the package indicator-sound - 12.10.2+16.04.20160105.2-0ubuntu1

---------------
indicator-sound (12.10.2+16.04.20160105.2-0ubuntu1) xenial; urgency=medium

  [ Xavi Garcia Mena ]
  * Adds an action to signal the UI to sync the current volume when we
    are waiting for the user to confirm or reject the high volume
    notification. (LP: #1520548, #1512798)
  * This branch just readds the OSD notifications code, that was
    reverted in trunk as the corresponding silo was also rolled back
    after landing.
  * This branch re-adds the integration tests using gmenuharness. Added
    OSD notifications to show output source when the volume or source
    change (LP: #1382548, LP: #1415480, LP: #1484589) debian/control:
    Added the following build dependencies: cmake-extras (>= 0.4),
    google-mock (>= 1.6.0+svn437), libqtdbusmock1-dev (>= 0.3),
    libqtdbustest1-dev, libunity-api-dev, pulseaudio, qt5-default,
    qtbase5-dev, qtbase5-dev-tools, qtdeclarative5-dev, qtdeclarative5-
    dev-tools Added gmenuharness library for integration tests support.
    New Files: src/gmenuharness/CMakeLists.txt
    src/gmenuharness/MatchResult.cpp src/gmenuharness/MatchUtils.cpp
    src/gmenuharness/MenuItemMatcher.cpp
    src/gmenuharness/MenuMatcher.cpp
    include/unity/gmenuharness/MatchResult.h
    include/unity/gmenuharness/MatchUtils.h
    include/unity/gmenuharness/MenuItemMatcher.h
    include/unity/gmenuharness/MenuMatcher.h Added integration tests
    using gmenuharness New Files: tests/dbus-types/CMakeLists.txt
    tests/dbus-types/com.ubuntu.AccountsService.Sound.xml tests/dbus-
    types/dbus-types.h tests/dbus-
    types/org.PulseAudio.Ext.StreamRestore1.xml tests/dbus-
    types/org.freedesktop.Accounts.xml tests/dbus-
    types/org.freedesktop.DBus.Properties.xml tests/dbus-
    types/org.freedesktop.Notifications.xml tests/dbus-
    types/org.gtk.Actions.xml tests/dbus-types/pulseaudio-volume.cpp
    tests/dbus-types/pulseaudio-volume.h
    tests/integration/CMakeLists.txt tests/integration/indicator-sound-
    test-base.cpp tests/integration/indicator-sound-test-base.h
    tests/integration/main.cpp tests/integration/test-indicator.cpp
    tests/integration/touch-stream-restore.table
    tests/integration/utils/dbus-pulse-volume.cpp
    tests/integration/utils/dbus-pulse-volume.h
    tests/integration/utils/get-volume.cpp tests/integration/utils/set-
    volume.cpp tests/service-mocks/CMakeLists.txt tests/service-
    mocks/DBusPropertiesNotifier.cpp tests/service-
    mocks/DBusPropertiesNotifier.h tests/service-mocks/accounts-
    mock/AccountsDefs.h tests/service-mocks/accounts-
    mock/AccountsMock.cpp tests/service-mocks/accounts-
    mock/AccountsMock.h tests/service-mocks/accounts-
    mock/AccountsServiceSoundMock.cpp tests/service-mocks/accounts-
    mock/AccountsServiceSoundMock.h tests/service-mocks/accounts-
    mock/CMakeLists.txt tests/service-mocks/accounts-
    mock/com.ubuntu.AccountsService.Sound.Mock.xml tests/service-
    mocks/accounts-mock/main.cpp tests/service-mocks/accounts-
    mock/org.freedesktop.Accounts.Mock.xml tests/service-mocks/media-
    player-mpris-mock/CMakeLists.txt tests/ser...

Read more...

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers