Indicator shouldn't set volume on pulse/account service if the volume didn't change

Bug #1443005 reported by Ricardo Salveti on 2015-04-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
indicator-sound (Ubuntu)
Medium
Ricardo Salveti

Bug Description

current build number: 168
device name: mako
channel: ubuntu-touch/devel-proposed
alias: ubuntu-touch/vivid-proposed
last update: 2015-04-12 03:49:09
version version: 168
version ubuntu: 20150411
version device: 20150210
version custom: 20150411

This is a regression from RTM.

The current logic doesn't check for the volume value before calling pulseaudio and account service when updating the volume variable. The consequence is that it will set the volume at least twice after you change it, since it will get a callback from account service, and that will result in another volume set with the exact same volume.

Related branches

Charles Kerr (charlesk) on 2015-04-13
Changed in indicator-sound (Ubuntu):
status: New → In Progress
assignee: nobody → Ricardo Salveti (rsalveti)
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+15.04.20150413-0ubuntu1

---------------
indicator-sound (12.10.2+15.04.20150413-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Ricardo Salveti de Araujo ]
  * volume-control-pulse: only set volume if value is indeed different
    and reason not from AS (LP: #1443005)

  [ Ted Gould ]
  * Fix stream property lookup to reliably signal multimedia streams
    (LP: #1436021)
 -- CI Train Bot <email address hidden> Mon, 13 Apr 2015 06:02:32 +0000

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers