No indicator-sound sometimes after switching language

Bug #1432689 reported by Andrew Hayzen on 2015-03-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
indicator-sound (Ubuntu)
High
Xavi Garcia
indicator-sound (Ubuntu RTM)
Undecided
Unassigned

Bug Description

Sometimes the indicator-sound does not start correctly (only a 'gear' if you expand the notification bar and no 'speaker' icon), this was found while testing changing language for the music-app and it should be noted that in the instance where the indicator didn't start I couldn't also play and audio.

Steps:
1) Start phone, note if the indicator-sound has started correct (with an icon)
2) Open system-settings->Language & Text->Display language
3) Change the language to something else (I cycled through EN, ES, FR) and accept the reboot
4) Upon reboot go back to step 1 until the indicator starts incorrectly (usually happens within 5-10 boots for me)

When the issue occurred this was in my indicator-sound.log
(process:2761): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
indicator-sound stop/pre-start, process 3380

$ system-image-cli -i
current build number: 214
device name: mako
channel: ubuntu-touch/ubuntu-rtm/devel-proposed
alias: ubuntu-touch/ubuntu-rtm/14.09-proposed
last update: 2015-03-12 01:42:23
version version: 214
version ubuntu: 20150312
version device: 20150116
version custom: mako-1.1

Related branches

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Pete Woods (pete-woods) wrote :

Sounds a bit like the HUD bug where Upstart wasn't setting the DBus session environment variables after resume.

We put the errors in this bucket via a recoverable error (and grabbed the dbus values ourselves), and it was fixed in Upstart after 14.04.

https://errors.ubuntu.com/bucket/?id=DBusSessionAddressNotSet

I'd be interested to see if the same or a similar thing is happening here.

Changed in indicator-sound (Ubuntu):
importance: Undecided → High
assignee: nobody → Xavi Garcia (xavi-garcia-mena)
Changed in canonical-devices-system-image:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Alejandro J. Cura (alecu)
milestone: none → ww02-2016
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in indicator-sound (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
milestone: ww02-2016 → ww08-2016
Xavi Garcia (xavi-garcia-mena) wrote :

The following branch landed in vivid and xenial a few days ago.
https://code.launchpad.net/~xavi-garcia-mena/indicator-sound/readd-respawn-upstart

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Committed
Pat McGowan (pat-mcgowan) wrote :

Landed 1/14

Changed in canonical-devices-system-image:
milestone: ww08-2016 → ww02-2016
status: In Progress → Fix Committed
Changed in indicator-sound (Ubuntu RTM):
status: New → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Changed in indicator-sound (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers