indicator-sound-service crashed with signal 5 in indicator_sound_service_construct()

Bug #1432446 reported by Joseph Ronne on 2015-03-15
74
This bug affects 7 people
Affects Status Importance Assigned to Milestone
indicator-sound (Ubuntu)
Medium
Charles Kerr
Vivid
Undecided
Unassigned

Bug Description

At log in white screen .. mouse click and then this request

ProblemType: Crash
DistroRelease: Ubuntu 15.04
Package: indicator-sound 12.10.2+15.04.20150311-0ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-9.9-lowlatency 3.19.1
Uname: Linux 3.19.0-9-lowlatency x86_64
ApportVersion: 2.16.2-0ubuntu3
Architecture: amd64
CrashCounter: 1
Date: Sun Mar 15 18:39:06 2015
ExecutablePath: /usr/lib/x86_64-linux-gnu/indicator-sound/indicator-sound-service
InstallationDate: Installed on 2015-02-13 (30 days ago)
InstallationMedia: Ubuntu-Studio 15.04 "Vivid Vervet" - Alpha amd64 (20150213)
ProcCmdline: /usr/lib/x86_64-linux-gnu/indicator-sound/indicator-sound-service
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/false
Signal: 5
SourcePackage: indicator-sound
StacktraceTop:
 indicator_sound_service_construct ()
 _start ()
Title: indicator-sound-service crashed with signal 5 in indicator_sound_service_construct()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

Joseph Ronne (jfronne) wrote :

StacktraceTop:
 indicator_sound_service_construct (object_type=140503298484064, playerlist=0x1ddfcc0, volume=0x7fc964008660, accounts=0x0) at /build/buildd/indicator-sound-12.10.2+15.04.20150311/obj-x86_64-linux-gnu/src/service.c:728
 indicator_sound_service_new (playerlist=playerlist@entry=0x1ddfcc0, volume=volume@entry=0x7fc964008660, accounts=accounts@entry=0x0) at /build/buildd/indicator-sound-12.10.2+15.04.20150311/obj-x86_64-linux-gnu/src/service.c:882
 on_bus_acquired (connection=<optimized out>, name=<optimized out>, user_data=<optimized out>) at /build/buildd/indicator-sound-12.10.2+15.04.20150311/src/main.c:62
 connection_get_cb (source_object=<optimized out>, res=0x1de1420, user_data=0x1de0400) at /build/buildd/glib2.0-2.43.91/./gio/gdbusnameowning.c:480
 g_simple_async_result_complete (simple=0x1de1420) at /build/buildd/glib2.0-2.43.91/./gio/gsimpleasyncresult.c:763

Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Matthew Paul Thomas (mpt) wrote :

Is there any reason for this bug report to be private?

Charles Kerr (charlesk) wrote :

Doesn't look like it -- I don't see anything sensitive in the crash attachments.

information type: Private → Public
summary: - Login after startup
+ indicator-sound-service crashed with signal 5 in
+ indicator_sound_service_construct()
Sebastien Bacher (seb128) wrote :

https://errors.ubuntu.com/problem/b200c67dc8b4d749da796ad4c670ce350e127b26 seems to indicated in started with 12.10.2+15.04.20150311-0ubuntu1

Charles Kerr (charlesk) on 2015-04-13
Changed in indicator-sound (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
Charles Kerr (charlesk) on 2015-04-20
Changed in indicator-sound (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+15.10.20150507-0ubuntu1

---------------
indicator-sound (12.10.2+15.10.20150507-0ubuntu1) wily; urgency=medium

  [ Charles Kerr ]
  * Use the BusWatcher to look for org.freedesktop.Notifications
    ownership changes on the bus. (LP: #1432446)

indicator-sound (12.10.2+15.04.20150421-0ubuntu1) vivid; urgency=medium

  [ Ted Gould ]
  * Always record the volume whether we do something with it or not (LP:
    #1446703) (LP: #1446703)

 -- CI Train Bot <email address hidden> Thu, 07 May 2015 15:27:00 +0000

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu Vivid):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers