wrong notification progress reported if volume >100% enabled in pulseaudio

Bug #1422745 reported by Didier Roche on 2015-02-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
indicator-sound (Ubuntu)
Medium
Unassigned

Bug Description

When using the option to use the volume above 100%, indicator-sounds interferes with the percentage reported in notify-osd:
- enable in pulseaudio capplet for allow volume being above 100%
- press volume up or down medium keys
- notice that the progress reported by notify-osd isn't the correct one compared to the capplet. Also, there is a glitch (like notification progress bar going back and force)

-> stop indicator-sound, the progress reported is correct, and the glitch is gone as well.
So, there are 2 updates occuring in a short period of time:
- the one from unity-settings-daemon
- the one from the indicator-sound, which doesn't send the correct value.

Another consequence is if you are using the indicator and slide the volume bar, you have the notification showing on top, making it hard to see what volume you are setting it. Moving the slider is already a visual user confirmation, you shouldn't get a notification on top.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: indicator-sound 12.10.2+15.04.20150205-0ubuntu1
ProcVersionSignature: Ubuntu 3.18.0-13.14-generic 3.18.5
Uname: Linux 3.18.0-13-generic x86_64
ApportVersion: 2.16.1-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Feb 17 15:18:19 2015
EcryptfsInUse: Yes
InstallationDate: Installed on 2012-05-28 (995 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
SourcePackage: indicator-sound
UpgradeStatus: Upgraded to vivid on 2014-10-31 (109 days ago)

Related branches

Didier Roche (didrocks) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
Ted Gould (ted) wrote :

This should be better with the newer version of indicator-sound, which only shows notifications on user feedback. Unfortunately don't have a vivid desktop to test for sure. Can you please update with the results for 0219 ? Thanks.

Changed in indicator-sound (Ubuntu):
status: Confirmed → Incomplete
Didier Roche (didrocks) wrote :

It's partially fixed.

This works now when using media keys for volume up and down (the reported value by the notification is the correct one). It is not fixed when using indicator-sound itself:
- there is still the notification spam
- this one is offset between the notification report and indicator sound slider

Changed in indicator-sound (Ubuntu):
status: Incomplete → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+15.04.20150227.1-0ubuntu1

---------------
indicator-sound (12.10.2+15.04.20150227.1-0ubuntu1) vivid; urgency=medium

  [ Martin Wimpress ]
  * Add support for settings on the MATE Desktop.

  [ Ted Gould ]
  * Check stream when looking at high volume (LP: #1418032)
  * Switch to an internal variable to track blocking notifications
  * Use max volume in calculating notification value (LP: #1422745)
 -- CI Train Bot <email address hidden> Fri, 27 Feb 2015 22:36:34 +0000

Changed in indicator-sound (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers