When "Allow louder than 100%" is checked, sound volume NotifyOSD shows the gauge only up to 100%

Bug #1293163 reported by Doctor Rover on 2014-03-16
34
This bug affects 8 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
Medium
Lars Karlitski
indicator-sound (Ubuntu)
Medium
Unassigned

Bug Description

When "Allow louder than 100%" box is checked in sound system settings, change of the sound volume by the mouse wheel over the sound indicator leads to the gauge in the NotifyOSD showing the volume level only up to 100%. That is, the maximum value of the gauge in the NotifyOSD corresponds to 100% and further change of the volume louder than 100% does not modify the gauge state. At the same time, the gauge in the sound indicator drop-down menu shows the volume correctly, i.e. the maximum value of the gauge in the drop-down corresponds to the actual maximum volume "louder than 100%" and 100% is somewhere in the middle. The same behaviour is expected for the gauge in the NotifyOSD.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: indicator-sound 12.10.2+14.04.20140313-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-17.37-generic 3.13.6
Uname: Linux 3.13.0-17-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Mar 16 20:15:28 2014
InstallationDate: Installed on 2014-01-27 (48 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140124)
SourcePackage: indicator-sound
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Doctor Rover (doctor-rover) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Lars Karlitski (larsu) wrote :

True. Thanks for reporting this!

no longer affects: notify-osd (Ubuntu)
Changed in indicator-sound:
status: New → Incomplete
status: Incomplete → In Progress
assignee: nobody → Lars Uebernickel (larsu)
importance: Undecided → Medium
Changed in indicator-sound (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+14.04.20140320-0ubuntu1

---------------
indicator-sound (12.10.2+14.04.20140320-0ubuntu1) trusty; urgency=low

  [ Lars Uebernickel ]
  * Scale volume in notifications when allow-amplified-volume is set
    (LP: #1293163)
  * Use audio-volume-mute-blocking-panel instead of *-blocked-panel
 -- Ubuntu daily release <email address hidden> Thu, 20 Mar 2014 08:58:30 +0000

Changed in indicator-sound (Ubuntu):
status: Confirmed → Fix Released
Doctor Rover (doctor-rover) wrote :

I confirm, the issue is solved. Lars, thank you!

Charles Kerr (charlesk) on 2014-03-21
Changed in indicator-sound:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers