Using volume buttons on phone triggers spurious popup

Bug #1236292 reported by Alan Pope 🍺🐧🐱 🦄 on 2013-10-07
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
High
Lars Karlitski
indicator-sound (Ubuntu)
High
Lars Karlitski
unity8 (Ubuntu)
High
Lars Karlitski

Bug Description

Flashed mako with image #82. Press volume rocker, get a popup with no image and just the text 'indicator-sound'. See screenshot.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-sound (Ubuntu):
status: New → Confirmed
Dave Morley (davmor2) wrote :

Happens on maguro too

Lars Karlitski (larsu) wrote :

This happens because unity8 doesn't support synchronous notifications in the way that notify-osd does on the desktop. It's not clear yet whether it will ever gain that. Maybe it'll grow a different API that is private to system components.

Until then, it's probably best to just disable the notification in indicator-sound.

Changed in indicator-sound:
importance: Undecided → High
assignee: nobody → Lars Uebernickel (larsu)
kevin gunn (kgunn72) wrote :

macslow - this might be one to try to get in soon, seems expectation is to disable the notif until there is some better design?

Changed in unity8:
assignee: nobody → Mirco Müller (macslow)
importance: Undecided → High
status: New → Triaged
Loïc Minier (lool) wrote :

So you'd just disable them on touch in some way?

Mirco Müller (macslow) wrote :

There is no visual/UX-design for confirmation (aka sychnonous) notifications on UbuntuTouch... and I don't know if they are meant to be added in the future.

As of rev385 of lp:indicator-sound the triggering of a confirmation notification was added. The lowest impact work-around I can currently think of is to make lp:unity-notifications (the new notification-backend) silently swallow such notifications without adding them to the queue, thus not making them display at all under unity8.

Thoughts?

Sebastien Bacher (seb128) wrote :

It's a side effect of the "scroll over the indicator should display a notification" regression-fix on the desktop; Lars is working on making the action quiet on the phone profile, a bit of patience the fix should be up for review soon (when it's going to land is another story since the mergers are stopped)

Changed in indicator-sound (Ubuntu):
assignee: nobody → Lars Uebernickel (larsu)
importance: Undecided → High
status: Confirmed → In Progress
Changed in unity8:
status: Triaged → Invalid
Changed in indicator-sound:
status: New → In Progress
Lars Karlitski (larsu) on 2013-10-10
Changed in unity8:
status: Invalid → In Progress
assignee: Mirco Müller (macslow) → Lars Uebernickel (larsu)
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-sound at revision 389, scheduled for release in indicator-sound, milestone 0.5.6

Changed in indicator-sound:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+13.10.20131011-0ubuntu1

---------------
indicator-sound (12.10.2+13.10.20131011-0ubuntu1) saucy; urgency=low

  [ Lars Uebernickel ]
  * Allow activating the 'volume' action It does the same as the
    'scroll' action except showing a notification. (LP: #1236292)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 389
 -- Ubuntu daily release <email address hidden> Fri, 11 Oct 2013 04:27:50 +0000

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2013-10-11
Changed in unity8:
status: In Progress → Fix Released
Changed in indicator-sound:
status: Fix Committed → Fix Released
tags: added: doesnt-need-test
Michał Sawicz (saviq) on 2017-03-13
affects: unity8 → unity8 (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers