[Dell Inspiron 1720] System does not power off reliably when "Shut Down" chosen from GUI

Bug #987220 reported by Mark Schneider on 2012-04-23
This bug affects 350 people
Affects Status Importance Assigned to Milestone
Session Menu
Invalid
Undecided
Unassigned
Debian
New
Undecided
Unassigned
gnome-session (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
indicator-session (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
upstart (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

Shutting down the computer using the menue does not work always correct. It often does not complete turn off the computer. The power LED and the LED of the bluetooth unit remain on. Also the fan is still running and won't stop.
Shutting down the computer with "sudo shutdown -h now" using the terminal works fine.

I am using a Dell Inspiron 1720.

Mark Schneider (mc-monti) wrote :
Bilal Akhtar (bilalakhtar) wrote :

Does this always happen? This might be hardware related, I guess.

Changed in indicator-session (Ubuntu):
status: New → Incomplete
Mark Schneider (mc-monti) wrote :

As far as I remember it never did a complete shutdown. I always need to push the power button a long time to really turn off the notebook.

Mark Schneider (mc-monti) wrote :

I made a complete reinstall of the system just to make sure that nothing messed up during the update process from 10.04 LTS to 12.04 LTS. But the behaviour is still the same, no complete shutdown in 12.04.

Mark Schneider (mc-monti) wrote :

Some additional informations:
If I shutdown my notebook right after booting it does make a complete shutdown. It seems like the longer I wait and work with it the higher are chances for a failure. I really tried to make it reproducible without success for now.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-session (Ubuntu):
status: New → Confirmed
Changed in upstart (Ubuntu):
status: New → Confirmed
1 comments hidden view all 209 comments
j-stuffer (j-stuffer) wrote :

Same here. I don't always encounter the problem, but I think the longer the Laptop runs, the chances are bigger that it won't shut down.
Dell Studio 1558. Ubuntu 12.04 64 Bit. Fresh install. As far as I can remember I didn't have the problem in 10.04 and it started after I made an upgrade to 10.11 or 11.04 - but I'm not 100% sure. I thought a fresh install could solve it, but no success.

Mark Schneider (mc-monti) wrote :

I found out that a shutdown using the terminal is not always working correct. I started using it constantly today and already the second time I used it happened the failure.

Photon (michael-kogan) wrote :

Same problem with Xubuntu Precise. Using fglrx. The problem is not reproducible though, it appears sporadically.

James Hunt (jamesodhunt) wrote :

This problem sounds like it could be kernel issue.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 987220

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Same Problem on a Lenovo T61P. System also freese by closing the cover. Ubuntu 12.04 with nvidia card.

Manuel (manuel-kuederli) wrote :

Same with hp notebook 2510p. No shutdown possible. It returns always to login window

Changed in indicator-session (Ubuntu):
status: Incomplete → Confirmed
Maik (voody13) wrote :

I have the same problem. I had 11.10 installed, updated to 12.04 and now I'm not able to shut down the system any more. The "ubuntu-screen" appears and nothing more happens everytime I try to shutdown. I also can't get my network card working. So I installed 12.04 complely new to ensure it was not a problem of the update and got the same results. With 11.10 and Win7 everything is working fine.
(System: Desktop "MSI Hetis 945-E", Intel E4500 64bit, 4GB Ram, Win7 64bit, 12.04 64bit (before: 11.10 64bit))

The same for me with XUbuntu 12.04 on 3 different systems (Dell, Asus-Notebook and self build system).

Sometime it works with command: shutdown now -h
It never works with command: halt

Photon (michael-kogan) wrote :

I encountered the problem on another system. Both systems using fglrx, the first time that the problem appeared was right after the installation of fglrx.

j-stuffer (j-stuffer) wrote :

I also think that fglrx could be the reason. (fglrx is the proprietary driver from ATI, right?)
I removed the driver and I had no problem with the shutdown. But as soon as I installed it again, I wasn't able to shut down again.

But I only started / shut down the laptop about 5 times without fxglr, as I usually use my desktop and also not using fglrx works not very well for me as:
1.) fan runs a lot more
2.) battery runs a lot less longer
3.) I can't switch users

Bilal Akhtar (bilalakhtar) wrote :

Seems like an issue with Upstart.

Changed in gnome-session (Ubuntu):
status: Confirmed → Incomplete
Changed in indicator-session (Ubuntu):
status: Confirmed → Incomplete
Changed in indicator-session:
status: New → Incomplete
Mark Schneider (mc-monti) wrote :

I am afraid that different incidents are mixed together here. As far as I understand in some cases the system remains in the process of shutdown. In other cases the shutdown of the operating system seems to work except the very last step of turning off the hardware.

Andre (ajx) wrote :

I really wonder why people post comments stating they "are affected too", and don't click on "Does this bug affect you?" at the top of the page. Only stating that you are "affected too" this way will draw more attention to this bug. I've counted 6 comments, but only 4 votes.

I'm experiencing the problem occasionally on Lenovo Thinkpad X220. The system basically goes to halt, but doesn't switch off the laptop. I have to long-press the power button to switch it off. During the next reboot, I don't get a filesystem check - what makes me think that it was umounted properly.

In what log files can I check what the problem is? And what to look for?

Andre (ajx) wrote :

I experienced the problem now also on another machine which I tried to shutdown via "sudo halt". Shutdown seemed to be OK, but the PC (desktop) was not switched off. I didn't experience this problem on Oneiric. It was introduced after the upgrade to Precise Pangolin.

Mark Schneider (mc-monti) wrote :

I noticed something in the past days. If I click shutdown the screen normaly turns black very fast. It does not show "Ubuntu" with the four dots, and at the end of the process I have to turn off the computer by pressing the power button a long time.
The few times I see the screen with Ubuntu and the four dots the shutdown works fine.

Andre (ajx) wrote :

I can see the dots moving. However, they keep on moving, but the device is not turned off.

Mark Schneider (mc-monti) wrote :

I also found out that after some time of using Ubuntu I can't switch to a terminal session anymore. Using Strg-Alt-F2 for example does not work after a while. The screen turns black and that's it. Pressing Strg-Alt-F7 brings me back to Unity again.
The shutdown works fine as long I can switch to a terminal. If I can't the shutdown does not work either.

Andre (ajx) wrote :

That's a very intersting observation, Mark. Thanks! I'll keep an eye on that, i.e. check if I can jump to another TTY before I shutdown.

On my laptop (Lenovo X220) I have noticed that the indicator lights (LEDs) for wifi and power(!) turn off, while the screen stays on. Marks observation plus this one points in the direction of problems with the graphics driver. My graphics card is Intel. Should be a GMA 3000. lspci says:

VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

I have Dell Inspiron 1520 and Ubuntu 12.04 fresh install, and it also doesn't completely turns off. Have to force the shutdown by holding the on button.

Vova U (uwl) wrote :

it's not only a notebbok related issue i see the similar behavior on MSI H61M-P22(B3) mainboard. The the screen will be turned off but the CPU fan will be slowed but never going off. I tested this with booting from Ubuntu 12.04 distribution DVD and and Try Ubuntu. Both power off just after start and power off after 30 min playing with firefox and libreoffice just powering the system off completely. Probably some regression during recent updates?

rsw@americamail.com (rsw) wrote :

Using a Dell D530 with NVIDIA graphics card. Same problem and any solutions I have tried have been infrequent.

Mark Schneider (mc-monti) wrote :

Is anybody experiencing the same problem with Kubuntu 12.04?

Lalatendu Mohanty (then4way) wrote :

I have the same issue in my Dell 12.04 . But I have observed that if I turn off the wireless and then shutdown , it works fine. Also "sudo poweroff" also works for me.

I have installed "firmware-b43-lpphy-installer" for my Wireless card as its Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] card

anders (anderspn) wrote :

I have the same problem on my Dell Inspiron 1720. Everything appears to shut down except the fan and leds which stay on.
Also I have noticed problems with the wireless network.
If I turn on my wireless router after Ubuntu has started the network newer connects. The workaround is to disable and
reenable the network.

Steve Langasek (vorlon) wrote :

> Sometime it works with command: shutdown now -h
> It never works with command: halt

That refers to bug #880240, which is not the bug reported by the submitter. The 'halt' command does not do what people assume it does. You need to call either 'shutdown -h now', or 'poweroff', or 'halt -p'.

The bug here is with the system not shutting down when shut down from the GUI - that's not at all due to a user calling the wrong command from the commandline. Perhaps the GUI makes the same wrong assumption and calls 'halt' when it should not, or perhaps there's a hardware-specific issue with the poweroff handling. (This would not be the first time that had happened, but most such problems were long ago with a much less mature kernel.)

summary: - no complete shutdown
+ System does not power off reliably when "Shut Down" chosen from GUI

indicator-session calls the consolekit shutdown interface, which uses '/usr/lib/ConsoleKit/scripts/ck-system-stop', which calls 'shutdown -h now'. So it doesn't look like there's any indicator-session bug here.

Changed in upstart (Ubuntu):
status: Confirmed → Invalid
plum7500 (plum01) wrote :

Shutdown using menu is working for me but using the terminal does not. If I do

sudo shutdown -h 2:00

to shutdown at 2am, it hangs. Another thread said that it does not happen if root user is used. I'll post later if root is able to do it successfully.

Steve Langasek (vorlon) on 2012-06-12
Changed in indicator-session (Ubuntu):
status: Incomplete → Invalid
Changed in gnome-session (Ubuntu Precise):
status: New → Incomplete
Changed in indicator-session (Ubuntu Precise):
status: New → Invalid
Changed in linux (Ubuntu Precise):
status: New → Confirmed
Changed in upstart (Ubuntu Precise):
status: New → Invalid
anders (anderspn) wrote :

I can confirm that changing to the virtual terminal also stops working. This may be caused by the binary nvidia driver for
the GeForce 8600M GT graphics card in my PC. I am currently using version 295.49 of the driver but both installed
drivers have the fault. I have used Ubuntu on this PC for several years without this problem so this bug was
introduced with 12.04.

I have tried "$ sudo poweroff" from a terminal and it fails. Shutdown from an remote ssh login also fails. Currently I do not have
any safe way to shut down the system.

Photon (michael-kogan) wrote :

It is surely not related to gnome-session, since the problem also appears on Xubuntu Precise.

Changed in gnome-session (Ubuntu):
status: Incomplete → Invalid
Changed in gnome-session (Ubuntu Precise):
status: Incomplete → Invalid

I also have a GeForce 8600 GT. I recently reverted to version 290.10 of nvidia's binary driver because of Bug #973096 (random Xorg crashes.)

The reversion also seems to have solved my problems powering off the system and changing to tty. It might be a coincidence, though.

tags: added: running-unity
description: updated
Charles Kerr (charlesk) on 2012-11-01
Changed in indicator-session:
status: Incomplete → Invalid
Changed in linux (Ubuntu):
assignee: nobody → davos pessos (davospessos)
status: Confirmed → In Progress
Karma Dorje (taaroa) on 2012-12-05
Changed in linux (Ubuntu):
status: In Progress → Confirmed
assignee: davos pessos (davospessos) → nobody
todaioan (alan-ar06) on 2012-12-28
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Changed in linux (Ubuntu Precise):
status: Confirmed → Fix Released
Karma Dorje (taaroa) on 2012-12-28
Changed in linux (Ubuntu):
status: Fix Committed → Confirmed
Changed in linux (Ubuntu Precise):
assignee: nobody → Karma Dorje (taaroa)
assignee: Karma Dorje (taaroa) → nobody
129 comments hidden view all 209 comments
Stefanbowe (stephan-bowe) wrote :

After sleeping a night over what I‘ve read so far, I had the following idea. We might have a race condition here. In this case it would many strange things seem plausible:
 that it doesn’t happen on every shutdown
that acpi=force works on some machines
that removing the nvidia-driver works somtimes
 and so on.

Maybe someone with deeper knowledge than mine can suggest a smart spot inside the shutdown scripts to put a ‘sleep 1‘ (or similar)?

Adolfo Jayme (fitojb) wrote :

Please don't mess with bug statuses.

Changed in linux (Ubuntu Precise):
status: Fix Released → Confirmed

I didn't

regards

Nick Sharp

On 07/01/13 14:49, Adolfo Jayme Barrientos wrote:
> Please don't mess with bug statuses.
>
> ** Changed in: linux (Ubuntu Precise)
> Status: Fix Released => Confirmed
>

--
Nick Sharp
eMl: <email address hidden>
Add: 77 Brighton Street
         Curl Curl
         NSW 2096
         Australia
Tel: +61 2 9938 3459
Mob: +61 413 948 375

Had the same "not shutting down" problem, fan continued to run.
I removed the graphics driver $ sudo apt-get purge nvidia*
Then installed the non-experimental one in "additional drivers" through the software center.
No problems since.

AMD FX(tm)-4100 Quad-Core Processor × 4
VGA compatible controller: NVIDIA Corporation GT218 [GeForce 8400 GS] (rev a2)

Jordan H (the-jman) wrote :

Also confirmed to happen on 12.04 Server with Supermicro X9DRW-iF motherboard. Hangs during reboot until you power cycle. CentOS works normally on these motherboards.

razor (razorxpress) wrote :

It affects 12.04 on dell inspiron n4110 too.

I changed the GUI from unitiy to gnome classic (no effects) and that fixed
the problem... Has anyone had the same experience?

Laptop SAMSUNG R540
Graphics VESA M92

2013/2/1 razor <email address hidden>

> It affects 12.04 on dell inspiron n4110 too.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/987220
>
> Title:
> System does not power off reliably when "Shut Down" chosen from GUI
>
> Status in The Session Menu:
> Invalid
> Status in “gnome-session” package in Ubuntu:
> Invalid
> Status in “indicator-session” package in Ubuntu:
> Invalid
> Status in “linux” package in Ubuntu:
> Confirmed
> Status in “upstart” package in Ubuntu:
> Invalid
> Status in “gnome-session” source package in Precise:
> Invalid
> Status in “indicator-session” source package in Precise:
> Invalid
> Status in “linux” source package in Precise:
> Confirmed
> Status in “upstart” source package in Precise:
> Invalid
>
> Bug description:
> Shutting down the computer using the menue does not work always correct.
> It often does not complete turn off the computer. The power LED and the LED
> of the bluetooth unit remain on. Also the fan is still running and won't
> stop.
> Shutting down the computer with "sudo shutdown -h now" using the
> terminal works fine.
>
> I am using a Dell Inspiron 1720.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: indicator-session 0.3.96-0ubuntu1
> ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
> Uname: Linux 3.2.0-23-generic i686
> NonfreeKernelModules: nvidia
> ApportVersion: 2.0.1-0ubuntu5
> Architecture: i386
> Date: Mon Apr 23 12:26:10 2012
> ExecutablePath: /usr/lib/indicator-session/gtk-logout-helper
> InstallationMedia: Kubuntu 10.04.1 LTS "Lucid Lynx" - Release i386
> (20100816.2)
> ProcEnviron:
> SHELL=/bin/bash
> PATH=(custom, no user)
> LANG=de_DE.UTF-8
> SourcePackage: indicator-session
> UpgradeStatus: Upgraded to precise on 2012-04-21 (1 days ago)
> ---
> ApportVersion: 2.0.1-0ubuntu7
> Architecture: i386
> DistroRelease: Ubuntu 12.04
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386
> (20120423)
> NonfreeKernelModules: nvidia
> Package: upstart
> PackageArchitecture: all
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 3.2.0-24.37-generic-pae 3.2.14
> Tags: precise
> Uname: Linux 3.2.0-24-generic-pae i686
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/indicator-session/+bug/987220/+subscriptions
>

Ken Sharp (kennybobs) wrote :

Yes, the problem is removed when you remove Unity. The logs show a
permissions problem of some sort.

I switched to KDE (Unity had not been removed, just not in use) and have
not been suffering from the issue since.

So far this seems to have affected multiple users, multiple kernels and a
broad range of hardware. The only common denominators thus far, seem to be
Unity and either the nVidia driver or fglrx.

My Computers (see post above) are both running KDE (ever since). One of the Computers (Toshiba) does not have a nvidia card.

I've been suffering from this issue almost at every shutdown since I installed Ubuntu (first 12.04 then 12.10), it disappeared when I switched to KDE a couple of weeks ago. The more the system is used, the more likely is the issue to happen, but I was never been able to reproduce it systematically. I have an ATI Radeon HD 3600 and fglrx-legacy 8.97.100.7.

J T (jackt-d) wrote :

Like above (Fabrizio) - the longer i work, the bigger probability of shutdown problem. IT IS NOT A HARDWARE ISSUE, because the parallel system (zubuntu based on 10.04) always shuts down correctly.

Stefanbowe (stephan-bowe) wrote :

I agree that it the cause does not seem to be a hardware issue. However, the result is a hardware issue in my case: Every time that I don’t realize that my laptop doesn‘t turn off, my battery runs empty. This decreases its capacity and lifetime.

Skilly (michael-scheepers) wrote :

Same problem as described in this thread.

My hardware is Dell XPS12

Stefanbowe (stephan-bowe) wrote :

Hi, on one laptop (Lenovo T61w) switching to the nouveau-driver helped! All shutdowns completed successfully since then. The other laptop (Toshiba sattelite) has no NVIDIA-Card, so I am looking for another solution for it.

anders (anderspn) wrote :

My Labtop still hangs If i do a shutdown from unity. However I have found a workaround which is to chose logout and then select shutdown from the login screen. This works every time.

Seems like something breaks after running unity for some time, but it gets reset when the X server is restarted by doing a logout.

Orosz Gyozo (oroszgyozo) wrote :

"Solved" the problem by removing the NVIDIA drivers and using nouveau instead .... :(
( Xubuntu 12.04 )

Patrick den Ouden (inf5) wrote :

Same problem on Mint 14 KDE (based on ubuntu 12.04),
Using a HP 550 laptop.
Shutdown results in end logo showing... indefenitly.

I am not using nvidia drivers btw, i got one of the crappy intel chipsets.

However, on my main system i dont have a problem with any ubuntu build.
I'm suspecting some sort of incompatability.

Patrick den Ouden (inf5) wrote :

Just noticed something... the wireless drivers.
My problems start after installing both the linux-nonfree-firmware and the b34 drivers.

Any of you that have the same?

Patrick den Ouden (inf5) wrote :

wireless card is the infamous broadcom chip.
dunno the type from top of my head... but forums are full of "how to get it working"

Mercer Rivière (vincentuq) wrote :

Dell Inspiron 1520 and Ubuntu 12.04. Upgraded from previous LTS where it worked.
Shutdown isn't working. Nvidia here, I will not remove it as I don't believe there is a relationship - it may only be a workaround.
I intend to stay on this LTS. I refuse to change any BIOS settings as it worked previously.

Other, perhaps unrelated:
- Sometimes X11 have 100% CPU and everything freezes
- ctrl-alt-f1 does not show a text terminal
- often kernel oopses, more info here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1154006

wantlamy (wantlamy) wrote :

I have the same problem with Debian wheezy(gnome 3), this is why I come to ubuntu 12.04. Unfortunately ubuntu has the problem too. But Debian wheezy with xfce desktop environment can shutting down normally with a warn message sometimes: killing all remaining processes failed.

Wolter Hellmund (wolterh) wrote :

Am I the only one who gets an error saying that I should stop S15networking via sudo service networking stop or sudo stop networking?

I tried running that command alone and I get a crash. Perhaps this is what's causing the problem?

I have it with several Intel Classmate with an Atom N2600 chipset

Mark Schneider, could you please confirm this issue exists with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the mainline kernels archive directory daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.10-rc6

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: needs-kernel-logs needs-upstream-testing regression-release
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
description: updated
tags: removed: apport-collected
summary: - System does not power off reliably when "Shut Down" chosen from GUI
+ [Dell Inspiron 1720] System does not power off reliably when "Shut Down"
+ chosen from GUI
plum7500 (plum01) wrote :

Most of the time when I set SABnzbd to shutdown computer after it finishes downloading files, it will work.
I've had this issue since doing a fresh install of 12.04.

plum7500, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Kernel team article:
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports

the Ubuntu Bug Control team and Ubuntu Bug Squad team article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Mercer Rivière (vincentuq) wrote :

Works in 3.2.0-51-generic (Inspiron 1520).

gratefulfrog (gratefulfrog) wrote :

This afffects me on 12.04 running on an Asus EEEpc 1201n.... It is systematic, the computer never completely powers off anymore, altough it used to some time ago.

Also, I run Gnome not Unity.

Cheers,
Bob

gratefulfrog, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

nafur (nafur) wrote :

Had the same problem (System powered off, but hardware did not actually turn off) on a dell vostro V131.
Problem persisted on installed Ubuntu and Windows 7 as well as Ubuntu and Fedora live systems (from USB)
As suggested in this thread: http://en.community.dell.com/support-forums/laptop/f/3518/t/19450900.aspx?pi239031352=1
I removed the BIOS battery for a few minutes. This solved the problem for me.

netikras (netikras) wrote :

Affects Linux Mint Petra as well. I'm on Samsung NF-210.

Issuing 'init 6' seems to kill processes and hung at blank screen. This actually has started quite a while ago.. >1 year ago. Then I used to notice this problem when hibernating with 's2disk' or 's2both' after using computer for a while (never occurred on a fresh boot). It used to fail to poweroff (although succeeded to dump the image) then too, but I decided it's simply because there are too many applications open and there's simply not enough of swap memory to store the image, or something like that... However a few weeks ago 'init 6' started to fail as well as simple shutdown...

Dunno if this could be related, but samsung-tools started to fail in re-enable wifi after waking up the OS from SLEEP (s2ram).

netikras (netikras) wrote :

umm.... just forgot to mention.. When it turned into zombie (almost dead) after attempt to hibernate I had to poweroff it manually with the button. After powering it on again fresh OS used to boot instead of the hibernated image (although uswsusp claimed image is saved at 100%). So I believe it's OS preventing computer from powering-off...

nafur / netikras, thank you for your comment. Unfortunately, this bug report is not scoped to you, or your problem. So your hardware and problem may be tracked, could you please file a new report with Ubuntu (not Linux Mint) by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

As well, please do not announce in this report you created a new bug report.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

George (geoaraujo) wrote :

It seems that I'm plagued by this issue too.
Dell Inspiron N 4050 and Kubuntu 14.10. Upgraded from previous LTS where it worked.
Intel Integrated Graphics card here.

George, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report with Ubuntu by executing the following in a terminal while booted into the default Ubuntu kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
https://wiki.ubuntu.com/Kernel/Policies/DuplicateBugs
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

As well, please do not announce in this report you created a new bug report.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Gregory Kramida (algomorph) wrote :

Judging by the number of different architectures affected, I speculate that bug occurs on a specific class of hardware (specific set of motherboard chipsets?)

I have had this same (or similar?) issue plaguing two of my desktop machines out of three. All have Ubuntu 15.04 currently on all three, all three have similar hardware configurations and the same M/B vendor, yet different motherboards.

What I would like to know is, specifically with what hardware components could shutting down become an issue? How would I find out which one I have (maybe, specific entries in output of "lspci", something in the kernel log, etc.)? How do I determine whether two of my machines are suffering from this same bug or a different one?

-Thanks

Rile (rile-tm86) wrote :

I have this problem after replacing my HDD with new SDD. Since than, everything is much faster but it wont't power off.

This is a thread about my issue: http://ubuntuforums.org/showthread.php?t=2292569

ken (cleari3) on 2016-02-16
Changed in linux (Ubuntu):
assignee: nobody → ken (cleari3)

I installed, from pendrive, Ubuntu 16.04 LTS in dell inspiron 1501 (with windows XP), the windows poweroff normally, but ubuntu do not: it goes shutdown apparently normally but finally do not power off the labtop.

The last lines reported are: All fylesystems unmounted Deactivating swaps All swaps deactivated Detaching loop devices All loop devices detached Detachig DM devices All DM devices detached Powering off

and the labtop do not power off

Ther is a significant note in the previous lines before those lines: Process 1043 (plymouthd) has benn marked to be ecluded form killing.......

I am new and no expert linux

jose castellanos, it will help immensely if you filed a new report with the Ubuntu repository kernel (not mainline/upstream) via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

For more on why this is helpful, please see https://wiki.ubuntu.com/ReportingBugs.

Changed in linux (Ubuntu Precise):
status: Confirmed → Incomplete
Changed in linux (Ubuntu):
assignee: ken (cleari3) → nobody
Displaying first 40 and last 40 comments. View all 209 comments or add a comment.