gtk-logout-helper crashed with SIGSEGV in g_variant_unref()

Bug #864085 reported by Dragos Surdescu on 2011-10-01
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Session Menu
Fix Released
Medium
Ted Gould
indicator-session (Ubuntu)
Medium
Ken VanDine
Oneiric
Medium
Ken VanDine
Precise
Medium
Ken VanDine

Bug Description

when shutdown

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: indicator-session 0.3.6-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Sat Oct 1 16:52:40 2011
ExecutablePath: /usr/lib/indicator-session/gtk-logout-helper
ProcCmdline: /usr/lib/indicator-session/gtk-logout-helper --shutdown
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7fadfc836bd9 <g_variant_unref+9>: lock xadd %eax,0x24(%rdi)
 PC (0x7fadfc836bd9) ok
 source "%eax" ok
 destination "0x24(%rdi)" (0x00000024) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: indicator-session
StacktraceTop:
 g_variant_unref () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_settings_get_boolean () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? ()
 __libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6
 ?? ()
Title: gtk-logout-helper crashed with SIGSEGV in g_variant_unref()
UpgradeStatus: Upgraded to oneiric on 2011-09-30 (0 days ago)
UserGroups: adm admin cdrom dialout disk lpadmin plugdev sambashare

Related branches

Dragos Surdescu (scdragos) wrote :

StacktraceTop:
 g_variant_unref (value=0x0) at /build/buildd/glib2.0-2.30.0/./glib/gvariant-core.c:617
 g_settings_get_boolean (settings=<optimized out>, key=<optimized out>) at /build/buildd/glib2.0-2.30.0/./gio/gsettings.c:1988
 main (argc=1, argv=0x7ffffaf1c258) at /build/buildd/indicator-session-0.3.6/./src/gtk-logout-helper.c:209

Changed in indicator-session (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-session (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

thank you for your bug report, did that happen while you were doing upgrades?

visibility: private → public
Changed in indicator-session (Ubuntu):
status: Confirmed → Incomplete
Ted Gould (ted) on 2011-10-08
Changed in indicator-session:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Ted Gould (ted)
milestone: none → 0.3.7
Ted Gould (ted) on 2011-10-09
Changed in indicator-session (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Ted Gould (ted) on 2011-10-12
Changed in indicator-session:
status: In Progress → Fix Committed
Ted Gould (ted) on 2011-10-13
Changed in indicator-session:
status: Fix Committed → Fix Released
Changed in indicator-session (Ubuntu):
status: Incomplete → Confirmed
milestone: none → oneiric-updates

Hello Dragos, or anyone else affected,

Accepted indicator-session into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in indicator-session (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Jean-Baptiste Lallement (jibel) wrote :

Please document this report with a test case detailing the steps to reliably reproduce this crash and the expected result. Otherwise there is no way to verify the fix.

Thanks in advance.

Changed in indicator-session (Ubuntu Oneiric):
status: Fix Committed → Incomplete
importance: Undecided → Medium
milestone: none → oneiric-updates
Changed in indicator-session (Ubuntu Precise):
milestone: oneiric-updates → precise-alpha-1
Changed in indicator-session (Ubuntu Oneiric):
assignee: nobody → Ken VanDine (ken-vandine)
Sebastien Bacher (seb128) wrote :

Thanks for looking at it jibel but those are issues that randomly happen, there is no real way to get a testcase out of "run the new version and check it works fine for you"...

Changed in indicator-session (Ubuntu Oneiric):
status: Incomplete → Fix Committed
Gema Gomez (gema) wrote :

Arguably enough, if the problems happens to someone every time they run the software and it happens in your environment so that you can fix it, I don't see how this is something that happens "randomly". It may not happen every time you shutdown but surely there are some conditions that trigger the issue. Otherwise I am not sure how you can say the fix is committed, if you don't know how to reproduce it?

It would be a huge help for QA to start getting this kind of input from the engineers so that we can build a meaningful regression test suite. It is not up to the developer to decide what the test cases should be like, you can give us the information on how you reproduced it so that we can decide whether it is worth adding or not.

Sebastien Bacher (seb128) wrote :

> if the problems happens to someone every time they run the software

the issue is that those bugs don't happen every time, read the description and comments from this bug or the duplicates, they are not really useful :-(

> it happens in your environment so that you can fix it

it doesn't happen, the fix comes from reading the code and figuring what might happen...

> there are some conditions that trigger the issue. Otherwise I am not sure how you can say the fix is committed, if you don't know how to reproduce it?

right, "some conditions," could be timing, a memory corruption which will lead to a segfault every 25 restarts, etc.
How bugs can be fixed without being reproduced? Those segfault have a "stacktrace", which tells us the code path followed which has been leading to the bug, by understanding the code logic it's often possible to see what could go wrong, or to see what part of the code is not robust enough against issues

> It would be a huge help for QA to start getting this kind of input from the engineers so that we can build a meaningful regression test suite. It is not up to the developer to decide what the test cases should be like, you can give us the information on how you reproduced it so that we can decide whether it is worth adding or not.

Right, not discussing that, it's just not always possible to get those informations...

Gema Gomez (gema) wrote :

Thanks for the information, this means that we would benefit from running some sort of static analysis tool on code. Are you aware of any team doing that? Is there any code analyzer that you think we could start running that would speed the detection of these problems?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.3.7-0ubuntu1

---------------
indicator-session (0.3.7-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    * Fix some variant ref issues causing crashes (LP: #863930)
    * Handle cases of returned dbus messages from ConsoleKit (LP: #864085)
 -- Ted Gould <email address hidden> Thu, 13 Oct 2011 13:19:13 -0500

Changed in indicator-session (Ubuntu Precise):
status: Confirmed → Fix Released

I run this version for a week now and didn't notice any regression. marking as verification-done.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.3.7-0ubuntu1

---------------
indicator-session (0.3.7-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    * Fix some variant ref issues causing crashes (LP: #863930)
    * Handle cases of returned dbus messages from ConsoleKit (LP: #864085)
 -- Ted Gould <email address hidden> Thu, 13 Oct 2011 13:19:13 -0500

Changed in indicator-session (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers