indicator-session-service crashed with SIGABRT (assertion failed: (0 <= index && index < 24))

Bug #863930 reported by Glenn Chugg on 2011-10-01
102
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Session Menu
Fix Released
High
Ted Gould
indicator-session (Ubuntu)
High
Ken VanDine
Oneiric
High
Ken VanDine

Bug Description

I had been in the OS for a while and decided to check for more updates since I last rebooted 3 hours ago. Then I got this error almost as soon as I clicked the "Software Up To Date" item in the Indicator on the far right (With Shutdown menu in it) I got the error, everything was still working as expected and the update window came up fine.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: indicator-session 0.3.6-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Sat Oct 1 19:35:50 2011
ExecutablePath: /usr/lib/indicator-session/indicator-session-service
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110915.1)
ProcCmdline: /usr/lib/indicator-session/indicator-session-service
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=en_AU:en
 LANG=en_AU.UTF-8
Signal: 6
SourcePackage: indicator-session
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: indicator-session-service crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Glenn Chugg (glennlchugg) wrote :

StacktraceTop:
 g_assertion_message (domain=<optimized out>, file=<optimized out>, line=<optimized out>, func=0x7f17647e59d0 "g_variant_type_info_check", message=0x17c94b0 "assertion failed: (0 <= index && index < 24)") at /build/buildd/glib2.0-2.30.0/./glib/gtestutils.c:1425
 g_assertion_message_expr (domain=0x7f1764795826 "GLib", file=0x7f17647e56b8 "/build/buildd/glib2.0-2.30.0/./glib/gvarianttypeinfo.c", line=186, func=0x7f17647e59d0 "g_variant_type_info_check", expr=<optimized out>) at /build/buildd/glib2.0-2.30.0/./glib/gtestutils.c:1436
 g_variant_type_info_check (info=<optimized out>, container_class=<optimized out>) at /build/buildd/glib2.0-2.30.0/./glib/gvarianttypeinfo.c:186
 g_variant_type_info_unref (info=0x7f1758010c60) at /build/buildd/glib2.0-2.30.0/./glib/gvarianttypeinfo.c:831
 g_variant_unref (value=0x7f175000b4a0) at /build/buildd/glib2.0-2.30.0/./glib/gvariant-core.c:625

Changed in indicator-session (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-session (Ubuntu):
status: New → Confirmed
visibility: private → public
summary: - indicator-session-service crashed with SIGABRT in raise()
+ indicator-session-service crashed with SIGABRT (assertion failed: (0 <=
+ index && index < 24))
Sebastien Bacher (seb128) wrote :

similar to bug #835885

Changed in indicator-session (Ubuntu):
importance: Medium → High
Changed in indicator-session:
importance: Undecided → High
Changed in indicator-session (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Ted Gould (ted) wrote :

Hmm, so I think this is probably caused by a GVariant getting unref'd that shouldn't have been. Then it crashes when the system unrefs that GVariant. I'm not sure how to figure out where that is though.

tags: added: bugpattern-needed
Ted Gould (ted) on 2011-10-09
Changed in indicator-session:
status: New → In Progress
milestone: none → 0.3.7
assignee: nobody → Ted Gould (ted)
Changed in indicator-session (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Ken VanDine (ken-vandine)
Ted Gould (ted) on 2011-10-12
Changed in indicator-session:
status: In Progress → Fix Committed
Ted Gould (ted) on 2011-10-13
Changed in indicator-session:
status: Fix Committed → Fix Released
Changed in indicator-session (Ubuntu Oneiric):
milestone: none → oneiric-updates

Hello Glenn, or anyone else affected,

Accepted indicator-session into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in indicator-session (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Glenn Chugg (glennlchugg) wrote :

I've not had it happen to me again over the last 2 days, unless I get a way to verify it for you, you'd have to count on another affected user who still receives troubles. Infact I've not had anything crash on me for 2 days.. strange really ;)

Please document this report with a test case detailing the steps to reliably reproduce this crash and the expected result. Otherwise there is no way to verify the fix.

Thanks in advance.

Changed in indicator-session (Ubuntu Oneiric):
status: Fix Committed → Incomplete
Sebastien Bacher (seb128) wrote :

Thanks for looking at it jibel but those are issues that randomly happen, there is no real way to get a testcase out of "run the new version and check it works fine for you"...

Changed in indicator-session (Ubuntu Oneiric):
status: Incomplete → Fix Committed
Gema Gomez (gema) wrote :

Arguably enough, if the problems happens to someone every time they run the software in a particular way and it happens in your environment so that you can fix it, I don't see how this is something that happens "randomly". It may not happen every time you shutdown but surely there are some conditions that trigger the issue. Otherwise I am not sure how you can say the fix is committed, if you don't know how to reproduce it?

It would be a huge help for QA to start getting this kind of input from the engineers so that we can build a meaningful regression test suite. It is not up to the developer to decide what the test cases should be like, you can give us the information on how you reproduced it so that we can decide whether it is worth adding or not.

Sebastien Bacher (seb128) wrote :

> if the problems happens to someone every time they run the software

the issue is that those bugs don't happen every time, read the description and comments from this bug or the duplicates, they are not really useful :-(

> it happens in your environment so that you can fix it

it doesn't happen, the fix comes from reading the code and figuring what might happen...

> there are some conditions that trigger the issue. Otherwise I am not sure how you can say the fix is committed, if you don't know how to reproduce it?

right, "some conditions," could be timing, a memory corruption which will lead to a segfault every 25 restarts, etc.
How bugs can be fixed without being reproduced? Those segfault have a "stacktrace", which tells us the code path followed which has been leading to the bug, by understanding the code logic it's often possible to see what could go wrong, or to see what part of the code is not robust enough against issues

> It would be a huge help for QA to start getting this kind of input from the engineers so that we can build a meaningful regression test suite. It is not up to the developer to decide what the test cases should be like, you can give us the information on how you reproduced it so that we can decide whether it is worth adding or not.

Right, not discussing that, it's just not always possible to get those informations...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.3.7-0ubuntu1

---------------
indicator-session (0.3.7-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    * Fix some variant ref issues causing crashes (LP: #863930)
    * Handle cases of returned dbus messages from ConsoleKit (LP: #864085)
 -- Ted Gould <email address hidden> Thu, 13 Oct 2011 13:19:13 -0500

Changed in indicator-session (Ubuntu):
status: Confirmed → Fix Released

I run this version for a week now and didn't notice any regression. marking as verification-done.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.3.7-0ubuntu1

---------------
indicator-session (0.3.7-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    * Fix some variant ref issues causing crashes (LP: #863930)
    * Handle cases of returned dbus messages from ConsoleKit (LP: #864085)
 -- Ted Gould <email address hidden> Thu, 13 Oct 2011 13:19:13 -0500

Changed in indicator-session (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers