gsettings-data-convert crashed with signal 5 in g_settings_set_value()

Bug #858798 reported by Attila Hammer on 2011-09-25
74
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Session Menu
Fix Released
Undecided
Unassigned
indicator-session (Ubuntu)
High
Ken VanDine
Oneiric
High
Ken VanDine

Bug Description

I using Oneiric with GNOME3 fallback session.
Without I doing anything I get this error.
Perhaps this problem is a duplicated report with an other bug, for example in Gedit this problem is fixed.

Attila

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gconf2 3.1.92-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
CasperVersion: 1.284
CrashCounter: 1
Date: Sun Sep 25 12:30:57 2011
ExecutablePath: /usr/bin/gsettings-data-convert
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110921.2)
ProcCmdline: gsettings-data-convert
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LC_MESSAGES=hu_HU.UTF-8
 LANG=hu_HU.UTF-8
 LANGUAGE=hu_HU:en
Signal: 5
SourcePackage: gconf
StacktraceTop:
 ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 g_settings_set_value () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 g_settings_set () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? ()
Title: gsettings-data-convert crashed with signal 5 in g_settings_set_value()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Attila Hammer (hammera) wrote :

This crash has the same stack trace characteristics as bug #816395. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: added: regression-retracer

StacktraceTop:
 g_settings_schema_get_value (schema=0x8206a78, key=0xb6f15838 "suppress_logout_menuitem") at /build/buildd/glib2.0-2.29.92/./gio/gsettingsschema.c:312
 g_settings_get_key_info (info=0xbfba68d0, settings=0x82066f0, key=0xb6f15838 "suppress_logout_menuitem") at /build/buildd/glib2.0-2.29.92/./gio/gsettings.c:932
 g_settings_set_value (settings=0x82066f0, key=0xb6f15838 "suppress_logout_menuitem", value=0xb6f14c48) at /build/buildd/glib2.0-2.29.92/./gio/gsettings.c:1561
 g_settings_set (settings=0x82066f0, key=0xb6f15838 "suppress_logout_menuitem", format=0x804aa07 "b") at /build/buildd/glib2.0-2.29.92/./gio/gsettings.c:1659
 handle_file (filename=<optimized out>) at gsettings-data-convert.c:199

Changed in gconf (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gconf (Ubuntu):
status: New → Confirmed
visibility: private → public
Sebastien Bacher (seb128) wrote :

Seems http://bazaar.launchpad.net/~indicator-applet-developers/indicator-session/trunk/revision/216 has been a fail (which was to fix bug #847807), instead of fixing the gsettings keys to be correct ted let the wrong one and broke the gconf ones

affects: gconf (Ubuntu) → indicator-session (Ubuntu)
Changed in indicator-session (Ubuntu):
importance: Medium → High
Sebastien Bacher (seb128) wrote :

Ken, do you think you could fix that to Oneiric today? Without the correct key mapping the settings migration will not work and the convertion script will abort before being done converting settings

Changed in indicator-session (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in indicator-session (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
Changed in indicator-session (Ubuntu Oneiric):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.3.6-0ubuntu2

---------------
indicator-session (0.3.6-0ubuntu2) oneiric; urgency=low

  * data/indicator-session.convert
    - Fixed improperly mapped gconf to gsettings keys (LP: #858798)
 -- Ken VanDine <email address hidden> Mon, 03 Oct 2011 10:26:54 -0400

Changed in indicator-session (Ubuntu Oneiric):
status: In Progress → Fix Released
Ted Gould (ted) on 2011-10-12
Changed in indicator-session:
status: New → Fix Committed
milestone: none → 0.3.7
Ted Gould (ted) on 2011-10-13
Changed in indicator-session:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers