the .convert lists keys that are not in the .schemas

Bug #847807 reported by Jamie Strandboge on 2011-09-12
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Session Menu
Fix Released
High
Ted Gould
Unity Foundations
High
Ted Gould
indicator-session (Ubuntu)
High
Ted Gould

Bug Description

After logging in, I am presented with this error. $ /usr/bin/gsettings-data-convert

GLib-GIO-ERROR **: Settings schema 'com.canonical.indicator.session' does not contain a key named 'suppress_logout_restart_shutdown'
Trace/breakpoint trap (core dumped)

Looking in gconf-editor, this key is found in /apps/indicator-session. This is a boolean value (set to False) and gconf-editor tells me it is not associated with any schema.

Removing the key allows gsettings-data-convert to complete without error.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gconf2 3.1.90-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Mon Sep 12 07:53:00 2011
Disassembly: => 0x7f861f6db473: Cannot access memory at address 0x7f861f6db473
ExecutablePath: /usr/bin/gsettings-data-convert
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110425.2)
ProcCmdline: gsettings-data-convert
Signal: 5
SourcePackage: gconf
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: gsettings-data-convert crashed with signal 5
UpgradeStatus: Upgraded to oneiric on 2011-07-23 (51 days ago)
UserGroups: adm admin cdrom dialout kvm libvirtd lpadmin plugdev sambashare sbuild

Related branches

Jamie Strandboge (jdstrand) wrote :
description: updated
description: updated

StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()

Changed in gconf (Ubuntu):
status: New → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

outdated debug symbol package for libnih1: package version 1.0.3-4ubuntu2 dbgsym version 1.0.3-1ubuntu1
outdated debug symbol package for psmisc: package version 22.14-1 dbgsym version 22.13-1
outdated debug symbol package for libslang2: package version 2.2.4-2ubuntu1 dbgsym version 2.2.2-4ubuntu2
outdated debug symbol package for libk5crypto3: package version 1.9.1+dfsg-1ubuntu1 dbgsym version 1.8.3+dfsg-5ubuntu2.1
outdated debug symbol package for passwd: package version 1:4.1.4.2+svn3283-3ubuntu2 dbgsym version 1:4.1.4.2+svn3283-3ubuntu1
outdated debug symbol package for libkrb5-3: package version 1.9.1+dfsg-1ubuntu1 dbgsym version 1.8.3+dfsg-5ubuntu2.1
outdated debug symbol package for libgssapi-krb5-2: package version 1.9.1+dfsg-1ubuntu1 dbgsym version 1.8.3+dfsg-5ubuntu2.1
outdated debug symbol package for procps: package version 1:3.2.8-10ubuntu5 dbgsym version 1:3.2.8-10ubuntu3
outdated debug symbol package for libkrb5support0: package version 1.9.1+dfsg-1ubuntu1 dbgsym version 1.8.3+dfsg-5ubuntu2.1
outdated debug symbol package for libnih-dbus1: package version 1.0.3-4ubuntu2 dbgsym version 1.0.3-1ubuntu1
outdated debug symbol package for module-init-tools: package version 3.16-1ubuntu1 dbgsym version 3.12-1ubuntu6

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-amd64-retrace

Using the script from https://wiki.ubuntu.com/Backtrace, here is the backtrace.

visibility: private → public
summary: - gsettings-data-convert crashed with signal 5
+ gsettings-data-convert crashed with signal 5 (does not contain a key
+ named 'suppress_logout_restart_shutdown')
description: updated
description: updated
Changed in gconf (Ubuntu):
status: Invalid → New

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gconf (Ubuntu):
status: New → Confirmed
affects: gconf (Ubuntu) → indicator-session (Ubuntu)
Sebastien Bacher (seb128) wrote :

seems there is a "-" "_" mismatch between the schemas and the .convert

Changed in indicator-session (Ubuntu):
assignee: nobody → Ted Gould (ted)
importance: Undecided → High
summary: - gsettings-data-convert crashed with signal 5 (does not contain a key
- named 'suppress_logout_restart_shutdown')
+ the .convert lists keys that are not in the .schemas
Ted Gould (ted) on 2011-09-19
Changed in indicator-session:
status: New → Confirmed
Changed in unity-foundations:
status: New → Confirmed
Changed in indicator-session:
importance: Undecided → High
Changed in unity-foundations:
importance: Undecided → High
Changed in indicator-session:
assignee: nobody → Ted Gould (ted)
Changed in unity-foundations:
assignee: nobody → Ted Gould (ted)
milestone: none → oneiric-beta-2
Ted Gould (ted) on 2011-09-21
Changed in unity-foundations:
milestone: oneiric-beta-2 → oneiric-final
Ted Gould (ted) on 2011-09-21
Changed in indicator-session:
status: Confirmed → Fix Committed
Changed in unity-foundations:
status: Confirmed → Fix Committed
Changed in indicator-session:
milestone: none → 0.3.5
milestone: 0.3.5 → 0.3.6
Ted Gould (ted) on 2011-09-27
Changed in indicator-session:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.3.6-0ubuntu1

---------------
indicator-session (0.3.6-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    * Fix convert file key naming (LP: #847807)
    * Use environment variable to get seat path (LP: #856455)
    * Fix abort when using ConsoleKit fallback (LP: #740382)
    * Update session icon instead of creating a new one (LP: #854292)
    * Update to latest Launchpad translations
 -- Ted Gould <email address hidden> Tue, 27 Sep 2011 17:06:47 -0500

Changed in indicator-session (Ubuntu):
status: Confirmed → Fix Released
Ted Gould (ted) on 2011-09-29
Changed in unity-foundations:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers