live session indicators/unity not translated

Bug #820705 reported by Mathieu Trudel-Lapierre on 2011-08-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
indicator-session (Ubuntu)
Medium
Canonical Desktop Team
Oneiric
Medium
Canonical Desktop Team

Bug Description

Marked against ubiquity for lack of a better target....

In the live session in French with image Ubuntu Desktop amd64 20110703.1; while the installer and desktop icons are properly translated in French, indicators and unity show in their default English strings (except the date which grabs the locale which is translated). The system once installs shows far more strings translated in indicators and unity.

tags: added: iso-testing
affects: ubiquity (Ubuntu) → ubuntu
Changed in ubuntu:
importance: Undecided → Medium
status: New → Confirmed
affects: Ubuntu Oneiric → ubiquity (Ubuntu Oneiric)
Jean-Baptiste Lallement (jibel) wrote :

removing ubiquity and assigning to translation project for review.

affects: ubiquity (Ubuntu Oneiric) → Ubuntu Oneiric
Jean-Baptiste Lallement (jibel) wrote :

french langpacks are not on the CD. To be verified with a langpack available from the live session(spanish for example)

Jean-Baptiste Lallement (jibel) wrote :

only indicator session is not completely translated.

The following items are in english:
- Settings
- Displays
- Bluetooth
- Startup Applications
- Update Available
- Attached Devices
- Printers

affects: Ubuntu Oneiric → indicator-session (Ubuntu Oneiric)
Changed in indicator-session (Ubuntu Oneiric):
status: Incomplete → Triaged
Sebastien Bacher (seb128) wrote :

Thanks for the bug report, it seems like what you describe there is that the liveCD image doesn't have the french langpacks, ubiquity doesn't strip its translations though to be usuable in any language to install Ubuntu, the desktop icons for their part probably have inline translation in their .desktop entry

Sebastien Bacher (seb128) wrote :

the indicator-session translation issue is probably because we didn't get an langpack update since the new strings landed

Gabor Kelemen (kelemeng) wrote :
Changed in ubuntu-translations:
status: New → Incomplete
status: Incomplete → Opinion
status: Opinion → Confirmed
importance: Undecided → Medium
Gabor Kelemen (kelemeng) wrote :

Running intltool on a local checkout of the oneiric indicator-session branch shows that there are no files left out of POTFILES.in, and a brand new pot file contains 55 strings (including the ones listed in comment 3), while the one I just linked contains only 43.

Looks like the template is not being regenerated during build.

Timo Witte (spacefish) wrote :

i have made a small patch that adds a command to the debian rules file to make the pot file after the build of the package! See attatchment.. Hope this is right.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.3.1-0ubuntu2

---------------
indicator-session (0.3.1-0ubuntu2) oneiric; urgency=low

  * debian/rules: run intltool-update to update the translations template
    (lp: #820705)
 -- Sebastien Bacher <email address hidden> Thu, 11 Aug 2011 17:09:08 +0200

Changed in indicator-session (Ubuntu Oneiric):
status: Triaged → Fix Released
Gabor Kelemen (kelemeng) on 2011-08-18
Changed in ubuntu-translations:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments