gtk-logout-helper crashed with SIGABRT in __libc_start_main()

Bug #740382 reported by BavarianPH on 2011-03-22
This bug affects 209 people
Affects Status Importance Assigned to Milestone
Session Menu
Fix Released
Medium
Ted Gould
Unity Foundations
Medium
Ted Gould
indicator-session (Ubuntu)
High
Ted Gould
Oneiric
High
Ted Gould

Bug Description

Binary package hint: indicator-session

on cold boot

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: indicator-session 0.2.15-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.37-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Date: Tue Mar 22 06:11:48 2011
ExecutablePath: /usr/lib/indicator-session/gtk-logout-helper
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
ProcCmdline: /usr/lib/indicator-session/gtk-logout-helper --shutdown
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
Signal: 6
SourcePackage: indicator-session
StacktraceTop:
 ?? ()
 __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
 ?? ()
Title: gtk-logout-helper crashed with SIGABRT in __libc_start_main()
UpgradeStatus: Upgraded to natty on 2011-03-21 (0 days ago)
UserGroups:

Related branches

BavarianPH (bavarianph) wrote :

StacktraceTop:
 consolekit_fallback (argc=1, argv=0xbf925784) at gtk-logout-helper.c:71
 session_action (argc=1, argv=0xbf925784) at gtk-logout-helper.c:100
 main (argc=1, argv=0xbf925784) at gtk-logout-helper.c:213

Changed in indicator-session (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Changed in indicator-session:
importance: Undecided → Low
Changed in indicator-session (Ubuntu):
importance: Medium → Low
Detlef Lechner (detlef-lechner) wrote :

I am affected too.
~$ uname -a
Linux T42 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:50 UTC 2011 i686 i686 i386 GNU/Linux
Last night I did a partial distribution update using Update Manager. Then I switched this computer off.
When I switched this computer on this morning, I obtained the above error message.

John M.K. (jconni) wrote :

Happened to me after cold but on a freshly installed daily live built on a usb stick (version 19-Apr-2011). Have been trying daily builds frequently, this is the first time it hapened to me...

Linda Spencer (turnagainwoman) wrote :

This happened after I installed 11.04 to a 16GB Toshiba USB stick, and booted the stick - about 30 seconds after the Unity Desktop came up. I hadn't tried doing a thing yet with the mouse or keyboard.

Please note: since an update to 10.04 Lucid, I've been unable to get preboot and boot screens, and no amount of fiddling with grub2 made any difference. The screen does come on after the default kernel is loaded, but not at the proper resolution (16:10) for my wide screen, which leaves fat vertical black stripes on either side of the screen.

My BIOS is the original version, and needs updating (all the drivers too) - but I can't do the flash when the black screen prevents me from getting into Windows and/or BIOS. Live CDs also show no screen, (Even Windows XP), so the boot fails waiting for my input. This is a show-stopper for me.

I wonder if this new bug is related to the firmware problems I just described.

Laptop: Acer Aspire 5602WLMi
graphics: Intel GMA 950
chipset: 945GM

Changed in indicator-session (Ubuntu):
status: New → Confirmed
Conor Curran (cjcurran) on 2011-09-01
Changed in indicator-session:
assignee: nobody → Ted Gould (ted)
importance: Low → Medium
status: New → Triaged
Changed in unity-foundations:
status: New → Triaged
assignee: nobody → Ted Gould (ted)
milestone: none → oneiric-beta-2
Changed in indicator-session:
milestone: none → 0.3.4
Ted Gould (ted) wrote :

So, at some level this has to be an invalid read, but I can't figure out where. Could someone who gets this regularly please run the gtk-logout-helper under valgrind?

https://wiki.ubuntu.com/Valgrind

The command you need to run is: valgrind /usr/lib/indicator-session/gtk-logout-helper --shutdown

Thanks!

Changed in indicator-session:
status: Triaged → Incomplete
Changed in unity-foundations:
status: Triaged → Incomplete
Jonathan Lange (jml) wrote :

Here ya go!

tags: added: iso-testing
Ted Gould (ted) wrote :

@jml, thanks! That doesn't seem to be showing the bug though :-/ Anyone able to recreate it regularly?

Conor Curran (cjcurran) on 2011-09-01
Changed in indicator-session:
milestone: 0.3.4 → none
crtm (carlosrtm) wrote :

after update, then crash

Changed in indicator-session:
status: Incomplete → Confirmed
Changed in unity-foundations:
status: Incomplete → Confirmed
Dmitry Shachnev (mitya57) wrote :

My Valgrind log.

I am affected with the latest kernel.
Linux Knight-PC 3.0.0-10-generic #16-Ubuntu SMP Fri Sep 2 18:38:35 UTC 2011 i686 i686 i386 GNU/Linux
Description: Ubuntu oneiric (development branch)
Release: 11.10

Conor Curran (cjcurran) on 2011-09-06
Changed in unity-foundations:
status: Confirmed → Triaged
status: Triaged → Confirmed
Changed in indicator-session (Ubuntu):
status: Confirmed → Triaged
importance: Low → High

Hello,

We're having a difficult time tracking this bug down, so we're at the
point of looking for more information. Yesterday we released a new
version of indicator-session that should be in your local archive soon.
It is version 0.3.5. If those who are effected by these bugs could
ensure that they have this version:

  $ apt-cache policy indicator-session

and then run this:

  $ /usr/lib/indicator-session/gtk-logout-helper --shutdown &>
gtk-logout.log

And then attach that log to this bug that'd be really helpful. Thanks a
lot! Hopefully we can nail this soon.

  --Ted

Just did a apt-get update, apt-get upgraded and then apt-cache policy indicator-session, and got this:

indicator-session:
  Instalados: 0.3.4.3-0ubuntu1
  Candidato: 0.3.4.3-0ubuntu1
  Tabla de versión:
 *** 0.3.4.3-0ubuntu1 0
        500 http://mx.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status

Why isn't version 0.3.5 in my Ubuntu box yet?

Anders Feder (afeder) wrote :

I just upgraded and also got:

indicator-session:
  Installeret: 0.3.4.3-0ubuntu1
  Kandidat: 0.3.4.3-0ubuntu1
  Versionstabel:
 *** 0.3.4.3-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status

Ted,

Today I applied an upgrade but the version of indicator-session is still
0.3.4.3. Once I get the 0.3.5 I send the log.

Edson.

2011/9/9 Ted Gould <email address hidden>

> Hello,
>
> We're having a difficult time tracking this bug down, so we're at the
> point of looking for more information. Yesterday we released a new
> version of indicator-session that should be in your local archive soon.
> It is version 0.3.5. If those who are effected by these bugs could
> ensure that they have this version:
>
> $ apt-cache policy indicator-session
>
> and then run this:
>
> $ /usr/lib/indicator-session/gtk-logout-helper --shutdown &>
> gtk-logout.log
>
> And then attach that log to this bug that'd be really helpful. Thanks a
> lot! Hopefully we can nail this soon.
>
> --Ted
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (831923).
> https://bugs.launchpad.net/bugs/740382
>
> Title:
> gtk-logout-helper crashed with SIGABRT in __libc_start_main()
>
> Status in The Session Menu:
> Confirmed
> Status in Unity Foundations:
> Confirmed
> Status in “indicator-session” package in Ubuntu:
> Triaged
> Status in “indicator-session” source package in Oneiric:
> Triaged
>
> Bug description:
> Binary package hint: indicator-session
>
> on cold boot
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: indicator-session 0.2.15-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-7.37-generic 2.6.38
> Uname: Linux 2.6.38-7-generic i686
> Architecture: i386
> Date: Tue Mar 22 06:11:48 2011
> ExecutablePath: /usr/lib/indicator-session/gtk-logout-helper
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
> ProcCmdline: /usr/lib/indicator-session/gtk-logout-helper --shutdown
> ProcEnviron:
> SHELL=/bin/bash
> PATH=(custom, no user)
> LANGUAGE=en_US:en
> LANG=en_US.UTF-8
> Signal: 6
> SourcePackage: indicator-session
> StacktraceTop:
> ?? ()
> __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
> ?? ()
> Title: gtk-logout-helper crashed with SIGABRT in __libc_start_main()
> UpgradeStatus: Upgraded to natty on 2011-03-21 (0 days ago)
> UserGroups:
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/indicator-session/+bug/740382/+subscriptions
>

Ralph Ulrich (eulenreich) wrote :

I don't have this crash any more with 0.3.5
Also:
When logged in an ubuntu session there is no more lightdm-user session in parallel but only:
root lightdm
  \ myuser gnome-session

Ted,
As you requested, the logfile is there.

Att.
Edson.

2011/9/9 <email address hidden> <email address hidden>

> Ted,
>
> Today I applied an upgrade but the version of indicator-session is still
> 0.3.4.3. Once I get the 0.3.5 I send the log.
>
> Edson.
>
>
> 2011/9/9 Ted Gould <email address hidden>
>
>> Hello,
>>
>> We're having a difficult time tracking this bug down, so we're at the
>> point of looking for more information. Yesterday we released a new
>> version of indicator-session that should be in your local archive soon.
>> It is version 0.3.5. If those who are effected by these bugs could
>> ensure that they have this version:
>>
>> $ apt-cache policy indicator-session
>>
>> and then run this:
>>
>> $ /usr/lib/indicator-session/gtk-logout-helper --shutdown &>
>> gtk-logout.log
>>
>> And then attach that log to this bug that'd be really helpful. Thanks a
>> lot! Hopefully we can nail this soon.
>>
>> --Ted
>>
>> --
>> You received this bug notification because you are subscribed to a
>> duplicate bug report (831923).
>> https://bugs.launchpad.net/bugs/740382
>>
>> Title:
>> gtk-logout-helper crashed with SIGABRT in __libc_start_main()
>>
>> Status in The Session Menu:
>> Confirmed
>> Status in Unity Foundations:
>> Confirmed
>> Status in “indicator-session” package in Ubuntu:
>> Triaged
>> Status in “indicator-session” source package in Oneiric:
>> Triaged
>>
>> Bug description:
>> Binary package hint: indicator-session
>>
>> on cold boot
>>
>> ProblemType: Crash
>> DistroRelease: Ubuntu 11.04
>> Package: indicator-session 0.2.15-0ubuntu1
>> ProcVersionSignature: Ubuntu 2.6.38-7.37-generic 2.6.38
>> Uname: Linux 2.6.38-7-generic i686
>> Architecture: i386
>> Date: Tue Mar 22 06:11:48 2011
>> ExecutablePath: /usr/lib/indicator-session/gtk-logout-helper
>> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
>> ProcCmdline: /usr/lib/indicator-session/gtk-logout-helper --shutdown
>> ProcEnviron:
>> SHELL=/bin/bash
>> PATH=(custom, no user)
>> LANGUAGE=en_US:en
>> LANG=en_US.UTF-8
>> Signal: 6
>> SourcePackage: indicator-session
>> StacktraceTop:
>> ?? ()
>> __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
>> ?? ()
>> Title: gtk-logout-helper crashed with SIGABRT in __libc_start_main()
>> UpgradeStatus: Upgraded to natty on 2011-03-21 (0 days ago)
>> UserGroups:
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/indicator-session/+bug/740382/+subscriptions
>>
>
>

damian@blackbox:~$ apt-cache policy indicator-session
indicator-session:
  Installed: 0.3.5.0-0ubuntu1
  Candidate: 0.3.5.0-0ubuntu1
  Version table:
 *** 0.3.5.0-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status

It hadn't crashed for a while, until after today's kernel update.

Ted Gould (ted) wrote :

Thanks guys. Hmm, so both of those logs aren't going through the code path that is in the stacktrace :-/ Anyone else able to get a log and a crash?

userdce (userdce) wrote :

got this bug while whole system was upto date

tags: added: rls-mgr-o-tracking
EricDHH (ericdhh) wrote :

Updated today, got the crash a few minutes after login. There was a desktop without unity-panel, it did not appear on the screen but this error.

Juha Siltala (topyli) wrote :

I'm getting this crash while running gnome-shell, which I find a bit strange.

Martin Pitt (pitti) on 2011-09-20
Changed in indicator-session (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Sebastien Bacher (seb128) wrote :

is bug #852343 the same issue?

Ted Gould (ted) on 2011-09-21
Changed in unity-foundations:
milestone: oneiric-beta-2 → oneiric-final

I am getting this crash consistently upon log in again.
Any suggestions on how to get the debugging information you requested?

Ted Gould (ted) wrote :

Yes if you run the command from the terminal it should provide it. So like this:

  $ /usr/lib/indicator-session/gtk-logout-helper --shutdown &> gtklogout.log

Then attach that file please.

Changed in unity-foundations:
importance: Undecided → Medium
bcbc (bcbc) wrote :

I got it again - not consistently - but here's the log anyway

Changed in indicator-session (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
David Barth (dbarth) on 2011-09-23
Changed in indicator-session (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Ted Gould (ted)
Changed in indicator-session (Ubuntu Oneiric):
status: Triaged → Incomplete
Dmitry Shachnev (mitya57) wrote :

Just got the crash when using shutdown dialog in Unity Greeter.
Unfortunately, ubuntu-bug fails to unpack it, so I attach it as is.

Traceback (most recent call last):
  File "/usr/bin/apport-unpack", line 44, in <module>
    pr.load(open(report))
  File "/usr/lib/python2.7/dist-packages/problem_report.py", line 133, in load
    l = base64.b64decode(line)
  File "/usr/lib/python2.7/base64.py", line 76, in b64decode
    raise TypeError(msg)
TypeError: Incorrect padding

Changed in indicator-session (Ubuntu Oneiric):
status: Incomplete → New
status: New → Incomplete
Changed in indicator-session (Ubuntu Oneiric):
status: Incomplete → Confirmed
Changed in indicator-session:
status: Confirmed → In Progress
Ted Gould (ted) on 2011-09-27
Changed in indicator-session:
status: In Progress → Fix Committed
Changed in unity-foundations:
status: Confirmed → Fix Committed
Changed in indicator-session:
milestone: none → 0.3.6
Ted Gould (ted) on 2011-09-27
Changed in indicator-session:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.3.6-0ubuntu1

---------------
indicator-session (0.3.6-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    * Fix convert file key naming (LP: #847807)
    * Use environment variable to get seat path (LP: #856455)
    * Fix abort when using ConsoleKit fallback (LP: #740382)
    * Update session icon instead of creating a new one (LP: #854292)
    * Update to latest Launchpad translations
 -- Ted Gould <email address hidden> Tue, 27 Sep 2011 17:06:47 -0500

Changed in indicator-session (Ubuntu Oneiric):
status: Confirmed → Fix Released
Ted Gould (ted) on 2011-09-29
Changed in unity-foundations:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers