Text on shutdown and restart boxes is selected while tabbing

Bug #597317 reported by David Stansby on 2010-06-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Matthew Rasmus
Session Menu
Fix Released
Low
Matthew Rasmus
indicator-session (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-session

Steps to reproduce: Go to shut down your computer and press tab a few times

What happens: As well as Cancel and Shut Down being selected, the text is also selected
What I think should happen: The text shouldn't be selected by tab, and tabbing should toggle only between cancel and Shut Down

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-session 2.30.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-4.5-generic 2.6.35-rc3
Uname: Linux 2.6.35-4-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Tue Jun 22 16:18:54 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: gnome-session

Related branches

Changed in gnome-session (Ubuntu):
status: New → Confirmed
Vish (vish) wrote :

This might be a side-effect of Ubuntu changes to the gnome-session dialogues.

Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Confirmed
Changed in gnome-session (Ubuntu):
importance: Undecided → Low
summary: - Text on shutdown and restart boxes is selecatble
+ Text on shutdown and restart boxes is selected while tabbing
Vish (vish) wrote :

Apparently its a bug in indicator-session,

affects: gnome-session (Ubuntu) → indicator-session (Ubuntu)
Changed in indicator-session (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: Confirmed → Triaged
Manuel J. Garrido (mgarrido) wrote :

The same behavior happens when nautilus asks for confirmation when deleting a file. So, I think this might be a more general bug, not only affecting indicator-session.

I don't know if I'm misunderstanding this report, but isn't this supposed to
be the case, so that you can select these options without the use of the
keyboard?

On 18 Dec 2010 18:41, "Manuel J. Garrido" <email address hidden> wrote:

The same behavior happens when nautilus asks for confirmation when
deleting a file. So, I think this might be a more general bug, not only
affecting indicator-session.

--
You received this bug notification because you are subscribed to One
Hundred Paper Cuts.
https://bugs.launchpad.net/bugs/597317

Title:
 Text on shutdown and restart boxes is selected while tabbing

Status in One Hundred Paper Cuts:
 Triaged
Status in The Session Menu:
 New
Status in “indicator-session” package in Ubuntu:
 Triaged

Bug description:
 Binary package hint: gnome-session

Steps to reproduce: Go to shut down your computer and press tab a few times

What happens: As well as Cancel and Shut Down being selected, the text is
also selected
What I think should happen: The text shouldn't be selected by tab, and
tabbing should toggle only between cancel and Shut Down

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-session 2.30.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-4.5-generic 2.6.35-rc3
Uname: Linux 2.6.35-4-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Tue Jun 22 16:18:54 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: gnome-session

The point is that you don't just tab through the buttons, you also tab
through the text in the box too which shouldn't be the case

Regards,
David

On 18 Dec 2010, at 18:56, Chris Wilson <email address hidden> wrote:

> I don't know if I'm misunderstanding this report, but isn't this supposed to
> be the case, so that you can select these options without the use of the
> keyboard?
>
> On 18 Dec 2010 18:41, "Manuel J. Garrido" <email address hidden>
> wrote:
>
> The same behavior happens when nautilus asks for confirmation when
> deleting a file. So, I think this might be a more general bug, not only
> affecting indicator-session.
>
> --
> You received this bug notification because you are subscribed to One
> Hundred Paper Cuts.
> https://bugs.launchpad.net/bugs/597317
>
> Title:
> Text on shutdown and restart boxes is selected while tabbing
>
> Status in One Hundred Paper Cuts:
> Triaged
> Status in The Session Menu:
> New
> Status in “indicator-session” package in Ubuntu:
> Triaged
>
> Bug description:
> Binary package hint: gnome-session
>
> Steps to reproduce: Go to shut down your computer and press tab a few
> times
>
> What happens: As well as Cancel and Shut Down being selected, the text is
> also selected
> What I think should happen: The text shouldn't be selected by tab, and
> tabbing should toggle only between cancel and Shut Down
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: gnome-session 2.30.2-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.35-4.5-generic 2.6.35-rc3
> Uname: Linux 2.6.35-4-generic i686
> NonfreeKernelModules: wl
> Architecture: i386
> Date: Tue Jun 22 16:18:54 2010
> InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
> PackageArchitecture: all
> ProcEnviron:
> PATH=(custom, user)
> LANG=en_GB.utf8
> SHELL=/bin/bash
> SourcePackage: gnome-session
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/597317
>
> Title:
> Text on shutdown and restart boxes is selected while tabbing
>
> Status in One Hundred Paper Cuts:
> Triaged
> Status in The Session Menu:
> New
> Status in “indicator-session” package in Ubuntu:
> Triaged
>
> Bug description:
> Binary package hint: gnome-session
>
> Steps to reproduce: Go to shut down your computer and press tab a few times
>
> What happens: As well as Cancel and Shut Down being selected, the text is also selected
> What I think should happen: The text shouldn't be selected by tab, and tabbing should toggle only between cancel and Shut Down
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: gnome-session 2.30.2-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.35-4.5-generic 2.6.35-rc3
> Uname: Linux 2.6.35-4-generic i686
> NonfreeKernelModules: wl
> Architecture: i386
> Date: Tue Jun 22 16:18:54 2010
> InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
> PackageArchitecture: all
> ProcEnviron:
> PATH=(custom, user)
> LANG=en_GB.utf8
> SHELL=/bin/bash
> SourcePackage: gnome-session
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/hundredpapercuts/+bug/597317/+subscribe

Vish (vish) on 2011-01-27
Changed in hundredpapercuts:
assignee: nobody → Papercuts Ninja (papercuts-ninja)
milestone: none → nt3-ayatana
Changed in indicator-session:
status: New → Confirmed
Matthew Rasmus (mrasmus) on 2011-02-06
Changed in indicator-session:
assignee: nobody → Matthew Rasmus (mrasmus)
Matthew Rasmus (mrasmus) wrote :

I've pushed a workaround for this bug, but it looks like it also exists in anything that uses GtkMessageDialog or GtkAboutDialog, so I'm not sure whether or not this is the intended behavior. My guess would be that it's not, since you can't do this in the file overwrite dialog in nautilus, but you can in the 'Slashes not allowed in filename' dialog. At the very least, it's inconsistent.

Ted Gould (ted) on 2011-02-07
Changed in indicator-session:
importance: Undecided → Low
Ted Gould (ted) wrote :

Awesome, thanks a ton!

Changed in indicator-session:
status: Confirmed → Fix Released
Vish (vish) on 2011-02-11
Changed in hundredpapercuts:
assignee: Papercuts Ninja (papercuts-ninja) → Matthew Rasmus (mrasmus)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.2.13-0ubuntu1

---------------
indicator-session (0.2.13-0ubuntu1) natty; urgency=low

  * New upstream release.
    * Making text in logout dialog unselectable (LP: #597317)
 -- Ted Gould <email address hidden> Fri, 11 Feb 2011 11:14:08 -0600

Changed in indicator-session (Ubuntu):
status: Fix Committed → Fix Released
Vish (vish) on 2011-02-11
Changed in indicator-session (Ubuntu):
status: Triaged → Fix Committed
Vish (vish) on 2011-02-11
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints