lock doesn't lock when gnome-screensaver not running in the background

Bug #509411 reported by Tomas Pospisek on 2010-01-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
indicator-session (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-screensaver

1)
$ lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10
2)
gnome-screensaver: 2.28.0-0ubuntu3.3
3)
When I click on the "lock" icon or
when I right-click on the "lock" icon and select "Lock Screen" or
when I click on the "shutdown" button and select "Lock Screen"
then I expect the screen to get actually locked or to get an error message or to get some log somewhere
4)
none of the expected results above, in fact nothing at all happens

FYI:

$ gconftool-2 -R /apps/gnome-screensaver
 lock_enabled = true
 idle_activation_enabled = true
 cycle_delay = 10
 status_message_enabled = true
 mode = blank-only
 theme = screensavers-ubuntu_theme
 user_switch_enabled = true
 idle_delay = 10
 logout_delay = 120
 power_management_delay = 120
 embedded_keyboard_enabled = false
 logout_enabled = false
 embedded_keyboard_command =
 lock_dialog_theme = default
 logout_command =
 themes = []
 lock_delay = 0

All dependencies of gnome-screensaver except for the "Suggests" xscreensaver-data-extra and xscreensaver-gl-extra are installed.

Locking the screen actually used to work. Also in Karmic. But it stopped working some time ago (like months ago?). Maybe a bug in a Karmic update?
*t

Chris Coulson (chrisccoulson) wrote :

Is gnome-screensaver actually running?

Changed in gnome-screensaver (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Tomas Pospisek (tpo-deb) wrote :

$ ps auxw|grep gnome-screensaver
me 22527 0.0 0.0 8404 896 pts/3 R+ 09:07 0:00 grep gnome-screensaver
$

no, it's not. If I start it manually from the command line, then:

- locking the screen by clicking on the "lock" icon works
- by right-clicking on the "lock" icon and selecting "Lock Screen" works
- clicking on the "shutdown" icon and selecting "Lock Screen" gives no reaction

Changed in gnome-screensaver (Ubuntu):
status: Incomplete → New
Chris Coulson (chrisccoulson) wrote :

Thanks. That's not a bug then - you've probably disabled the screensaver in System -> Preferences -> Startup Applications

Changed in gnome-screensaver (Ubuntu):
status: New → Invalid
Tomas Pospisek (tpo-deb) wrote :

You are right, thanks Chris. The screen saver is disabled there.

However, the current architecture/concept is not consistent in itself:

- what for is there an icon, when it doesn't have any effect?

- why doesn't clicking the icon start the required programm
  (gnome-screen-saver) by itself?

- why isn't there any feedback about why nothing happens when I tell the
  computer to do some action (lock the screen) and it doesn't do it?

- why is it necessary to occupy virtual memory and CPU cycles with a programm
  (gnome-screensaver), when the programm doesn't do anything useful during
  its life? Locking the screen is an active action from the user and thus
  gnome-screensaver can be startet and stoped when it is not needed?

- why does it have an effect to click on the "lock" icon but not any effect to
  click on the "shutdown" icon and choose "Lock Screen"?

Changed in gnome-screensaver (Ubuntu):
status: Invalid → New
summary: - lock doesn't lock
+ lock doesn't lock when gnome-screensaver not running in the background
Tomas Pospisek (tpo-deb) wrote :

(If I knew how, I'd set this bug to Wishlist/Feature Request)

Chris Coulson (chrisccoulson) wrote :

gnome-screensaver is a session agent designed to be started when you log in, as it's needed for monitoring the session idle-ness and automatically activating the screensaver. It doesn't need to be activated when you try to lock the screen, as it should already be running.

The other points you make are separate issues with the session applet

Changed in gnome-screensaver (Ubuntu):
status: New → Invalid
Tomas Pospisek (tpo-deb) wrote :

See Chris' comment #6 (https://bugs.launchpad.net/509411/comments/6). The stated problems seem to be mainly a problem of indicator-session.

Could this bug be transformed into a Wishlist/Feature Request?

affects: gnome-screensaver (Ubuntu) → indicator-session (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers