indicator-applet doesn't show menu choices when selected

Bug #506683 reported by Marjo F. Mercado on 2010-01-12
86
This bug affects 13 people
Affects Status Importance Assigned to Milestone
indicator-session (Ubuntu)
Critical
Ken VanDine
Lucid
Critical
Ken VanDine

Bug Description

Binary package hint: indicator-applet

On a live session CD, when I select the indicator-applet to shutdown the system, the icon lights up, but nothing else happens. There's no menu to choose actions from.
Description: Ubuntu lucid (development branch)
Release: 10.04
Alpha 2 build

ProblemType: Bug
Architecture: i386
Date: Tue Jan 12 22:47:55 2010
DistroRelease: Ubuntu 10.04
LiveMediaBuild: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100112.1)
Package: indicator-applet 0.3.1-0ubuntu3
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
SourcePackage: indicator-applet
Tags: lucid ubuntu-unr
Uname: Linux 2.6.32-10-generic i686

tags: added: iso-testing
Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed in indicator-applet (Ubuntu):
status: New → Incomplete
Omer Akram (om26er) wrote :

i have not been able to reproduce it on 20100112(did not test 12.1)

Paul Larson (pwlars) wrote :

Also seeing this on imx51 A2 candidate image (20100113). Yes, it is reproducible, and the steps to recreate are listed in the original problem description: click on the indicator-applet-session icon (power control in the upper right corner). Odd thing that I noticed, is that on the live image, it seemed to work fine. The menu choices are present. However, after installing the system, they are gone again.

Changed in indicator-applet (Ubuntu):
status: Incomplete → Confirmed
Paul Larson (pwlars) wrote :

Seems to work ok again if I remove/re-add it

Steve Langasek (vorlon) wrote :

critical> leaves users no way to gracefully logout.

Changed in indicator-applet (Ubuntu Lucid):
importance: Undecided → Critical
Steve Langasek (vorlon) wrote :

indicator-applet doesn't appear to have been changed since December, but indicator-session was uploaded on 8 Jan; reassigning this to the more likely culprit package. Ted, can you please look at this for alpha-2?

affects: indicator-applet (Ubuntu Lucid) → indicator-session (Ubuntu Lucid)
Changed in indicator-session (Ubuntu Lucid):
milestone: none → lucid-alpha-2
assignee: nobody → Ted Gould (ted)

When this is happening is indicator-session-service running? It's the
supplier of the menu. If not, does restarting it fix the issue?

Martin Pitt (pitti) on 2010-01-14
Changed in indicator-session (Ubuntu Lucid):
milestone: lucid-alpha-2 → lucid-alpha-3
Paul Larson (pwlars) wrote :

I need to reinstall again, as this system has been through other things since that install. At the moment, I'm booted onto the live image and the power control menu is availableand indicator-session-service is running. However, the user status menu is empty, and indicator-status-service is *not* running

Ted Gould (ted) wrote :

On Thu, 2010-01-14 at 15:11 +0000, Paul Larson wrote:
> I need to reinstall again, as this system has been through other things
> since that install. At the moment, I'm booted onto the live image and
> the power control menu is availableand indicator-session-service is
> running. However, the user status menu is empty, and indicator-status-
> service is *not* running

It's actually changed names in Lucid. It's now "indicator-me-service".
Is that running?

  --Ted

Paul Larson (pwlars) wrote :

reinstalled and both the status and the session menu are empty. The only processes running with indicator in the name are: indicator-applet-session, indicator-applet, and indicator-messages-service

Esqui (esquiskwerl) wrote :

Also had this problem on alpha 2. Restarting fixed and both status and session menus are currently appearing.

Ted Gould (ted) wrote :

On Fri, 2010-01-15 at 00:55 +0000, Paul Larson wrote:
> reinstalled and both the status and the session menu are empty. The
> only processes running with indicator in the name are: indicator-applet-
> session, indicator-applet, and indicator-messages-service

Can you please run the services on the command line and see if they show
any errors?

   $ /usr/lib/indicator-session/indicator-session-service

and

   $ /usr/lib/indicator-me/indicator-me-service

Thanks!

David Barth (dbarth) wrote :

When booting the new UNE session on Lucid on my netbook, with autologin enabled, sometime the session service is not running (crash or race condition) and so the menu is empty. When trying to restart the indicator-session-service, it cannot register again, and on the command line I get:
...
*** (process:1747): DEBUG: GDM Settings change: true
*** (process:1747): DEBUG: Service shutdown

David Barth (dbarth) wrote :

Note: to fix the issue, I killed the gnome-panel and upon restart, the applet had restored the different indicator services.

Ted Gould (ted) wrote :

On Fri, 2010-01-15 at 16:26 +0000, David Barth wrote:
> When booting the new UNE session on Lucid on my netbook, with
> autologin enabled, sometime the session service is not running
> (crash or race condition) and so the menu is empty. When trying
> to restart the indicator-session-service, it cannot register again,
> and on the command line I get:
> ....
> *** (process:1747): DEBUG: GDM Settings change: true
> *** (process:1747): DEBUG: Service shutdown

The restart issue of reconnecting is a known issue, the code just isn't
written yet. This will be in a future release of libindicator.

What I'd like to track down in this bug is why, in some cases, it seems
that indicator-session-service isn't starting. Unfortunately it seems
that bonobo swallows a bunch of the logging messages.

Here's a shot in the dark :) Put this in a .desktop file
in .config/autostart/

[Desktop Entry]
Name=Test
Exec=/usr/lib/libindicator/indicator-loader /usr/lib/indicators/3/libsession.so

That'll start a small window with the session indicator in it, hopefully
then some error messages will end up in .xsession-errors

UGN (eugene-korneev) wrote :

confirm this bug
some time i have same issue too!

Ted Gould (ted) wrote :

I just released an indicator-applet 0.3.2 which I believe may fix this.
It'll take a while to get through all the distro builds/mirrors/etc. so
you'll probably get it today or tomorrow. Unfortunately, since I wasn't
able to conclusively recreate it, I'm not 100% sure it's fixed. If
people could please test the updated version when you get it and report
back that'd be wonderful.

Thanks!

Martin Pitt (pitti) wrote :

Thanks, Ted! Setting to "fix committed" for now, until a "yay" or "nay" arrives.

Changed in indicator-session (Ubuntu Lucid):
status: Confirmed → Fix Committed
Omer Akram (om26er) wrote :

Yes, faced it and did not face it after today's update. its fixed

Paul Sladen (sladen) wrote :

The logic should ideally be that indicator-me-menu does not remove/override the main gnome-panel Shutdown... entries (found under "System") _until_ it has confirmed that its own menu replacements are working.

And the same in reverse; if the replacement/overridden menus seize to work, then the main gnome-panel Shutdown... menu entries should return automatically.

Paul Sladen (sladen) wrote :

Had this again; I take it the fix wasn't released?

Omer Akram (om26er) wrote :

I am facing this at the moment with Indicator Applet Session 0.3.2

Changed in indicator-session (Ubuntu Lucid):
status: Fix Committed → Confirmed
Paul Sladen (sladen) wrote :

Dudes. This is *still* happening.

Ted Gould (ted) wrote :

On Thu, 2010-01-28 at 17:39 +0000, Paul Sladen wrote:
> Dudes. This is *still* happening.

There has been additional information added to the indicator-applet log
files with the new libindicator release. If, when it happens, you could
send ~/.cache/indicator-applet-session.log that would be helpful!

MillenniumBug (millenniumbug) wrote :

I shall take a look as soon as the ISO file is small enough to fit a CD.

Thomas Schweikle (tps) wrote :

I found it right easy to make the empty menu happen every time: switch to xdm or kdm, login and the user-menu will be empty.

Ted Gould (ted) wrote :

On Wed, 2010-02-17 at 02:26 +0000, Thomas Schweikle wrote:
> I found it right easy to make the empty menu happen every time: switch
> to xdm or kdm, login and the user-menu will be empty.

Hmm, perhaps different. It's probably crashing trying to get something
from GDM, that shouldn't happen. Could you run this from the command
line and add the output:

  $ /usr/lib/indicator-session/indicator-session-service

Thanks!

Thomas Schweikle (tps) wrote :

1. I logged in using gdm
2. same using kdm

1. all OK
2. Error: "Trace/breakpoint trap".

Thomas Schweikle (tps) wrote :
Thomas Schweikle (tps) wrote :

With gdm running a menu is shown.
With kdm/xdm running no menu.

David Barth (dbarth) wrote :

The problem is when trying to get the list of user session. That depends on a patch specific to gdm. The crasher comes from there.

David Barth (dbarth) wrote :

It's actually crashing inside g_error. Here is a patch to fix the problem.

tags: added: patch
Changed in indicator-session (Ubuntu Lucid):
assignee: Ted Gould (ted) → Ken VanDine (ken-vandine)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.2.3-0ubuntu2

---------------
indicator-session (0.2.3-0ubuntu2) lucid; urgency=low

  * debian/patches/fix-session-menu-without-gdm.patch
    - Don't fail with a g_error when we fail to get a list of user sessions
      from gdm (LP: #506683)
 -- Ken VanDine <email address hidden> Fri, 19 Feb 2010 09:43:14 -0500

Changed in indicator-session (Ubuntu Lucid):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers