Session Indicator's "Suspend" button has no effect in Unity 8

Bug #1674389 reported by Charles Kerr on 2017-03-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Stephen M. Webb
indicator-session (Ubuntu)
High
Charles Kerr
repowerd (Ubuntu)
High
Alexandros Frantzis
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

Testing Unity 8 from a Zesty nightly iso install on March 17 2017.

When clicking on the "Suspend" button in the session indicator, nothing happens.

This may or may not be an indicator-session issue. I need to triage this and see where the breakage is, e.g. does it work in Unity 7 on Zesty, and are there are any DBus signatures that have changed in Zesty that would cause this

Related branches

Charles Kerr (charlesk) wrote :

Might be a two-parter bug.

On the indicator-session side, we need to handle "challenge" as a response to CanSuspend / CanHibernate calls and, when calling suspend/hibernate, allow interactivity. This is in the fix-suspend-on-u8 branch.

Even after this is done, u8's challenge prompt is the lockscreen, so the unintuitive UX is that you have to (appear to) unlock in order to suspend. So in u8,
1. we should consider whether a password prompt should be necessary for suspend, and
2. if prompt is necessary, Calls to login1.Suspend(interactive=True) should probably be handled more elegantly than showing the lockscreen prompt

Changed in indicator-session (Ubuntu):
importance: Undecided → High
tags: added: unity8-desktop
kevin gunn (kgunn72) wrote :

adding repowerd because it suspiciously sounds a lot like bug 1668596

Changed in repowerd (Ubuntu):
importance: Undecided → High
assignee: nobody → Alexandros Frantzis (afrantzis)
Changed in canonical-devices-system-image:
assignee: nobody → Stephen M. Webb (bregma)
importance: Undecided → High
dobey (dobey) on 2017-03-22
Changed in indicator-session (Ubuntu):
status: Confirmed → In Progress
Alexandros Frantzis (afrantzis) wrote :

repowerd, or some other process that acquires logind suspend inhibitions, could be involved in this. It's easy to find out if this is the case by running:

$ systemd-inhibit

and checking if any inhibitions with parameters What:sleep Mode:block are active. Note that repowerd acquiring such an inhibition just means that another program has requested a suspend inhibition from repowerd.

In any case, as discussed in bug 1668596, repowerd will soon stop acquiring logind suspend inhibitions.

Changed in repowerd (Ubuntu):
status: New → Fix Committed
Changed in repowerd (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
milestone: none → u8c-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 17.3.20+17.04.20170403-0ubuntu1

---------------
indicator-session (17.3.20+17.04.20170403-0ubuntu1) zesty; urgency=medium

  [ Pete ]
  * Add phone indicator profiles.

  [ Charles Kerr ]
  * Handle "challenge" responses from login1 CanSuspend and CanHibernate
    calls (LP: #1674389)

 -- Pete Woods <email address hidden> Mon, 03 Apr 2017 15:38:27 +0000

Changed in indicator-session (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers