Lock/Switch stay in session menu even if disabled

Bug #1325353 reported by Jan Groenewald on 2014-06-01
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Session Menu
In Progress
Medium
Unassigned
indicator-session (Ubuntu)
Medium
Robert Ancell
Trusty
Medium
Unassigned

Bug Description

[Impact]
Session indicator no longer honours the lockdown settings that worked in 12.04 LTS. There are no alternative settings to perform the same behaviour. This functionality is required in large installations where users are not allowed to perfom these actions (e.g. corporate installations / labs / public terminals).

[Test Case]

1. Create the file /usr/share/glib-2.0/schemas/lockdown.gschema.override:
[org.gnome.desktop.lockdown]
disable-lock-screen=true
disable-user-switching=true
2. Reboot
3. Log into a session

Expected result:
Opening the session indicator should not show any options to lock the screen or switch the user.

Observed result:
"Lock/Switch Account" and user list shown for installations with more than one user. "Lock" shown for installations with one user.

[Regression Potential]
Potential for modified options to be shown/hidden incorrectly. Risk reduced by using existing regression tests, adding new test for lockdown and manually testing each case.

Related branches

Changed in indicator-session (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in indicator-session:
status: New → Triaged
importance: Undecided → Medium
Robert Ancell (robert-ancell) wrote :

I've proposed this for 14.04 LTS because in 12.04 LTS while the menus were laid out differently (user options were a separate indicator) they did honour the org.gnome.desktop.lockdown keys.

This feature is likely to be used on large Ubuntu deployments.

Changed in indicator-session (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → Medium
Changed in indicator-session (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in indicator-session:
assignee: nobody → Robert Ancell (robert-ancell)
status: Triaged → In Progress
Changed in indicator-session (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 12.10.5+14.10.20140718-0ubuntu1

---------------
indicator-session (12.10.5+14.10.20140718-0ubuntu1) utopic; urgency=low

  [ Robert Ancell ]
  * Hide relevant items from session indicator when
    org.gnome.desktop.lockdown disable-lock-screen or disable-user-
    switching are set to match 12.04 LTS behaviour (LP: #1325353)
 -- Ubuntu daily release <email address hidden> Fri, 18 Jul 2014 21:36:22 +0000

Changed in indicator-session (Ubuntu):
status: In Progress → Fix Released
description: updated
description: updated
description: updated
Changed in indicator-session (Ubuntu Trusty):
status: Triaged → In Progress
assignee: nobody → Robert Ancell (robert-ancell)

Would it possible to release the fix also for 14.04 ?

Vanush Paturyan (ektich) wrote :

I've backported the changes that fixed this issue in 14.10. It applied cleanly to the indicator-session 12.10.5_14.04.20151021.1-0ubuntu1 from the trusty-updates. Rebuilding the patched source package and installing it in Ubuntu 14.04 solves the issue. It would be nice if this patch is applied and released (I have never prepared new packages for upload, but can try doing it if it will help maintainers release the fix for 14.04 LTS).

Cheers,

Misha

Vanush Paturyan (ektich) wrote :

of course the moment I've submitted this I've noticed the "Related Branches" section above that lists this patch as "Ready for review for merging into lp:indicator-session/14.04". Can the process of accepting it be influenced somehow?

TUAdmin (jnlickey) wrote :

Same problem seen in Ubuntu 16.04 LTS. Is there a fix for this!

TUAdmin (jnlickey) wrote :

Colleague of mine just figured out a workaround for this in Ubuntu 16.04 LTS, by appending the following to /etc/bash.bashrc

gsettings set com.canonical.indicator.session user-show-menu false

This way when any user login occurs the switch user menu does not appear.

Changed in indicator-session:
assignee: Robert Ancell (robert-ancell) → nobody
Changed in indicator-session (Ubuntu Trusty):
assignee: Robert Ancell (robert-ancell) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions