J. Random User Showing In Session Indicator

Bug #1256590 reported by Andy Morris on 2013-12-01
66
This bug affects 14 people
Affects Status Importance Assigned to Milestone
indicator-session (Ubuntu)
Low
Charles Kerr

Bug Description

Yesterday I encountered an issue that was very concerning, at least until I investigated a bit more, and found that it may only be due to debug/test code that's still be present in released software. The search I made brought me here. Please redirect me if I'm in the wrong place.

"J. Random User" appeared in the Ubuntu 13.10 (x86_64) Unity Power indicator list, below 'Lock' and above '{my user name}'.

This was only noticed as I was about to lock the screen, which I do a number of times per day, however, this time "J. Random User" was visible.

There was no User Account for that entry in System Settings > User Accounts.
There was no one else logged onto the machine except my own username (checked by '$ w').
There seemed to be no rogue processes running (checked in log and current processes).

From a security point of view, it was very concerning. But after my searches on the matter, I belive the machine not to be compromised, but tickled by 'developer test code'.

Restarting the computer removed the issue.

It could be coincidence, but the only bit of new software I tried (for the first time ever) was the "Remmina Remote Desktop Client" to see if was interested to remotely connect to another computer on the home network. After restarting my computer and running that software again, it did not cause a "J. Random User" to appear in the indicator, so it could be a red-herring.

It could also be related to this? : https://code.launchpad.net/~larsu/ido/custom-menu-items/+merge/165498

Hope you know something about it, or can redirect this bug report elsewhere.

Thanks.

Related branches

Andy Morris (andygmorris) wrote :

From originating question 'Question' :
https://answers.launchpad.net/ubuntu/+question/240069

Andy Morris (andygmorris) wrote :

Screenshot (by mobile phone camera) available here :-
http://i.imgur.com/ZKQorzM.jpg

Andy Morris (andygmorris) wrote :

The actual screenshot, attached.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1256590/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Andy Morris (andygmorris) wrote :

I have no idea which package caused it. That's for you (the developers) to figure out.

In my posting, I let you know already that the only 'first time' usage of an app which may be related to this is "Remmina Remote Desktop Client". But I don't know for sure if that app caused the problem as the error that I'm reporting is seen on the Ubuntu Desktop and not inside a specific application.

affects: ubuntu → ido (Ubuntu)
Peter Murray (peter-h) wrote :

I also notice this after starting and stopping Remmina Remote Desktop Client for the first time since upgrading to Ubuntu 13.10.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ido (Ubuntu):
status: New → Confirmed

I have noticed the same issue ("J. Random User" appearing in menu) on my system today.
I'm on Ubuntu 13.10 (32 bit).

Yesterday I re-installed SciLab via Ubuntu Software Centre - this is the only change I made recently. Possibly automatic updates also occured in the background.

pcworld (pcworld) wrote :

I noticed this after I tried to launch a "Guest session" through the menu. Might or might not be related.

tags: added: saucy
Sami Olmari (olmari) wrote :

+1

I have this odd "user" too now...

Stefano Coronado (stefanoume) wrote :

I saw a second guest acount show up in the LightDM greeter. It has a password on it.

Stefano Coronado (stefanoume) wrote :

Adding to my previous comment, it's nothing malicous? Only a bug?

Jason Robinson (jaywink) wrote :

Just got hit by this, 13.10 fully updated. Guest session has been recently used by family members, though has also been used before too and haven't seen this before.

There is nothing strange in /etc/passwd afaik and this "user" is not visible in User settings.

Charles Kerr (charlesk) on 2014-03-05
summary: - J. Random User Showing In Unity Power Menu Indicator
+ J. Random User Showing In Session Indicator
affects: ido (Ubuntu) → indicator-session (Ubuntu)
Jason Robinson (jaywink) wrote :

Menu entry disappeared after reboot. Attached ubuntu-bug output.

Charles Kerr (charlesk) on 2014-03-26
Changed in indicator-session (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
Waldo (vvaldo) wrote :

Yeah, I got this too and flipped out until I found this issue. Here's a screen shot. Switched from one account to another and bam... there ya go. 13.10 here too.

Changed in indicator-session (Ubuntu):
importance: Undecided → Low
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 12.10.5+14.04.20140403-0ubuntu1

---------------
indicator-session (12.10.5+14.04.20140403-0ubuntu1) trusty; urgency=low

  [ Charles Kerr ]
  * Fix the phantom "J Random User" menuitem that shows up under some
    conditions. (LP: #1256590)
 -- Ubuntu daily release <email address hidden> Thu, 03 Apr 2014 17:13:30 +0000

Changed in indicator-session (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers