indicator-session-service crashed with "Settings schema 'org.gnome.desktop.lockdown' is not installed"

Bug #1212664 reported by Adolfo Jayme on 2013-08-15
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
indicator-session (Ubuntu)
Medium
Charles Kerr

Bug Description

I've seen the session indicator disappearing sometimes when I wake up the computer after suspension, that could be related to this.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: indicator-session 12.10.5+13.10.20130812-0ubuntu1
ProcVersionSignature: Ubuntu 3.10.0-6.17-generic 3.10.3
Uname: Linux 3.10.0-6-generic i686
NonfreeKernelModules: wl
ApportVersion: 2.12-0ubuntu3
Architecture: i386
Date: Thu Aug 15 06:38:04 2013
ExecutablePath: /usr/lib/i386-linux-gnu/indicator-session/indicator-session-service
InstallationDate: Installed on 2013-08-08 (7 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha i386 (20130807)
MarkForUpload: True
ProcCmdline: /usr/lib/i386-linux-gnu/indicator-session/indicator-session-service
ProcEnviron:
 SHELL=/bin/false
 XDG_RUNTIME_DIR=<set>
 PATH=(custom, no user)
 LANGUAGE=es_MX:es
 LANG=es_MX.UTF-8
Signal: 5
SourcePackage: indicator-session
StacktraceTop:
 ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 g_object_new_valist () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 g_object_new () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 g_settings_new () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
Title: indicator-session-service crashed with signal 5 in g_object_new_valist()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

Adolfo Jayme (fitojb) wrote :

StacktraceTop:
 g_settings_set_property (object=0x9192490, prop_id=2, value=0xbf8b4d78, pspec=0x918e8b8) at /build/buildd/glib2.0-2.37.5/./gio/gsettings.c:492
 object_set_property (nqueue=0x918b910, value=<optimized out>, pspec=0x918e8b8, object=0x9192490) at /build/buildd/glib2.0-2.37.5/./gobject/gobject.c:1363
 g_object_new_internal (class=class@entry=0x918aae8, params=0xbf8b4e8c, n_params=1) at /build/buildd/glib2.0-2.37.5/./gobject/gobject.c:1776
 g_object_new_valist (object_type=object_type@entry=152627064, first_property_name=first_property_name@entry=0xb768592b "schema-id", var_args=<optimized out>, var_args@entry=0xbf8b4f58 "\207M\b\b") at /build/buildd/glib2.0-2.37.5/./gobject/gobject.c:1999
 g_object_new (object_type=152627064, first_property_name=first_property_name@entry=0xb768592b "schema-id") at /build/buildd/glib2.0-2.37.5/./gobject/gobject.c:1556

Changed in indicator-session (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Adolfo Jayme (fitojb) on 2013-08-15
information type: Private → Public
Charles Kerr (charlesk) on 2013-08-21
Changed in indicator-session (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-session (Ubuntu):
status: New → Confirmed
Charles Kerr (charlesk) wrote :

This is crashing with GSettings failing to find the 'org.gnome.desktop.lockdown' schema.

Do you have gsettings-desktop-schemas or gnome-screensaver installed?

summary: - indicator-session-service crashed with signal 5 in g_object_new_valist()
+ indicator-session-service crashed with "Settings schema
+ 'org.gnome.desktop.lockdown' is not installed"
Adolfo Jayme (fitojb) wrote :

Charles: I'm sorry, I don't really remember if I removed those packages — maybe I did by accident. Since I reported this problem I've upgraded to Trusty and never faced it again.

Charles Kerr (charlesk) wrote :

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in indicator-session (Ubuntu):
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 12.10.5+14.04.20140320-0ubuntu1

---------------
indicator-session (12.10.5+14.04.20140320-0ubuntu1) trusty; urgency=low

  [ Charles Kerr ]
  * Don't show the lockscreen accelerator in switch-user mode. (LP:
    #1241906)
  * indicator-session relies on the org.gnome.desktop.lockdown schema
    provided by gsettings-desktop-schemas. (LP: #1212664)

  [ Ted Gould ]
  * Synchronize process management across indicators
 -- Ubuntu daily release <email address hidden> Thu, 20 Mar 2014 19:18:01 +0000

Changed in indicator-session (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers