Ubuntu

Cups notifies "printer ' xxx ' may be not connected " although printer is OK and printing is OK too

Reported by Pierre-Olivier Megret on 2011-09-06
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned
indicator-printers (Ubuntu)
Medium
Lars Uebernickel
Oneiric
Medium
Unassigned
Precise
Medium
Lars Uebernickel
system-config-printer (Ubuntu)
Undecided
Lars Uebernickel
Oneiric
Undecided
Unassigned
Precise
Medium
Lars Uebernickel

Bug Description

My printer :USB HP deskjet 460c well installed

when I launch any printing job ( from all apps included printing test page by "printer" menu in system/logout right menu ) , system notifies me that my printer may be not connected .. but all works .

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: cups 1.5.0-5
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
Architecture: amd64
CupsErrorLog:
 W [06/Sep/2011:07:56:14 +0200] failed to AddProfile: org.freedesktop.ColorManager.Failed:profile object path '/org/freedesktop/ColorManager/profiles/Deskjet_460_RGB__' has already been added
 E [06/Sep/2011:07:56:14 +0200] Failed to update TXT record for HP Deskjet 460 @ pierreolivier-Desktop: -2
Date: Tue Sep 6 16:32:30 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110808)
Lpstat: device for Deskjet-460: hp:/usb/Deskjet_460?serial=MY64P4Z38M
MachineType: System manufacturer System Product Name
Papersize: a4
PpdFiles: Deskjet-460: HP Deskjet 460, hpcups 3.11.7
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-10-generic root=UUID=b2f3b035-88c2-450b-919e-0b65be858730 ro quiet splash vt.handoff=7
SourcePackage: cups
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/10/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0220
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5QPL-VM EPU
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0220:bd04/10/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5QPL-VMEPU:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Screenshot from the notification.

Till Kamppeter (till-kamppeter) wrote :

Can you follow the instructions in the section "CUPS error_log" on https://wiki.ubuntu.com/DebuggingPrintingProblems. Thanks.

Changed in cups (Ubuntu):
status: New → Incomplete

I beg you pardon :)

Here's the error-log after printing two message from thunderbird : The wrong notification appeared the two times ;)

Changed in cups (Ubuntu):
status: Incomplete → In Progress
affects: cups (Ubuntu) → system-config-printer (Ubuntu)
Changed in system-config-printer (Ubuntu):
importance: Undecided → Medium
Till Kamppeter (till-kamppeter) wrote :

Deeper investigation revealed that these notifications come from gnome-settings-daemon and not from system-config-printer, moving ...

affects: system-config-printer (Ubuntu) → gnome-settings-daemon (Ubuntu)
Till Kamppeter (till-kamppeter) wrote :

The problem was indeed caused by the gnome-settings-daemon package. I have attached the debdiff with a workaround which simply suppresses this misleading "Printer XXX may not be connected", triggered whenever CUPS reports "connecting-to-device" which it does on every job. This is a workaround as we are after string/UI freeze. The fix is to improve the text, for example to replace it by "Connecting to printer XXXX ...". The same text improvement should also be done in system-config-printer.

Changed in gnome-settings-daemon (Ubuntu):
status: In Progress → Fix Committed
Till Kamppeter (till-kamppeter) wrote :

Rodrigo, can you upload the updated gnome-settings-daemon package as a fix for this bug before beta2 freeze? Thanks.

Changed in gnome-settings-daemon (Ubuntu):
milestone: none → ubuntu-11.10-beta-2
assignee: nobody → Rodrigo Moya (rodrigo-moya)
tags: added: patch
Till Kamppeter (till-kamppeter) wrote :

Added P-Series tasks for improving the human-readable text for the CUPS printer state reason "connecting-to-device".

Changed in system-config-printer (Ubuntu Oneiric):
status: New → Invalid

The attachment "Workaround to suppress the "May not be connected" message." of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

system-config-printer also handled in bug 855379.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.1.92-0ubuntu2

---------------
gnome-settings-daemon (3.1.92-0ubuntu2) oneiric; urgency=low

  * debian/patches/45_suppress-printer-may-not-be-connected-notification.patch:
    Do not show notifications if the printer state reason "connecting-to-device"
    is reported by CUPS. The text of this state reason notificatioon is the
    misleading "Printer XXX may not be connected" and the reason is set in
    every print job (usually only for a short time but enough to trigger the
    notifier). As we are after UI freeze we simply suppress this notification
    with this patch (do not forward upstream). The real fix would be improving
    the text, like really saying "Connecting to printer XXX ..." (LP: #842768).
 -- Till Kamppeter <email address hidden> Thu, 15 Sep 2011 18:34:24 +0200

Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Scott Moser (smoser) wrote :

In my reading of the bug above, it appears this is still open because:
 | Added P-Series tasks for improving the human-readable text for the CUPS
 | printer state reason "connecting-to-device"

I don't think this is ready for sponsorship or upload then for P, and am then going to unsubscribe ubuntu-sponsors.
If you disagree, please re-subscribe ubuntu-sponsors.

If I'm right, then feel free to submit a merge proposal or attach a debdiff and re-subscribe sponsors.

The subscription of the ubuntu-sponsors was done by an automatic process triggered by my addition of a debdiff. When I added the debdiff it was already decided that the maintiner of the gnome-settings-daemon, Rodrigo Moya, uploads it for me and he did. So I did not relly notice this subscription dangling around.

Changed in gnome-settings-daemon (Ubuntu Precise):
status: Confirmed → Triaged
Changed in system-config-printer (Ubuntu Precise):
status: Confirmed → Triaged
tags: added: patch-needswork
removed: patch
Changed in gnome-settings-daemon (Ubuntu Oneiric):
assignee: Rodrigo Moya (rodrigo-moya) → nobody
Changed in gnome-settings-daemon (Ubuntu Precise):
assignee: nobody → Lars Uebernickel (larsu)
Changed in system-config-printer (Ubuntu Precise):
assignee: nobody → Lars Uebernickel (larsu)
Lars Uebernickel (larsu) wrote :

In precise, indicator-printers handles notifications. It doesn't show a notification in this case at all.

affects: gnome-settings-daemon (Ubuntu Precise) → indicator-printers (Ubuntu Precise)
Changed in indicator-printers (Ubuntu Precise):
status: Triaged → Fix Released
Changed in system-config-printer (Ubuntu Precise):
status: Triaged → Invalid
cement_head (andor-udel) wrote :

This bug is back in Precise.

Alkis Georgopoulos (alkisg) wrote :

I'm using the gnome-fallback session with Ubuntu Precise, as Unity doesn't work with thin clients (LTSP).
The first time I print a job, the notification area shows "Error: connecting-to-device", but printing completes successfully.
This confuses students, which try to send their jobs again, resulting in duplicate prints.

Any plans on fixing this? Where can I help, revise the proposed patch?

Alkis Georgopoulos (alkisg) wrote :

In gnome-fallback, both indicator-printers-service and gsd-printer are running as part of the session.

larsu in IRC suggested the following workaround:
> (11:36:40 μμ) larsu: alkisg, yep, gsd-printer shouldn't be running
> (11:43:19 μμ) larsu: cool, set org.gnome.settings-daemon.plugins.print-notifications.active to false

I did that, and after reboot [*] I got a different printer icon and no messages about the "Error: connecting-to-device" (and no notification about the job being completed either).

So the problem that remains is to set that setting to false by default in the gnome-fallback session.

[*] the reboot was necessary because when I tried powering on my printer right after the setting change, I got an apport window about a gnome-settings-daemon crash.

Alkis Georgopoulos (alkisg) wrote :

I believe the fix about making org.gnome.settings-daemon.plugins.print-notifications default to "false" may be shipped as a patch of the gnome-settings-daemon package, so I put it in the affects list.

$ dpkg -S /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.print-notifications.gschema.xml
gnome-settings-daemon: /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.print-notifications.gschema.xml

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu Oneiric):
status: New → Confirmed
Changed in gnome-settings-daemon (Ubuntu Precise):
status: New → Confirmed
Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers