indicator-printers-service crashed with SIGSEGV in __GI_____strtol_l_internal()

Bug #1703046 reported by siucdude on 2017-07-07
380
This bug affects 77 people
Affects Status Importance Assigned to Milestone
indicator-printers (Ubuntu)
Medium
Andrea Azzarone
Artful
Undecided
Unassigned

Bug Description

[ Impact ]

indicators-printers crashes, notifying the error to the user.

[ Test case ]

This was one of the most hit crash in errors.ubuntu.com. Make sure this will no longer happen once the fix is released.
The link is https://errors.ubuntu.com/problem/43e6488fd8640c6a0cb8ca237286153b5b547f80

[ Regression potential ]

Nothing really possible, other not crashing.

Just got this from the recent update

ProblemType: Crash
DistroRelease: Ubuntu 17.10
Package: indicator-printers 0.1.7+17.04.20170227-0ubuntu1
ProcVersionSignature: Ubuntu 4.11.0-10.15-generic 4.11.8
Uname: Linux 4.11.0-10-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.5-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity:Unity7
Date: Fri Jul 7 16:55:07 2017
ExecutablePath: /usr/lib/x86_64-linux-gnu/indicator-printers/indicator-printers-service
InstallationDate: Installed on 2015-12-17 (567 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
ProcCmdline: /usr/lib/x86_64-linux-gnu/indicator-printers/indicator-printers-service
ProcEnviron:
 LANG=en_US.UTF-8
 PATH=(custom, no user)
 SHELL=/bin/bash
 XDG_RUNTIME_DIR=<set>
SegvAnalysis:
 Segfault happened at: 0x7fa9166826b5 <__GI_____strtol_l_internal+53>: movsbq (%r14),%rax
 PC (0x7fa9166826b5) ok
 source "(%r14)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: indicator-printers
StacktraceTop:
 __GI_____strtol_l_internal (nptr=0x0, endptr=0x0, base=10, group=<optimized out>, loc=0x7fa916a09400 <_nl_global_locale>) at ../stdlib/strtol_l.c:293
 ()
 g_type_create_instance () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_new_valist () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: indicator-printers-service crashed with SIGSEGV in __GI_____strtol_l_internal()
UpgradeStatus: Upgraded to artful on 2017-02-14 (143 days ago)
UserGroups: adm cdrom dip kismet libvirt lpadmin lxd plugdev sambashare sudo ubridge

Related branches

siucdude (siucdude) wrote :
information type: Private → Public

StacktraceTop:
 __GI_____strtol_l_internal (nptr=0x0, endptr=endptr@entry=0x0, base=base@entry=10, group=group@entry=0, loc=0x7fa916a09400 <_nl_global_locale>) at ../stdlib/strtol_l.c:293
 __strtol (nptr=<optimized out>, endptr=endptr@entry=0x0, base=base@entry=10) at ../stdlib/strtol.c:106
 atoi (__nptr=<optimized out>) at /usr/include/stdlib.h:241
 update_all_printer_menuitems (self=0x55714728e520) at indicator-printers-menu.c:223
 g_type_create_instance (type=<optimized out>) at ../../../../gobject/gtype.c:1866

Changed in indicator-printers (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-printers (Ubuntu):
status: New → Confirmed
spike speigel (frail-knight) wrote :

Just happened after the latest round of updates that required a reboot.

Andrea Azzarone (azzar1) on 2017-10-20
Changed in indicator-printers (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
status: Confirmed → In Progress
description: updated
Andrea Azzarone (azzar1) on 2017-11-14
description: updated
Brian Murray (brian-murray) wrote :

In the bug description I was expecting a link to the bucket which is the same crash as this e.g.

https://errors.ubuntu.com/problem/43e6488fd8640c6a0cb8ca237286153b5b547f80

This way the SRU team can easily confirm that the new version of the package does not appear there.

Hello siucdude, or anyone else affected,

Accepted indicator-printers into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/indicator-printers/0.1.7+17.10.20171021-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in indicator-printers (Ubuntu Artful):
status: New → Fix Committed
tags: added: verification-needed verification-needed-artful
Andrea Azzarone (azzar1) on 2017-11-16
description: updated

I've tested indicators-printers version 0.1.7+17.10.20171021-0ubuntu1 and so far no crashes are present.

Also given the simplicity of the change, I think we can safely mark this as verified.

tags: added: verification-done verification-done-artful
removed: verification-needed verification-needed-artful
Changed in indicator-printers (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-printers - 0.1.7+17.10.20171101-0ubuntu1

---------------
indicator-printers (0.1.7+17.10.20171101-0ubuntu1) bionic; urgency=medium

  [ Andrea Azzarone ]
  * According to the documentation cupsGetOptions can return NULL.
    Do not crash if it happens. (lp: #1703046)

 -- Sebastien Bacher <email address hidden> Fri, 17 Nov 2017 16:11:19 +0100

Changed in indicator-printers (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-printers - 0.1.7+17.10.20171021-0ubuntu1

---------------
indicator-printers (0.1.7+17.10.20171021-0ubuntu1) artful; urgency=medium

  [ Andrea Azzarone ]
  * According to the documentation cupsGetOptions can return NULL. Do
    not crash if it happens. (LP: #1703046)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Sat, 21 Oct 2017 23:41:33 +0000

Changed in indicator-printers (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for indicator-printers has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers