indicator-printers not working on Ubuntu 14.04

Bug #1341562 reported by Peter Sewell on 2014-07-14
130
This bug affects 26 people
Affects Status Importance Assigned to Milestone
indicator-printers (Ubuntu)
Undecided
Unassigned

Bug Description

This is a regression from bug 1304434

The bug is still there for quite a lot of users including myself.

Please can the Ubuntu Dev Team look into this bug again for us please.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-printers (Ubuntu):
status: New → Confirmed
Peter Sewell (peter-sewell) wrote :

Bug has been fixed with the latest kernel release.

See bug 1304434

Changed in indicator-printers (Ubuntu):
status: Confirmed → Invalid
zvqra (zvqra3) on 2014-08-06
Changed in indicator-printers (Ubuntu):
status: Invalid → Confirmed
Thomas Mayer (thomas303) wrote :

I updated from 12.04.4 to 14.04 some days ago, but since that, the printers-indicator is missing (I use gnome classic). Any other indicator is displayed. The package indicator-printers is installed according to synaptic.

As of today, my system is up-to-date, including the kernel. I do not use the proposed-repository.

This bug has seen a fix in 1304434, but many people still have the same problem. That's why 1341562 needed to be opened, because another fix seems to be necessary according to the reports in 1304434, which has been closed and will not get any further attention by the development team.

przekop (przekop) wrote :

Stopped working

Ubuntu 32bit
latest kernel 3.13.0.33.39
latest indicator-printers 0.1.7+14.04.20140527-0ubuntu1

Chris Watts (chris-candvwatts) wrote :

I am affected by this too. The interesting and frustrating thing is, though, that I sometimes I do get the print queue icon but I haven't been able to work out what causes it to work or not to work.

Incidentally, if you open System Settings -> Printers and then lock the icon in the launcher before closing it again, the print queue is only a few clicks away; you open the printers dialogue (click on the icon now in the launcher) then either open Printer -> View Print Queue or use the shortcut ctrl-F. A bug-fix would be better, but at least one can work round it for the time being.

Chris Watts (chris-candvwatts) wrote :

Having reflected on my previous comment, maybe there was an update that brought the icon back and shortly afterwards another that removed it again. Nothing I have tried in the way of use brings it back. In case it helps, both of these things must have happened in the last three weeks -- the removing in the last two.

Chris Watts (chris-candvwatts) wrote :

Printer icon consistently coming up today, whenever I send something to the print queue. What's going on? It didn't work yesterday. If someone has updated something, thank you.

Peter Sewell (peter-sewell) wrote :

Chris, This is the same for me - some days it works without any problems and then others it doesn't show up at all. It's a very strange bug.

Chris Watts (chris-candvwatts) wrote :

I can see why this bug is elusive, even to the experts. The icon has stopped appearing for me now. Some random or unnoticed event must be causing it to come and go. If and when I figure out what the event is and can reproduce it I will report back. Otherwise I will not make any further comments. I don't believe only 7 people are affected, only that 7 have noticed the bug. The print queue icon is useful if a job gets held in the queue (because you forgot to turn the printer on or plug it in) or if you suddenly want to cancel a job because you've sent 50 pages to the printer when you only wanted one. We seven are the stupid ones. But we'd still like the bug fixed. Ubuntu is for stupid people like us as well as sensible ones.

João Manuel Rodrigues (jmr) wrote :

I installed 14.04.1 (fresh, not an update) a week ago, and have kept it up-to-date. I have only installed a couple of packages from the standard repositories: vim, java, no fancy stuff.

I configured a couple of network printers (via SMB print server), and noticed that when I print, no indicator appears. Also, the jobs won't start printing until I open the corresponding print queue in the "Printers" configuration application. This may be related to the fact that these printers require user authentication. Anyway, this is an inconvenience that would probably be solved if the indicator-printers applet were running properly.

I am affected from this bug too.

Ubuntu 14.04
Kernel 3.14.0-031400
0.1.7+14.04.20140527-0ubuntu1

Daniel (bsddmail) wrote :

I would like to add that this can not be just 7 users. I run a small PC support business and have several people on Ubuntu 14.04.1 and all have this problem (including me).

Dieter Fauth (fauthd) wrote :

Confirm this bug on 3 14.04 machines. It starts to show up as soon as a machine gets upgraded (from 12.04).
uname -r: 3.13.0-34-generic
indicator-printers:
  Installed: 0.1.7+14.04.20140527-0ubuntu1

Running in Flashback mode.

Chris Watts (chris-candvwatts) wrote :

I think I have spotted what makes this bug happen and what makes the icon work. If I enter my password promptly when the dialog comes up, the icon usually doesn't work. If I delay (e.g. fire up the computer, then go and do something else before coming back to enter my password) it invariably does.

I hope this narrows down the possibilities of what may be causing the bug, e.g. some process that is interrupted by the completion of the password dialog.

Charles Kerr (charlesk) on 2014-11-19
Changed in indicator-printers (Ubuntu):
assignee: nobody → Lars Uebernickel (larsu)
TomasHnyk (sup) wrote :

Yes, I have autologin on, so the indicator never gets displayed. Logging out and in makes it appear. Can other confirm?

Also, I am still on 14.04, is this still the case on the developement version?

Peter Sewell (peter-sewell) wrote :

I can confirm - if you log out and then back in again the printer notification works. 14.04LTS

Coeur Noir (gerald-maruccia-e) wrote :

indicator printer does not show each time a job print is launched.

It's not linked to one particular software, sometimes indicator-printer shows up, sometimes it does not…

Ubuntu 14.04 (unity) regularly updated - kernel 3.16.x

https://forum.ubuntu-fr.org/viewtopic.php?id=1982901

Chris Watts (chris-candvwatts) wrote :

Still no change. Can I elaborate on my observation of 2014-11-14? When the login prompt appears I need to wait at least 10 seconds before entering my password. Then the notification works. It may or may not be relevant that when the login prompt appears, the cursor flashes for just 10 seconds and then stops. There must be some process lasting or continuing for 10 seconds from the appearance of the login prompt (and which may or may not be linked to the appearance of the cursor) that is interrupted when you enter your password.

It is possible to work round this bug, but it is a bug. It would be nice if someone could stamp on it for us.

James (jglossinger) wrote :

The printer indicator seemed to work ok in 15.10, but it is broken again in 16.04

James (jglossinger) wrote :

Ignore my comment about 16.04. (I can't figure out how to delete it.) It seems to work fine.

Changed in indicator-printers (Ubuntu):
assignee: Lars Uebernickel (larsu) → nobody
Chris Watts (chris-candvwatts) wrote :

I agree that this bug is fixed in 16.04 (I didn't try 15.10 -- I only do LTS). Thank you to whoever is responsible.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers