[Precise] power indicator some menu items inaccessible with Orca Screen reader

Bug #953176 reported by Attila Hammer on 2012-03-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
indicator-power
Fix Released
Low
Charles Kerr
indicator-power (Ubuntu)
Low
Unassigned

Bug Description

Dear Developers,

I using Ubuntu Precise with GNOME3 fallback session, and using the Complete indicator panel applet.
I am a screen reader user.
When I activate Super+S keystroke the complete indicator menu system and jump the power indicator, see following menu items if my notebook the battery is present:
- Battery charged (main menu item)
- Show time the menu check menu item (this is the first menu item)
- Power settings
- A silent menu item with Orca identifying "panel", this role text present my braille display. This is the problem.
When I press ENTER this menu item, launching correct with Power statistics preference tool.
Possible associate a label or tooltip this menu item?

Attila

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: indicator-power 1.91-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic-pae 3.2.9
Uname: Linux 3.2.0-18-generic-pae i686
ApportVersion: 1.94.1-0ubuntu2
Architecture: i386
Date: Mon Mar 12 17:30:36 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120308)
SourcePackage: indicator-power
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Attila Hammer (hammera) wrote :
Olli Ries (ories) wrote :

Ted, anything we can do here?

@Attila: we recommend Unity2d for a11y support

Changed in indicator-power:
assignee: nobody → Ted Gould (ted)
importance: Undecided → Low

Hy Olli,

I will be testing this problem in Unity 2d this day.

Attila

Changed in indicator-power (Ubuntu):
importance: Undecided → Low
Bilal Akhtar (bilalakhtar) wrote :

I'm marking this Incomplete until your test with Unity-2d is complete.

Changed in indicator-power (Ubuntu):
status: New → Incomplete
Changed in indicator-power:
status: New → Incomplete
Attila Hammer (hammera) wrote :

Hy,

Sorry the delayed test.
Unfortunately the problem reproducable my machine with Unity 2d too.
Can I attach a video with showing what happening with Unity 2d when my
machine present the battery?

Attila

Changed in indicator-power:
status: Incomplete → New
Charles Kerr (charlesk) wrote :

Attila: yes, please do.

Attila Hammer (hammera) wrote :

Hy Charles,

Sending the Unity 2d produced video.
Now I see an issue, with possible I looking with Orca upstream level.
When I land this silent image or image menu item, my braille display I
see my battery is charged, but this image label Orca are not spokened.
Charge indicator is the purpose this image?
Possible activating any function this image?

If not a big request, please don't close this bug until I not consulting
Joanmarie Diggs Orca developer.

Attila

Attila Hammer (hammera) wrote :

Charles, I compared the GNOME3 fallback session the power indicator
related output.
When I land this silent me unknown menu item, my braille display I see
only "panel" text, not the battery status charge related informations
with Unity 2d sent.
So, possible have two separated issues.
In Unity 2d power indicator related I reported my experiences for Orca
in Bugzilla, I wait Joanie answer what possible doing in Orca side.

Attila

Attila Hammer (hammera) wrote :

Charles, I paste Joanie answer from I reported bug, Orca level not
possible fixing this issue in speech support:
"The bug is the following: The Battery Charge menu item lacks an
accessible name. the fix is for the creator of that menu item to give it
an accessible name.

FWIW:
The other menu items (e.g. power settings...) have accessible names.
That is why the other menu items get spoken.

The reason why you see it in braille is because in braille we display
the full context (i.e. all the parent objects). The menu item in
question has a parent with the same name. We do not want to present the
full ancestry of menu items in speech because then Orca would be
extremely chatty (imagine if Orca spoke
'File New', 'File Save', 'File Save as...' etc.).

This needs to be fixed downstream."

Attila

Charles Kerr (charlesk) on 2012-04-09
Changed in indicator-power:
status: New → Confirmed
Charles Kerr (charlesk) on 2012-04-09
Changed in indicator-power:
assignee: Ted Gould (ted) → Charles Kerr (charlesk)
Charles Kerr (charlesk) on 2012-04-09
Changed in indicator-power:
status: Confirmed → Triaged
Charles Kerr (charlesk) on 2012-04-09
Changed in indicator-power:
status: Triaged → Fix Committed
Charles Kerr (charlesk) on 2012-04-12
Changed in indicator-power:
status: Fix Committed → Fix Released
Charles Kerr (charlesk) on 2012-04-12
Changed in indicator-power:
milestone: none → 2.0
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 2.0-0ubuntu1

---------------
indicator-power (2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    * Make menu items accessible with Orca Screen reader (LP: #953176)
    * Plug memory leaks when updating our icons
 -- Charles Kerr <email address hidden> Wed, 11 Apr 2012 10:12:54 -0500

Changed in indicator-power (Ubuntu):
status: Incomplete → Fix Released
Attila Hammer (hammera) wrote :

Hy,

The indicator power package related fix is great, thank you very mutch
the fix.
If not a big request, anybody possible look following bug with
indicator-sound package related and do a similar fix the volume slider
menu widget?
https://bugs.launchpad.net/bugs/902715
This widget is a silent widget with Orca doesn't possible telling any
informations, and if I using left and right arrow this widget, the
changed volume is doesn't spokening.

I only would like ask one hint:
Some notification type main menu items doesn't have labels or accessible
name/description. For example if happened a crash my system, if I moving
between the indicators main categories, I hear only "menu". If I press
down arrow key, i right hear "crash report" menu item.
Have similar issue some time in keyboard indicator, and some time the
updates related notification main menu.
What packages are need reporting this issue?
Other indicators are great now.

Attila

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers