Battery meter design needs to make both percentage and time statistics easily accessible.

Bug #811777 reported by Jeremy Bicha
228
This bug affects 104 people
Affects Status Importance Assigned to Milestone
indicator-power
Fix Released
Wishlist
Haw Loeung
indicator-power (Ubuntu)
Low
Haw Loeung

Bug Description

indicator-power 0.3-0ubuntu1, Ubuntu 11.10

The power menu option to "show time remaining" is not very useful. The number fluctuates way too much to be constantly visible in the menu bar and is therefore distracting.

If any number should be there, the battery's percent charged won't fluctuate but will go down or up steadily based on whether the laptop is plugged in or not.

In fact, the current design does not show the charge percentage at all. This is in contrast to how other OS's work. My Android phone shows me a % but does not tell me how many minutes I have left. Gnome Shell shows both the time & a percentage: https://live.gnome.org/GnomeShell/Design/Guidelines/SystemStatus/BatteryPower

Suggestions:
1. Replace Show Time Remaining with Show Percentage Remaining (I think a checkbox in Power Settings would be an even better location for this option but I believe we're hesitant to patch System Settings more than is necessary.)
2. Optionally, follow Gnome Shell's design and include the charge percentage on the battery charge line of the power menu.

<https://wiki.ubuntu.com/Power#menu>: "If 'Show Time in Menu Bar' and/or 'Show Percentage in Menu Bar' is checked, the icon should be followed by brackets..."

Related branches

Revision history for this message
Jeremy Bicha (jbicha) wrote :
Revision history for this message
Vish (vish) wrote :

Not really sure how you are basing the "more useful" here, but I'd have to disagree with the current bug report.
What is the first thought that pops into your head when you see " NN% remaining"?
Alteast, in my head it is, "oh! that would be approximately nn mins left or maybe something closer" But I'm always not exactly sure what the percentage really relates to.

From reading the bug report it seems the problem here is "number fluctuates way too much ... and is therefore distracting" ,
maybe we should be looking into fixing the update interval and not how the time is displayed.

Changed in indicator-power (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Changed in indicator-power:
status: New → Incomplete
tags: added: needs-design
Revision history for this message
Jeremy Bicha (jbicha) wrote :

Vish, thanks for the comments. It's not just that the number fluctuates, but that the number is usually wrong.

The time remaining on my laptop just went from "13 hours 2 minutes" to "2 hours 4 minutes" to "1 hour 52 minutes" to "1 hour 58 minutes" within about 2 minutes time of mostly idling. I estimate this laptop gets about 2 hours of battery time. So at 50%, I have about an hour left.

I concede that there's some use for a time estimate but a percentage is nice because it only takes up about 3 characters of space on our symbolic status menu and a simple click to open the menu will show the actual time remaining. I also agree with not showing either the time or percentage by default next to the main tray icon itself but it's a nice power user feature.

Revision history for this message
Javier Jardón (jjardon) wrote :

From IRC:

tedg> And I think we should fix upower to better time instead of going back to percentage.

Revision history for this message
Sam_ (and-sam) wrote :

#2 +1
Percent doesn't tell me how much time is left, which is rather human language (similar to df -h).
I don't experience fluctuance here, notebook usually has ~2:30 after fully charged (which is less due to Bug #760131) and is mostly consistent with conky, in between offset sometimes 1-5 minutes, which is probably due to different update time of both apps.
It also doesn't display the time by default, the option needs to be clicked in the menu.
indicator-power 0.3-0ubuntu1
Compromise may be to add a choice which value a user likes to view.
If it all isn't satisfying there're already indicators created by community.
http://www.omgubuntu.co.uk/2011/02/battery-applet-status-ubuntu/

Revision history for this message
Sam_ (and-sam) wrote :

NotifyOSD shows time and percent, e.g. screenshot, time remaining 16 min. in battery state 17%.

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

The summary of this bug report says "'Show Percentage Remaining' is more useful than 'Show Time Remaining'". As far as I can tell, though, this bug report does not contain any evidence for that, and doesn't even contain any evidence that showing the percentage is useful at all. For that reason, I'm marking it Incomplete.

Without that evidence, I believe that battery percentage -- while easy for a battery to report, and for an OS to display -- is pretty much useless to humans. For example, on the 2008 MacBook running Ubuntu that I'm using right now, 98% means about 2 hours remaining. On my 2011 MacBook running Mac OS X, 98% means about 10 hours remaining. That's a fivefold difference in how long I can use the computer, represented by exactly the same percentage value.

It may be true that on some machines, the time estimate changes too much and/or too often to be useful either. If so, then as Vish and Ted have suggested, that is a fixable bug. (Sample from more minutes, and/or give less emphasis to recent changes in the charge level, and/or cater for old batteries by reversing the charge curve from the previous cycle.) Making the time estimate less prominent would not fix that bug. And showing the percentage would not improve the situation at all -- because in the absence of a time estimate, your brain would be estimating the time based on the rate of percentage decline, and that rate would be fluctuating exactly as much.

Percentage might be interesting to someone troubleshooting a battery problem, or investigating whether a battery is worn out. So it is useful to show it in the Power Statistics window, where it already is. I would be happy to help anyone who would like to make that window more understandable.

Changed in ayatana-design:
status: New → Incomplete
Revision history for this message
Jeremy Bicha (jbicha) wrote :

Ok, fair enough. I personally prefer the percentage but perhaps the design goals are different & perhaps time left (if it works) is more useful than a percentage. I'll quote my original report for the only support I have for my opinion:

"This is in contrast to how other OS's work. My Android phone shows me a % but does not tell me how many minutes I have left. Gnome Shell shows both the time & a percentage: https://live.gnome.org/GnomeShell/Design/Guidelines/SystemStatus/BatteryPower "

Javier Jardón (jjardon)
Changed in indicator-power:
status: Incomplete → Opinion
Changed in indicator-power (Ubuntu):
status: Incomplete → Opinion
Revision history for this message
Matty Lamb (mooosepurchases) wrote :

Here are several reasons why "percent remaining" is a useful statistic:
--Power consumption varies, making "time remaining" less accurate. Yes, if we can improve the estimate, then by all means, we should do so, but that doesn't change the fact that percent remaining is more precise and accurate. It can also be more useful when the user is going to switch to a different sort of task, as it will drain the battery at a different rate.
--The battery percentage is FAR more important to users who are concerned about managing battery health.
===Batteries have to be stored at the proper charge level (which is impossible to deduce from "time remaining" since as the battery's overall capacity decreases, this statistic will change, while the percentage will not).
===To maintain battery health, it is necessary to start charging the battery at a particular percentage (for batteries where "memory" is an issue, a full discharge is recommended. For Lithium ion batteries, which are the standard for laptops, it's around 10-20 percent).
--Some users prefer "percent remaining (to charge)" to "time remaining (to charge)." When possible, good interfaces accommodate user preference. This alone is sufficient reason to give the user more options.

The current design makes this statistic less accessible and limits user choice. Currently, when you click on the battery icon, it displays the time remaining (time to charge), gives you the option of putting this info in the menu bar, and does NOT display the percentage. This is a poor design because:
it decreases user control over what statistics are being displayed (giving the user options is BETTER)
it makes the other statistic (percent remaining) harder to find. One has to either look at battery statistics (which doesn't display percentage when battery is charging), power system settings, or use the terminal.
Additionally, both statistics are most useful when used in conjunction with the other, so user experience can be improved by making both accessible regardless of preference.

A better design is to give the user the option to display EITHER the time remaining OR the percentage, and displaying the other statistic when you click on the battery icon. This would increase customization make both statistics accessible, resulting in a better user experience.

summary: - "Show Percentage Remaining" is more useful than "Show Time Remaining"
+ Battery meter design needs to make percentage and time statistics easily
+ accessible.
summary: - Battery meter design needs to make percentage and time statistics easily
- accessible.
+ Battery meter design needs to make both percentage and time statistics
+ easily accessible.
Revision history for this message
Leonardo Brás (leonardobsp) wrote :

There are good points for both sides.
There are people that likes percentage, others prefer seeing the time remaining, so why not make easy to choose whichever the user want?

I mean, is that hard to make it possible?

Revision history for this message
Leonardo Brás (leonardobsp) wrote :

For those who prefer percentage, i made a PPA with a little hack to show percentage instead time remaining:

https://launchpad.net/~leonardobsp/+archive/indicator-upower-percentage

I hope you like. :)

Changed in ayatana-design:
status: Incomplete → New
assignee: nobody → Matthew Paul Thomas (mpt)
Revision history for this message
Matthew Paul Thomas (mpt) wrote :

Matty Lamb, thanks for those reasons. I don't understand the relevance of "percent remaining is more precise and accurate", if people are just going to use that percentage to inaccurately calculate time remaining anyway. And "some users prefer percent remaining" is assuming the question; it's not our job to make it easy for people to mislead themselves.

However, your other points are interesting: "Batteries have to be stored at the proper charge level" and "To maintain battery health, it is necessary to start charging the battery at a particular percentage". Do you have references that either or both of those do help battery life? If so, we could help people achieve those goals somehow. Maybe by showing the percentage in the menu. Or maybe by something smarter, such as giving people the option to run down the battery to the ideal level when they switch off the computer. Or maybe both.

Revision history for this message
Matty Lamb (mooosepurchases) wrote :

First, I still think there is a good argument for percentage as a useful statistic because your time remaining is a function of what you're using your computer for (gaming/video editing/flash vs word processing), while the percentage is not. Granted, users are going to make very rough estimates, but eh. As I said in my prior post, I think that both statistics are more useful when you can access both of them.

From what I've gathered, the most important factor in maintaining battery health is temperature. High temperature = bad. Kind of hard to fix in software though.

This table summarizes a bunch of does and don'ts. Almost all laptop batteries these days are Lithium Ion batteries. http://batteryuniversity.com/learn/article/do_and_dont_battery_table

When you store a battery, it unavoidably loses some capacity (not charge--capacity, ie, your battery used to store 1000 mAh, now only stores 800 mAh overall effect is that your 100% charged battery doesn't last as long). You can reduce this effect by storing batteries at about 40% discharge (ie, charge to 100%, discharge to 40%, store). This table compares battery storage at 100% and at 40%: http://batteryuniversity.com/learn/article/how_to_store_batteries
Also here is a nice picture illustrating capacity loss: http://batteryuniversity.com/learn/article/capacity_loss

Old batteries like Nickle Cadnium had a "memory effect" where the battery would "forget" how much capacity it actually had unless you fully dischared it and then fully recharged it. Lithium Ion batteries DO NOT have this behavior, and it is generally better for the battery to AVOID a full discharge. This is because repeated partial discharges of the battery increase the total number of charge cycles. Practically speaking this means you want to start charging the battery when it's at 20-30% instead of at zero. This page has a table summarizing the result: http://batteryuniversity.com/learn/article/how_to_prolong_lithium_based_batteries

The references I've used here are from batteryuniviersity.com because their site has nice sections and I can link you to specific things. Here are some more sources that give good overviews of how to maximize battery life:
http://www.mpoweruk.com/life.htm (this goes into some of the chemistry of batteries)
http://forum.notebookreview.com/hardware-components-aftermarket-upgrades/91846-notebook-battery-guide.html#post1696318 (A good practical guide, though he recommends monthly full discharges to calibrate the battery which is not good practice with lithium ion batteries)
http://en.wikipedia.org/wiki/Lithium-ion_battery#Prolonging_battery_pack_life (of course Wikipedia has something to say)

I hope this is helpful. Have a nice day.

Changed in ayatana-design:
importance: Undecided → Medium
Revision history for this message
Jared Buckley (buckjrdley) wrote :

First of all, thanks for the hack Leonardo. Worked perfectly for me.

I typically use my laptop on battery power for simple scientific calculations, using it mostly as a desk calculator; however, I do run into times when I need to run more demanding programs, which require higher cpu loads to solve differential equations. The normal light load during simple calculations causes an artificially extended battery life to be reported, since the sudden increase in load from the more demanding program will consume power at a faster rate. I typically solve this by looking at the battery percentage, to see if I've got enough juice left to execute the calculation.

Although I don't think it should be classified as a "bug," it would be nice to have an officially supported way to show battery percentage as opposed to time remaining next to the battery icon.

Revision history for this message
Greg A (etulfetulf) wrote :

I just reported bug #1029339 ("Battery time remaining fluctuates wildly, despite charge declining predictably") which is directly related to this bug and mpt's comments in comment 7.

John Lea (johnlea)
summary: - Battery meter design needs to make both percentage and time statistics
- easily accessible.
+ Menu Bar - Battery meter design needs to make both percentage and time
+ statistics easily accessible.
Changed in ayatana-design:
importance: Medium → Undecided
tags: added: quantal unity
Adolfo Jayme (fitojb)
Changed in indicator-power:
status: Opinion → Confirmed
Changed in indicator-power (Ubuntu):
status: Opinion → Confirmed
Changed in ayatana-design:
assignee: Matthew Paul Thomas (mpt) → nobody
Changed in indicator-power (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
Charles Kerr (charlesk)
Changed in indicator-power:
importance: Undecided → Wishlist
Revision history for this message
Matthew Paul Thomas (mpt) wrote : Re: Menu Bar - Battery meter design needs to make both percentage and time statistics easily accessible.

A belated thanks to Matty Lamb for the detailed and persuasive rationale. I've updated the specification to include a "Show Percentage in Menu Bar" item, and to describe how the percentage should be displayed. <https://wiki.ubuntu.com/Power?action=diff&rev2=37&rev1=36>

Changed in indicator-power (Ubuntu):
assignee: Matthew Paul Thomas (mpt) → nobody
status: Confirmed → Triaged
no longer affects: ayatana-design
description: updated
summary: - Menu Bar - Battery meter design needs to make both percentage and time
- statistics easily accessible.
+ Battery meter design needs to make both percentage and time statistics
+ easily accessible.
Revision history for this message
papukaija (papukaija) wrote :

There is also a related bug 884038 to get back support for opening the remaining battery time in the OSD with Fn+F2.

Haw Loeung (hloeung)
Changed in indicator-power:
assignee: nobody → Haw Loeung (hloeung)
Changed in indicator-power (Ubuntu):
assignee: nobody → Haw Loeung (hloeung)
Changed in indicator-power:
status: Confirmed → In Progress
Changed in indicator-power (Ubuntu):
status: Triaged → In Progress
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:indicator-power at revision None, scheduled for release in indicator-power, milestone Unknown

Changed in indicator-power:
status: In Progress → Fix Committed
Charles Kerr (charlesk)
Changed in indicator-power:
status: Fix Committed → Fix Released
Changed in indicator-power (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers