Ubuntu

Power Menu should respect icon-policy hide setting

Reported by Jeremy Bicha on 2011-07-17
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon
Invalid
Wishlist
indicator-power
High
Charles Kerr
indicator-power (Ubuntu)
Undecided
Charles Kerr

Bug Description

In previous Ubuntu releases, the power menu has been hidden by default when the computer is fully charged. I'd like to see this continue for Ubuntu 11.10. gnome-power-manager includes a setting for when the Gnome Shell version of the battery menu should be shown. indicator-power should respect this setting but at the moment it appears to be ignored.

To test:
1. Run this command to set the power menu to hide when the laptop is fully charged.
gsettings set org.gnome.power-manager icon-policy charge
2. With a fully charged laptop, the menu should be hidden. Unplugging the laptop should cause the menu to appear and plugging the laptop back in should cause the menu to hide again (after the laptop is fully charged).

<https://wiki.ubuntu.com/Power#Power_settings>: "At the bottom of the “Power” panel of System Settings should be a “Show battery status in the menu bar:” menu, with options “When battery is present”, “When battery is charging/in use”, and “Never”. By default, the setting should be “When battery is present”."

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: indicator-power 0.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-5.6-generic 3.0.0-rc7
Uname: Linux 3.0.0-5-generic x86_64
Architecture: amd64
Date: Fri Jul 15 16:40:57 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
SourcePackage: indicator-power
UpgradeStatus: Upgraded to oneiric on 2011-06-17 (28 days ago)

Jeremy Bicha (jbicha) wrote :
Javier Jardón (jjardon) wrote :

Hello Jeremy, thanks for your bug report. I'm following the design from this page: https://wiki.ubuntu.com/Power

There, you can read this:

"By default, the setting should be “When battery is present”. (If the menu disappeared whenever the thing was fully charged, this would make it difficult to realize that it was fully charged.)"

I'll discuss with the desingers about the possibility to hide the battery icon automatically, so we do not need to patch gnome-control-center

Javier Jardón (jjardon) wrote :

Indeed, IMHO we should follow upstream and show the icon always by default.

The icons represent system status. connected ac and fully charged is part of that status.
Also, there is not a key to configure this anymore, It was remove with the move of gnome-power-manager to gnome-settings-daemon)

Jeremy Bicha (jbicha) wrote :

Javier, there is still a gsettings key to configure when the power icon should be shown. And this bug is that indicator-power should follow that setting.

In Ubuntu right now, it is set to hide when fully charged. You are correct that the GNOME default is to always show when there is a battery. As far as I can tell from the changelog, we've been overriding this default for over 5 years.

Javier Jardón (jjardon) wrote :

@Jeremy: "org.gnome.power-manager icon-policy" will be removed in GNOME 3.2, as gnome-power-manager code is being moved to gnome-settings-daemon, where there is not a key to configure this.

Anyway, the question is; why would you want to hide the icon?

Jeremy Bicha (jbicha) wrote :

I expect that key to migrate to g-s-d like most power settings have.

Ubuntu for over 5 years has hidden that icon by default, which is as long as I've been using Ubuntu, so I'm rather attached to that functionality. If my battery is fully charged & plugged in then I don't want to see an icon. I am trained now that seeing a battery icon is a subtle warning that I am on battery power or waiting for my computer to finish charging.

It's one thing to change a default (which I think should be a separate discussion) but it's another to change the default and completely remove any way to get the olddefault back. The specification does say that this should be an option, possibly through System Settings, or perhaps via gsettings/dconf-editor.

By the way, does this menu /always/ show up, even on desktop computers without battery peripherals?

Javier Jardón (jjardon) wrote :

From IRC:

tedg> I don't think it should hide when full though... that seems like a support call waiting to happen.

Jeremy Bicha (jbicha) wrote :

In response to the previous comment, Ubuntu has been shipping this way for 5 years and I haven't heard of support calls or angry users due to this.

But it turns out that you were right that this gsettings key was removed from GNOME now so if we want this, we'll have to use our own key.

Changed in gnome-settings-daemon:
importance: Unknown → Wishlist
status: Unknown → New
Changed in indicator-power (Ubuntu):
status: New → Confirmed
Chris Coulson (chrisccoulson) wrote :

I don't think we should be hiding it when fully charged either. I've always found that behaviour confusing, as it's not obvious to the user whether the icon hiding has any significant meaning. In addition to that, the menu provides access to some features that I might want to use regardless of whether my battery is charging or not (eg, power settings/power statistics). Why would it make sense to hide those options when my battery is charged?

Jeremy Bicha (jbicha) wrote :

Chris, it looks like GNOME feels the same way. They've removed the ability to hide their power menu.

Matthew Paul Thomas (mpt) wrote :

Unfortunately this bug report seems to have mixed three distinct issues.

First, it asks for the default setting to be reverted from showing whenever there is a battery (Gnome behavior) to showing only when charging/discharging (previous Ubuntu behavior). Javier has quoted the part of the specification where I explained why I think the Gnome behavior is better. The counterarguments posted to that have been "I'm rather attached to that functionality" and "Ubuntu has been shipping this way for 5 years and I haven't heard of support calls or angry users due to this". For the former, it should take about 20 seconds to restore the old behavior. For the latter, a Web search finds numerous examples:
<http://ubuntuforums.org/showthread.php?t=1334167>
<http://ubuntuforums.org/showthread.php?t=1665580>
<http://jaypeeonline.net/tips-tricks/howto-add-ubuntu-battery-power-applet/>
<http://ubuntuforums.org/showthread.php?t=1566976>
<http://ubuntuforums.org/showthread.php?t=1687349>

Second, that there should be an interface for people who (like Jeremy) do want to change the behavior. I've specified how this interface should look and work.

Third, that the interface should follow the existing setting for people who are upgrading ("this bug is that indicator-power should follow that setting"). I have no opinion on that, except that if it's possible to tell that someone did not customize the behavior at all, it may make sense to migrate them to the new default.

Changed in ayatana-design:
assignee: nobody → Matthew Paul Thomas (mpt)
status: New → Fix Committed
Changed in gnome-settings-daemon:
status: New → Invalid
zhiwei (chenzhiwei) wrote :

hi,Matthew Paul Thomas.
I want to know when would I hide the battery icon if the power is fully charged ?

The battery is full means that it works all right, so it should be hidden in order to give space to useful applications.

The battery icon do not like network icon, I often change the network setting(so, network icon should show all the time on top panel), but I rarely change the power settings (so, if the power is fully charged, the icon should be hidden).

Matthew Paul Thomas (mpt) wrote :

zhiwei, you will be able to do that when this bug is fixed.

zhiwei (chenzhiwei) wrote :

Thank you!

John Lea (johnlea) on 2011-10-18
Changed in ayatana-design:
status: Fix Committed → Confirmed
Josh Mckibbin (joshmckibbin) wrote :

I think another solution or option (for those that want an icon to remain), would be to have the icon change from a battery icon to a plug icon once the battery is charged, instead of disappearing altogether.

Changed in ayatana-design:
importance: Undecided → High
Changed in indicator-power:
importance: Undecided → High
Matthew Paul Thomas (mpt) wrote :

Since (according to Javier) the org.gnome.power-manager icon-policy key has been abandoned, either this bug report is Invalid, or it should be used to track reimplementation of the setting (not necessarily with the same key name). The latter seems more useful.

description: updated
no longer affects: ayatana-design
Changed in indicator-power:
status: New → Triaged
Charles Kerr (charlesk) on 2012-01-30
Changed in indicator-power (Ubuntu):
assignee: nobody → charles (charlesk)
Changed in indicator-power:
assignee: nobody → charles (charlesk)
status: Triaged → In Progress
Changed in indicator-power (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 1.90-0ubuntu1

---------------
indicator-power (1.90-0ubuntu1) precise; urgency=low

  * New upstream release.
    * Support for hiding of icon and settings for it as well (lp: #811769)
    * Adding a name hint
 -- Ted Gould <email address hidden> Tue, 14 Feb 2012 16:26:48 -0600

Changed in indicator-power (Ubuntu):
status: In Progress → Fix Released
Michael Terry (mterry) on 2012-02-15
Changed in indicator-power:
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.