Battery indicator turns red at 30% on desktop

Bug #1559731 reported by Omer Akram
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Unassigned
indicator-power (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

The indicator turns red as soon as battery goes 30%

Please refer to the attached screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: indicator-power 12.10.6+16.04.20160105-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-14.30-generic 4.4.5
Uname: Linux 4.4.0-14-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Mar 20 20:43:32 2016
InstallationDate: Installed on 2016-03-18 (1 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160313)
SourcePackage: indicator-power
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Omer Akram (om26er) wrote :
Changed in indicator-power (Ubuntu):
importance: Undecided → High
Revision history for this message
Omer Akram (om26er) wrote :

In modern computers where battery life lasts 4-6 hours normally, I would expect the icon to go red at 10% and the really critical point should be 4%

Revision history for this message
Samarth Mathur (samarth-math) wrote :

I agree, I keep charging my laptop, because it gets red at 30%, which is just annoying!

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-power (Ubuntu Xenial):
status: New → Confirmed
Changed in indicator-power (Ubuntu):
status: New → Confirmed
Charles Kerr (charlesk)
Changed in indicator-power (Ubuntu):
importance: High → Medium
Changed in indicator-power (Ubuntu Xenial):
importance: High → Medium
Revision history for this message
Charles Kerr (charlesk) wrote :

This looks like a Desktop variation of bug #1388235. The solution there was to provide extra icons for 10%, 30%, 50%, 70%, and 90% so that we could improve our accuracy when rounding to the closest icon, and also to special case the rounding between [20-30%) to avoid hitting the red-at-20% icons from not just our own icon sets but others eg Humanity.

I'm seeing the same behavior on my Xenial box when I set the battery to 28%. The icon list sent by indicator-power is correct:

> {"battery-030", "gpm-battery-030", "battery-020", "gpm-battery-020", "battery-low-symbolic", "battery-low"}

So the rounding rules described in bullet point #2 of https://bugs.launchpad.net/ubuntu/+source/indicator-power/+bug/1388235/comments/5 are working correctly and things look great on devices with suru icons. The problem for the Desktop is that bullet point #3 is incorrect:

> indicator-power keep providing the current icon names as fallbacks so that this fix doesn't break compatibility with other icon themes

Because ?keeping the current icon names as fallbacks" means the problem still persists in other icon sets. We should tweak the special case rule for [20-30%) s.t. the fallback icon is *040* instead of *020*, e.g.:

- {"battery-030", "gpm-battery-030", "battery-020", "gpm-battery-020", "battery-low-symbolic", "battery-low"}
+ {"battery-030", "gpm-battery-030", "battery-040", "gpm-battery-040", "battery-low-symbolic", "battery-low"}

Changed in indicator-power (Ubuntu):
status: Confirmed → Triaged
Changed in indicator-power (Ubuntu Xenial):
status: Confirmed → Triaged
Charles Kerr (charlesk)
Changed in indicator-power (Ubuntu):
status: Triaged → In Progress
Charles Kerr (charlesk)
summary: - Battery indicator turns red at 30%
+ Battery indicator turns red at 30% on desktop
Changed in indicator-power (Ubuntu):
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Changed in canonical-devices-system-image:
status: New → Fix Committed
importance: Undecided → Medium
milestone: none → 12
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+16.04.20160516.1-0ubuntu1

---------------
indicator-power (12.10.6+16.04.20160516.1-0ubuntu1) xenial; urgency=medium

  * Fix the fallback power icon so the battery icon doesn't show red
    above 20% even when the Suru icon theme isn't present. (LP:
    #1559731)
  * Use the fdo 'sound-file' hint to play a sound when a low battery
    notification is shown.

 -- Charles Kerr <email address hidden> Mon, 16 May 2016 21:33:32 +0000

Changed in indicator-power (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Omer, or anyone else affected,

Accepted indicator-power into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/indicator-power/12.10.6+16.04.20160708-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in indicator-power (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Revision history for this message
Anita Kuno (anteaya) wrote :

I don't know if this is the same bug or not but my laptop decided it was critically low and shut itself off while the battery indicated it still had about 3+ hours of life left. I couldn't power it back on until I plugged in ac and at that point it was over 80% of battery life. I don't think this is caused by a 30% icon. If you want me to open up a new bug, I can do so but the title at least looks the same.

Thank you,
Anita.

Revision history for this message
Anita Kuno (anteaya) wrote :

It appears the solution to my problem was to use the dconf-editor and set org.settings-daemon.plugins.power.critical-battery-action to nothing. My laptop currently displays 19% battery life and continues to work. Thanks, Anita.

Revision history for this message
Ewan (ewann) wrote :

In my test indicator still turns red at 29% after this proposed update installed:

apt list indicator-power -a
Listing... Done
indicator-power/xenial-proposed,now 12.10.6+16.04.20160708-0ubuntu1 amd64 [installed,automatic]
indicator-power/xenial 12.10.6+16.04.20160105-0ubuntu1 amd64

If you would like additional info please list out what is useful.

tags: added: verification-failed
removed: verification-needed
Revision history for this message
Martin Pitt (pitti) wrote : Proposed package removed from archive

The version of indicator-power in the proposed pocket of Xenial that was purported to fix this bug report has been removed because the bugs that were to be fixed by the upload were not verified in a timely (105 days) fashion.

Changed in indicator-power (Ubuntu Xenial):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers