[indicators] Battery icon turns red at 30%

Bug #1388235 reported by Pat McGowan
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Thomas Strehl
Ubuntu UX
Medium
Paty Davila
indicator-power (Ubuntu)
High
Charles Kerr
ubuntu-themes (Ubuntu)
Wishlist
Matthieu James
ubuntu-themes (Ubuntu RTM)
Undecided
Unassigned

Bug Description

This seems a bit pessimistic since the phone still has a great deal of capacity and time left, perhaps 15 or 20% is a better threshold

Related branches

Oliver Grawert (ogra)
Changed in ubuntu-ux:
status: New → Confirmed
Changed in indicator-power (Ubuntu):
status: New → Confirmed
summary: - Icon turns red at 30%
+ Battery icon turns red at 30%
Revision history for this message
Ricardo Salveti (rsalveti) wrote : Re: Battery icon turns red at 30%

I'd just follow what we have with some other phones, and showing low battery only when < 15%

Revision history for this message
Paty Davila (dizzypaty) wrote :

@rsalveti - According to the current indicators specs, the charge level should be visually supported through the different states of the battery indicator icon (i.e. 20%, 40%, 60%, 80%,100% & battery charged) in the status bar (https://drive.google.com/a/canonical.com/#folders/0BzbnWoHmYF3ablBITVByRnpzdEk)

In this case, when the phone drops below 20% power, the battery indicator should turn red giving a nudge to recharge.

Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

@charles can you check, seems its not doing it per spec or maybe theme is wrong

Changed in indicator-power (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
Revision history for this message
Charles Kerr (charlesk) wrote :

So, what the spec says is:

> * The charge level should be visually supported through the different states of the battery indicator icon (i.e. 20%, 40%, 60%, 80%,100% & battery charged) in the status bar.
> * When the phone drops below 20% power, the battery indicator should turn red giving a nudge to recharge.

I-power currently picks the closest match of the -000, -020, -040, -060, -080, and -100 icons; e.g. a charge of 51% will get the -060 icon, and a charge of 49% will get the -040 icon. This is /usually/ The Right Thing because it minimizes the difference between the icon level and the actual battery level.

However this does mean 29% shows red. So we need a special case to treat the 20-30% range as a special case that deviates from the "closest match" approach, such as:

[0%..10%) battery-000
[10%..20%) battery-020
[20%...50%) battery-040
[50%..70%) battery-060
[70%..90%) battery-080
[90%..100%] battery-100

This works but isn't a great fix because the icon-to-label shear can be up to 20%: if the battery is at 20%, the label will read 20% and the icon will show 40%.

We also can't just change the 20% icon to black because we also want to maintain compatibility with other in-house and third-party icon themes on Desktop.

IMO we should do the closest match / special case approach listed above but ALSO add new charging/discharging icons for battery-010, -030, -050, -070, and -090. i-power would generally match to the nearest 10% icon, add a special case for [20-25%], and use the existing GNOME icon names as fallbacks.fallbacks.

This approach would:

(a) Fix this bug

(b) Not regress on icon-to-label shear. (Currently the max is 10%, under this scheme the worst case would be a battery at 20% and an icon at -030) and in the general case it would /reduce/ the shear since we'd be matching to the closest 10% instead of closest 20%.

(c) Maintain compatibility with other desktop icon themes by using the current names as fallbacks

Changed in ubuntu-themes (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Charles Kerr (charlesk) wrote :

To be a little more precise about the previous comment, I suggest:

1. that ubuntu-themes add new icons:

* ubuntu-mobile/status/scalable/battery-010.svg
* ubuntu-mobile/status/scalable/battery-010-charging.svg
* ubuntu-mobile/status/scalable/battery-030.svg
* ubuntu-mobile/status/scalable/battery-030-charging.svg
* ubuntu-mobile/status/scalable/battery-050.svg
* ubuntu-mobile/status/scalable/battery-050-charging.svg
* ubuntu-mobile/status/scalable/battery-070.svg
* ubuntu-mobile/status/scalable/battery-070-charging.svg
* ubuntu-mobile/status/scalable/battery-090.svg
* ubuntu-mobile/status/scalable/battery-090-charging.svg

2. that indicator-power try to match to the closest 10% =except= for [20-25%] which would be special cased to -030 to avoid the red 20% icon:

[0%..5%) battery-000
[5%..15%) battery-010
[15%..19%) battery-020
[20%..35%) battery-030
[35%..45%) battery-040
[45%..55%) battery-050
[55%..65%) battery-060
[65%..75%) battery-070
[75%..85%) battery-080
[85%..95%) battery-090
[95%..100%] battery-100

3. that indicator-power keep providing the current icon names as fallbacks so that this fix doesn't break compatibility with other icon themes

Revision history for this message
Charles Kerr (charlesk) wrote :

According to Paty in IRC, this is fine with Design and tiheum's going to add the new needed icons.

Changed in indicator-power (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntu-themes (Ubuntu):
status: New → In Progress
assignee: nobody → Matthieu James (tiheum)
Charles Kerr (charlesk)
Changed in indicator-power (Ubuntu):
importance: Undecided → High
Changed in ubuntu-ux:
assignee: nobody → Vesa Rautiainen (vesar)
importance: Undecided → Medium
Vesa Rautiainen (vesar)
Changed in ubuntu-ux:
assignee: Vesa Rautiainen (vesar) → Paty Davila (dizzypaty)
Revision history for this message
Christoph Buchner (bilderbuchi) wrote :

Also, please keep e.g. laptop use in mind when designing this. I'm currently on a laptop, and the battery indicator shows a red-with-a-little-left icon, when I have 1h10min of battery left (which feels a bit ridiculous). The percentage is at 22%.
See also the previous bug #743823, which apparently has regressed since 2011?

summary: - Battery icon turns red at 30%
+ [indicators] Battery icon turns red at 30%
Changed in ubuntu-ux:
status: Confirmed → Triaged
Changed in canonical-devices-system-image:
importance: Undecided → Medium
milestone: none → ww07-2015
status: New → In Progress
tags: added: usability
Changed in canonical-devices-system-image:
assignee: nobody → Thomas Strehl (strehl-t)
milestone: ww07-2015 → ww09-2015
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+15.04.20150212-0ubuntu1

---------------
indicator-power (12.10.6+15.04.20150212-0ubuntu1) vivid; urgency=medium

  [ Charles Kerr ]
  * Use the new power level icons for a more accurate display of the
    battery level. (LP: #1388235)
 -- CI Train Bot <email address hidden> Thu, 12 Feb 2015 22:45:30 +0000

Changed in indicator-power (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 14.04+15.04.20150212-0ubuntu1

---------------
ubuntu-themes (14.04+15.04.20150212-0ubuntu1) vivid; urgency=medium

  [ Matthieu James ]
  * Added battery icons for more charge levels: 10%, 30%, 50%, 70% and
    90%. (LP: #1388235)
 -- CI Train Bot <email address hidden> Thu, 12 Feb 2015 22:46:11 +0000

Changed in ubuntu-themes (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 14.04+15.04.20150217~rtm-0ubuntu1

---------------
ubuntu-themes (14.04+15.04.20150217~rtm-0ubuntu1) 14.09; urgency=medium

  [ Charles Kerr ]
  * Add new power icons for bug #1388235 (LP: #1388235)
 -- CI Train Bot <email address hidden> Tue, 17 Feb 2015 16:43:29 +0000

Changed in ubuntu-themes (Ubuntu RTM):
status: New → Fix Released
Paty Davila (dizzypaty)
Changed in ubuntu-ux:
status: Triaged → Fix Released
Revision history for this message
Charles Kerr (charlesk) wrote :

See also bug #1559731

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers