Auto brightness toggle sometimes doesn't appear in power indicator

Bug #1382861 reported by Mitchell on 2014-10-18
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Thomas Strehl
indicator-power (Ubuntu)
Critical
Charles Kerr
Vivid
Undecided
Unassigned

Bug Description

On build #5 in the ubuntu-touch/ubuntu-rtm/devel channel, the auto brightness toggle is sometimes missing in the power indicator. Sometimes everything is fine and sometimes it's simply not there.

Related branches

Niklas Wenzel (nikwen) wrote :

It's still there for me.

Changed in indicator-power (Ubuntu):
status: New → Incomplete
Niklas Wenzel (nikwen) wrote :

Ok, I confirmed this but modified the bug description according to the discussion here: https://lists.launchpad.net/ubuntu-phone/msg10258.html

Changed in indicator-power (Ubuntu):
status: Incomplete → Confirmed
description: updated
Niklas Wenzel (nikwen) wrote :

Hoping that it's of help to you, I'll attach my log file.

Niklas Wenzel (nikwen) wrote :

Screenshot.

summary: - Auto brightness toggle removed from power indicator
+ Auto brightness toggle sometimes doesn't appear in power indicator
Niklas Wenzel (nikwen) wrote :

To add some information which might be valuable:

If the option does not appear in the indicator, then it has already not been there since boot time. If it is available at boot, it won't disappear. If it's not available at boot, it won't appear later.

Michal Predotka (mpredotka) wrote :

I have this problem on bq phone as well.

Pat McGowan (pat-mcgowan) wrote :

This is being reported more often and on all hardware
The check that the device supports autobrightness seems unreliable.

Changed in indicator-power (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
importance: Undecided → Critical
Changed in canonical-devices-system-image:
assignee: nobody → Thomas Strehl (strehl-t)
importance: Undecided → Critical
milestone: none → ww22-2015
status: New → Confirmed
Charles Kerr (charlesk) on 2015-05-15
Changed in indicator-power (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+15.10.20150515-0ubuntu1

---------------
indicator-power (12.10.6+15.10.20150515-0ubuntu1) wily; urgency=medium

  [ Charles Kerr ]
  * Fix timing issue that caused "Adjust brightness automatically"
    menuitem to sometimes not be shown. (LP: #1382861)

 -- CI Train Bot <email address hidden> Fri, 15 May 2015 16:40:33 +0000

Changed in indicator-power (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-power (Ubuntu Vivid):
status: New → Confirmed
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers