Phone doesn't alert user of critical power situations

Bug #1296431 reported by Alan Pope 🍺🐧🐱 🦄 on 2014-03-23
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
indicator-power (Ubuntu)
Critical
Charles Kerr

Bug Description

The phone doesn't currently alert the user when the battery is critical.
This leads to power loss at times and the user doesn't know it's about to happen or had happened.
e.g. during a call, or while listening to music. Also if the phone is sat on the desk unplugged from power connection.

<https://wiki.ubuntu.com/Power#Warnings>: "When the device’s battery/batteries are discharging and reach — or begin discharging and already have — 1 hour or less remaining (PC) or 20% or less remaining (phone/tablet), a notification bubble should appear ... When the device’s battery/batteries are discharging and reach — or begin discharging and already have — 30 minutes or less remaining (PC) or 10% or less remaining (phone/tablet), an alert should appear..."

Related branches

Charles Kerr (charlesk) on 2014-03-23
Changed in indicator-power (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
status: New → Confirmed
Charles Kerr (charlesk) wrote :

Assigning mpt for Design guidance on how to notify the user of low battery situations, such as when and how to notify users.

The spec currently mentions "Be warned of low battery" by "bubble notification, alert" on both the PC and Phone.

On the PC, this role is currently filled by gnome-settings-daemon, which makes bubble notifications with the strings listed in engine_charge_critical() at <https://git.gnome.org/browse/gnome-settings-daemon/tree/plugins/power/gsd-power-manager.c#n518>

Matthew Paul Thomas (mpt) wrote :

Coincidentally, I just started designing this on Friday. <https://wiki.ubuntu.com/Power?action=diff&rev2=63&rev1=61> It's not quite done; the notification bubble should have an icon on Touch just as it does on the PC.

Pat McGowan (pat-mcgowan) wrote :

Would be nice to provide this, just hit the update button prior to an emergency shutdown on the nexus.
The design says warn at 20% on phone, that seems quite high since it should be as long as a days use remaining.

Changed in indicator-power (Ubuntu):
status: Confirmed → In Progress
Matthew Paul Thomas (mpt) wrote :

Specification updated.
<https://wiki.ubuntu.com/Power?action=diff&rev2=63&rev1=61>
<https://wiki.ubuntu.com/Power?action=diff&rev2=66&rev1=65>

I'll insert my usual misgiving here about non-indicator-related notifications being provided by indicator code. We should have low-power notifications regardless of whether indicator-power is running or even exists.

Changed in indicator-power (Ubuntu):
status: In Progress → Triaged
assignee: Matthew Paul Thomas (mpt) → nobody
description: updated
Charles Kerr (charlesk) on 2014-04-16
Changed in indicator-power (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
Charles Kerr (charlesk) on 2014-07-16
Changed in indicator-power (Ubuntu):
status: Triaged → In Progress
John McAleely (john.mcaleely) wrote :

Not sure how this bug should be tagged, but I assume this is in scope for RTM? (Note duplicate bugs)

tags: added: rtm14
Changed in indicator-power (Ubuntu):
importance: Undecided → Critical
Oliver Grawert (ogra) wrote :

i just filed bug 1360162 which is a far cousin of this one

Charles Kerr (charlesk) wrote :

So, the good news is that the code to pop up a notification is there and working -- an alert does appear, as per the spec.

The bad news is that it's an interactive notification, which means that unity-notifications hardcodes the notification to disappear after five seconds. So unless you're looking at the screen during those five seconds, you won't see the notification.

I'm not sure how to proceed on this. MacSlow's got a valid point about avoiding feature creep in unity-notifications, but I don't see any other obvious medium for this notification. I'm not sure what the Right Thing to do is here.

Perhaps we should have a "low power" sound play, just as laptops and android phones do?

FWIW, this bug is compounded by the power icon not showing red at low power levels. This has a fix about to land in <https://bugs.launchpad.net/ubuntu/+source/indicator-power/+bug/1186181>, which has a fix about to land.

Charles Kerr (charlesk) wrote :
Charles Kerr (charlesk) wrote :

Daniela's updated the notifications spec to handle this case; see attached wireframe.

In short, we change the notification to a Snap Decision so that the notification doesn't disappear after 5 sec. The Snap Decision's two actions are "Battery settings" and "OK".

Thomas Strehl (strehl-t) on 2014-08-29
tags: added: touch-2014-09-11
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+14.10.20140909-0ubuntu1

---------------
indicator-power (12.10.6+14.10.20140909-0ubuntu1) utopic; urgency=low

  [ Charles Kerr ]
  * Add support for UPower 0.99. (LP: #1330037)
  * When the phone's battery goes down past a certain level, pop up a
    snap decision to warn the user. (LP: #1296431)

  [ Ted Gould ]
  * Synchronize process management across indicators
 -- Ubuntu daily release <email address hidden> Tue, 09 Sep 2014 04:22:52 +0000

Changed in indicator-power (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers