Display brightness can lag far behind moving the slider

Bug #1289477 reported by Matthew Paul Thomas on 2014-03-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
indicator-power (Ubuntu)
Undecided
Unassigned
ubuntu-system-settings (Ubuntu)
Low
Unassigned

Bug Description

Ubuntu Trusty r188

1. Access any of the brightness sliders: in System Settings > "Brightness", or System Settings > "Battery", or the Battery menu (bug 1289470).
2. Rapidly slide the slider from minimum to maximum and back again, about ten times, then let go.
3. Wait.

What happens: The phone repeatedly dims and brightens over several seconds after you stop touching the slider.

What should happen: The current brightness level is always either on, or less than ~500 ms from reaching, the brightness shown by the slider *right now*. Any values that the slider was on previously should be ignored.

Compare bug 1306499, the equivalent problem with the volume slider.

affects: ubuntu-system-settings (Ubuntu) → indicator-power (Ubuntu)
Charles Kerr (charlesk) on 2014-03-17
Changed in indicator-power (Ubuntu):
status: New → Confirmed
description: updated
Charles Kerr (charlesk) wrote :

Marking as "fixed" for indicator-power since the brightness slider was removed for 14.04. ;)

mpt, are you seeing this behavior in system settings as well? If so you may want to add that package to this ticket.

Changed in indicator-power (Ubuntu):
status: Confirmed → Fix Released
Matthew Paul Thomas (mpt) wrote :

On a Galaxy Nexus it was terrible. On a Nexus 4 it is much better, but both the slider and the emitted brightness still lag about half a second behind where I drag. Because the slider itself is lagging, I can't tell whether this is a toolkit problem, a System Settings problem, or a brightness subsystem problem.

Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → Low
Pat McGowan (pat-mcgowan) wrote :

Working fine on mako, slider and brightness are simultaneous with the action in the settings pages

Changed in ubuntu-system-settings (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers