icons in indicators are small (difficult to view on FullHD display and smaller than was on 12.04)

Bug #1263228 reported by Norbert
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ido (Ubuntu)
High
Unassigned
indicator-power (Ubuntu)
High
Lars Karlitski

Bug Description

I have Ubuntu 14.04 with all updates installed.

My screen resolution is 1920x1080 (FullHD) at 16.4 inches.
Icons from the menu of newest indicator-keyboard and other gnome-panel icons are very small (difficult to read).

Please adapt icon sizes to large screen resolutions.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: indicator-keyboard 0.0.0+14.04.20131125-0ubuntu1
ProcVersionSignature: Ubuntu 3.12.0-7.15-generic 3.12.4
Uname: Linux 3.12.0-7-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.12.7-0ubuntu3
Architecture: i386
CurrentDesktop: Unity
Date: Sat Dec 21 00:41:25 2013
InstallationDate: Installed on 2013-10-20 (61 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release i386 (20131016.1)
SourcePackage: indicator-keyboard
UpgradeStatus: Upgraded to trusty on 2013-11-19 (31 days ago)

Related branches

Revision history for this message
Norbert (nrbrtx) wrote :
Adolfo Jayme (fitojb)
Changed in indicator-keyboard (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in indicator-keyboard:
status: New → Confirmed
Revision history for this message
Matthew Paul Thomas (mpt) wrote :

This isn't about high resolutions in particular. If the keyboard layout icon isn't readable, then other icons won't be either -- for example the current battery charge, or the Wi-Fi signal strength.

The problem here is that the icons inside the menu are smaller than those in the menu title. They should be exactly the same size. This is also a problem with the battery menu in 13.10.

Norbert (nrbrtx)
summary: - indicator-keyboard icons are small (difficult to view on FullHD displa)
+ indicator-keyboard icons are small (difficult to view on FullHD display)
Norbert (nrbrtx)
tags: added: trusty-desktop
removed: i386
Norbert (nrbrtx)
summary: - indicator-keyboard icons are small (difficult to view on FullHD display)
+ indicator-keyboard and gnome-panel icons are small (difficult to view on
+ FullHD display)
affects: gnome-panel → gnome-panel (Ubuntu)
Revision history for this message
Norbert (nrbrtx) wrote : Re: indicator-keyboard and gnome-panel icons are small (difficult to view on FullHD display)

@mpt, thank you for your comment.
I made a wider title of this bug and updated its description.
The following icons are smaller than on Ubuntu 12.04:
* application menu
* battery charge
* social statuses
* volume icons
* calendar month
and maybe other.

This is usability issue which need to be fixed before Ubuntu 14.04 final release.

description: updated
Norbert (nrbrtx)
tags: added: a11y
Revision history for this message
Dmitry Shachnev (mitya57) wrote :

Not an issue in gnome-panel, I believe this is a bug in indicators stack.

Does this happen in Unity?

no longer affects: gnome-panel (Ubuntu)
Revision history for this message
Norbert (nrbrtx) wrote :

@mitya57, thank you for your comment!
Yes, it happen in Unity too. I see these small icons in all sessions in Ubuntu 14.04 - Ubity, GNOME FlashBack (Compiz and Metacity).

If gnome-panel is not affected, may be gnome-applets are affected package? I do not know package name which belongs to "Add to panel" window. If you see my screenshot: the correct (bigger) size of Ubuntu logo is in 'Main menu' applet, and the incorrect (smaller) size of Ubuntu logo is in 'Menu bar' applet. While in Ubuntu 12.04 these logos have the same size.

Revision history for this message
Dmitry Shachnev (mitya57) wrote : Re: icons in indicators are small (difficult to view on FullHD display)

No, if it happens in Unity, then it is not a bug in gnome-panel/gnome-applets/indicator-applet.

Other tasks look OK to me.

no longer affects: indicator-applet (Ubuntu)
summary: - indicator-keyboard and gnome-panel icons are small (difficult to view on
- FullHD display)
+ icons in indicators are small (difficult to view on FullHD display)
Adolfo Jayme (fitojb)
no longer affects: indicator-keyboard
no longer affects: libindicator (Ubuntu)
tags: added: hidpi
Revision history for this message
Norbert (nrbrtx) wrote :

@Adolfo, bug with small icons still exists.
I returned libindicator again.
If you know other correct source package name which cause small icons in indicators, please add it too.

As an example, indicator-keyboard is affected. And other icons are about 1.5x smaller than in 12.04 LTS.
This problem is accessibility problem.

Revision history for this message
Norbert (nrbrtx) wrote :

The battery icon in indicator-power is extremely small too.
Please find and eliminate the problem.

Norbert (nrbrtx)
summary: - icons in indicators are small (difficult to view on FullHD display)
+ icons in indicators are small (difficult to view on FullHD display and
+ smaller than was on 12.04)
Revision history for this message
Norbert (nrbrtx) wrote :

Marked almost all preinstalled indicators as affected by this bug.
Added attachment with visual comparison of indicators in Ubuntu 12.04 and 14.04, both use Gnome Fallback/FlashBack sessions.

Revision history for this message
Sebastien Bacher (seb128) wrote :

@Norbert: thanks for the interest, I don't think you need to keep posting on that bug so often though, it's going to look at though, no need to spam everyone subscribed

Revision history for this message
Norbert (nrbrtx) wrote :

@seb128
Thank you for your comment, Sebastien!
I'm not going to do spam.

Today I have time to detect problem and collect images. Tomorrow I may not have time for such tests.

For now I have nothing new to say/write. So I'm going to wait and sit quietly :)

no longer affects: indicator-keyboard
no longer affects: indicator-appmenu (Ubuntu)
no longer affects: indicator-applet (Ubuntu)
Revision history for this message
Norbert (nrbrtx) wrote :

Thank you, Dmitry! It seems that I marked more packages that it really needed, but indicator-messages has small icons too.

Sebastien, I'm sorry, but small Ubuntu circle in "Application" and "Places" menu bar come from gnome-panel package (<Alt> + Right Mouse Click on a panel -> Add to panel -> "Menu Bar"/"A custom menu bar").
I grepped my system for "A custom menu bar" - and this string is located in /usr/bin/gnome-panel file (you can test it on your 14.04 system with 'cat /usr/bin/gnome-panel | grep "A custom menu bar" -a'). So gnome-panel package is affected too.

Problem may come from system-wide library as glib or pixman, I do not know exactly.

tags: added: saucy
Charles Kerr (charlesk)
Changed in indicator-power (Ubuntu):
status: New → In Progress
assignee: nobody → Lars Uebernickel (larsu)
Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

It impacts accessibility of a core package.

Changed in gnome-panel (Ubuntu):
importance: Undecided → High
Changed in indicator-application (Ubuntu):
importance: Undecided → High
Changed in indicator-datetime (Ubuntu):
importance: Undecided → High
Changed in indicator-keyboard (Ubuntu):
importance: Medium → High
Changed in indicator-messages (Ubuntu):
importance: Undecided → High
Changed in indicator-power (Ubuntu):
importance: Undecided → High
Changed in indicator-session (Ubuntu):
importance: Undecided → High
Changed in indicator-sound (Ubuntu):
importance: Undecided → High
Changed in libindicator (Ubuntu):
importance: Undecided → High
Changed in indicator-application (Ubuntu):
status: New → Triaged
Changed in indicator-datetime (Ubuntu):
status: New → Triaged
Changed in indicator-keyboard (Ubuntu):
status: Confirmed → Triaged
Changed in indicator-messages (Ubuntu):
status: New → Triaged
Changed in indicator-session (Ubuntu):
status: New → Triaged
Changed in indicator-sound (Ubuntu):
status: New → Triaged
Changed in libindicator (Ubuntu):
status: New → Triaged
Changed in gnome-panel (Ubuntu):
status: New → Triaged
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+14.04.20140328-0ubuntu1

---------------
indicator-power (12.10.6+14.04.20140328-0ubuntu1) trusty; urgency=low

  [ Charles Kerr ]
  * If there are two batteries detected, combine their percentages and
    their time-remainings as per the revised spec. (LP: #880881)

  [ Lars Uebernickel ]
  * Use com.canonical.indicator.basic menu item for device items That
    menu item can handle non-square icons. (LP: #1263228)
 -- Ubuntu daily release <email address hidden> Fri, 28 Mar 2014 16:10:45 +0000

Changed in indicator-power (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Norbert (nrbrtx) wrote :

Thank you, Lars Uebernickel! The indicator-power looks great now.

Revision history for this message
Khurshid Alam (khurshid-alam) wrote :

With latest update, on Gnome-flashback (gnome-panel-3.8) every indicator icons appears small except sound indicator. It doesn't happen in Unity.

Revision history for this message
Norbert (nrbrtx) wrote :

Ubuntu 14.04 with all updates for today - bug exists. Please fix it as soon as possible.

Revision history for this message
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 14.10 (installed from Ubuntu 14.10 _Utopic Unicorn_ - Alpha i386 (20140902)).
Please fix it. Save our eyes!

tags: added: utopic
Revision history for this message
Norbert (nrbrtx) wrote :

Reinstalled Utopic from official beta2 , the bug is still here.

Revision history for this message
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu Utopic 14.10 final.

Mathew Hodson (mhodson)
tags: added: i386
removed: saucy trusty-desktop utopic
Norbert (nrbrtx)
tags: added: saucy utopic
removed: i386
Revision history for this message
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 15.04 alpha2.

tags: added: vivid
Revision history for this message
Ted Gould (ted) wrote :

Moving this over to an ido bug. The individual widgets live there, so that's where it'll need to be fixed/tracked.

no longer affects: indicator-application
no longer affects: indicator-datetime
no longer affects: indicator-keyboard
no longer affects: indicator-messages
no longer affects: indicator-session
no longer affects: indicator-sound
no longer affects: indicator-power
no longer affects: libindicator
no longer affects: gnome-panel (Ubuntu)
affects: indicator-application (Ubuntu) → ido (Ubuntu)
no longer affects: indicator-datetime (Ubuntu)
no longer affects: indicator-keyboard (Ubuntu)
no longer affects: indicator-messages (Ubuntu)
no longer affects: indicator-session (Ubuntu)
no longer affects: indicator-sound (Ubuntu)
no longer affects: libindicator (Ubuntu)
Revision history for this message
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 15.04 beta2.

Revision history for this message
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 15.04 final.

Revision history for this message
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 15.10 beta2.

tags: added: wily
Revision history for this message
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 15.10 final. Icons are small even if I use common 1366x768.

Revision history for this message
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 16.04. Indicator icons are small even if I use common 1366x768.

tags: added: xenial
Revision history for this message
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 16.10. Indicator icons are small even if I use common 1366x768.

tags: added: yakkety
Revision history for this message
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 17.10 final with GNOME Shell.

tags: added: artful
Revision history for this message
Jeremy Bicha (jbicha) wrote :

Norbert, please open a new bug for your Ubuntu 17.10 issue. I recommend running

ubuntu-bug gnome-shell

no longer affects: gnome-shell (Ubuntu)
Revision history for this message
Norbert (nrbrtx) wrote :

Thanks, Jeremy.
The bug on GNOME Shell seems to be already reported - it is bug 1725734 .

Norbert (nrbrtx)
tags: removed: artful saucy trusty utopic vivid wily yakkety
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers