Indicator stuck on mouse icon, along with "estimating..."

Bug #1234458 reported by Marc Deslauriers on 2013-10-03
396
This bug affects 90 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Charles Kerr
indicator-power
In Progress
Low
Charles Kerr
indicator-power (Ubuntu)
Low
Charles Kerr

Bug Description

indicator-power 12.10.6+13.10.20130918.2-0ubuntu1, Ubuntu 13.10

My power indicator is stuck on the mouse icon. When I click on it, it says "Mouse (estimating)".

Why is it stuck on "estimating"?
Why show the icon at all if I'm using a Logitech mouse with a battery?

<https://wiki.ubuntu.com/Power#time-presentation>: "The brief time-remaining string for a component should be:
* the time remaining for it to empty or fully charge, if estimable, in H:MM format; otherwise
* 'estimating…' if the time remaining has been inestimable for less than 30 seconds; otherwise
* 'unknown' if the time remaining has been inestimable for between 30 seconds and one minute; otherwise
* the empty string."

Related branches

Marc Deslauriers (mdeslaur) wrote :
Changed in indicator-power (Ubuntu):
status: New → Confirmed
Ohad Lutzky (lutzky) wrote :

After a little research, here's what I think is going on: The power level information from Logitech mice (using HID++) has very low resolution, as can be seen in hidpp-device.c from the "upower" package: Power level will always be reported as one of [5, 20, 55, 90]. Power drain rate (in watts) is not reported, so I assume the power indicator is trying to figure out how long the battery will last just by taking the differential of the power level. Since this never changes (until it drops by a whole level), the estimate is always infinity.

The solution should be to modify the estimation algorithm so that if it fails to estimate within 1 minute or so, it just reports the power rate (55% in your case).

Alexander Poddubny (poddubny) wrote :

I'd suggest, if possible, to make the mouse charge state indicator optional, or, as a quick fix, to remove it at all. This indicator is not much needed and and just increases the clutter

eksortso (eksortso) wrote :

Just based on the comments on 2013-10-20, although lutzky's proposition is interesting, my preference is to make the mouse charge status indicator optional. I have a Logitech wireless mouse, and the power level is a stable 85%, which I don't want to see.

tags: added: rls-t-incoming
Changed in indicator-power:
assignee: nobody → Charles Kerr (charlesk)
Charles Kerr (charlesk) wrote :

Marc / Ohad, could you please attach the output of "upower --dump" when this behavior is happening?

Furkan (falaca) wrote :

Here's mine, for what it's worth (I just pasted the section about the mouse). It's been reporting 55% for 5-6 days now, which seems to confirm what Ohad says:

Device: /org/freedesktop/UPower/devices/mouse_0003o046DoC52Fx0002
  native-path: /sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.1/1-1.1:1.1/0003:046D:C52F.0002
  vendor: Logitech, Inc.
  model: M305
  serial: 87223A2A
  power supply: no
  updated: Wed 23 Oct 2013 01:11:01 PM EDT (48 seconds ago)
  has history: yes
  has statistics: no
  mouse
    present: yes
    rechargeable: yes
    state: discharging
    percentage: 55%

fimbulvetr (fimbulvetr) wrote :

Same here:

Device: /org/freedesktop/UPower/devices/mouse_0003o046DoC52Bx0004
  native-path: /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.2/0003:046D:C52B.0003/0003:046D:C52B.0004
  vendor: Logitech, Inc.
  model: Performance MX
  serial: 9E2F383D
  power supply: no
  updated: Wed 23 Oct 2013 07:04:42 PM MDT (40 seconds ago)
  has history: yes
  has statistics: no
  mouse
    present: yes
    rechargeable: yes
    state: discharging
    percentage: 20%

K W (djstrong) wrote :

Label "estimating...". The log is the same when mouse is recharging or not.

Device: /org/freedesktop/UPower/devices/mouse_0003o046DoC52Bx0004
  native-path: /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.2/0003:046D:C52B.0003/0003:046D:C52B.0004
  vendor: Logitech, Inc.
  model: Performance MX
  serial: 45469E4D
  power supply: no
  updated: Thu 24 Oct 2013 09:20:04 AM CEST (38 seconds ago)
  has history: yes
  has statistics: no
  mouse
    present: yes
    rechargeable: yes
    state: discharging
    percentage: 5%

K W (djstrong) wrote :

When charged and plugged to USB:
Device: /org/freedesktop/UPower/devices/mouse_0003o046DoC52Bx0004
  native-path: /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.2/0003:046D:C52B.0003/0003:046D:C52B.0004
  vendor: Logitech, Inc.
  model: Performance MX
  serial: 45469E4D
  power supply: no
  updated: Thu 24 Oct 2013 01:13:40 PM CEST (55 seconds ago)
  has history: yes
  has statistics: no
  mouse
    present: yes
    rechargeable: yes
    state: fully-charged
    percentage: 5%

Alexander Ruliov (rulix-exec) wrote :

Percentage always at 90%.

Device: /org/freedesktop/UPower/devices/mouse_0003o046DoC52Fx0002
  native-path: /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.1/0003:046D:C52F.0002
  vendor: Logitech, Inc.
  model: M185/M225
  serial: 0320E001
  power supply: no
  updated: Thu 24 Oct 2013 09:39:44 PM FET (3 seconds ago)
  has history: yes
  has statistics: no
  mouse
    present: yes
    rechargeable: yes
    state: discharging
    percentage: 90%

Petar Sredojevic (perosredo) wrote :

Disabling this indicator optional should definitely be an option somewhere.

Dump attached eitherwhichway.

Disabling the indicator is my strongly preferred option...

On 10/29/2013 03:57 PM, Petar Sredojevic wrote:
> Disabling this indicator optional should definitely be an option
> somewhere.
>
> Dump attached eitherwhichway.
>
> ** Attachment added: "upower-dump.txt"
> https://bugs.launchpad.net/ubuntu/+source/indicator-power/+bug/1234458/+attachment/3895167/+files/upower-dump.txt
>

--
Dan Gillmor
dangillmor.com/about
+1.650.868.7528

Matthew Paul Thomas (mpt) wrote :

So do we need to blacklist all Logitech mice as devices that will never provide useful estimates? Or just some Logitech mice? Or something else?

(You can turn off the menu altogether in the "Power" panel of System Settings.)

Dan Gillmor (dan-gillmor) wrote :

Until there's a fix for the Logitech mice specifically, the best option
is to let people turn off individual devices. In my case I never care to
see the mouse battery indicator.

On 11/01/2013 12:07 PM, Matthew Paul Thomas wrote:
> So do we need to blacklist all Logitech mice as devices that will never
> provide useful estimates? Or just some Logitech mice? Or something else?
>
> (You can turn off the menu altogether in the "Power" panel of System
> Settings.)

Marc Deslauriers (mdeslaur) wrote :

Well, Logitech mice do provide useful "percentage of battery remaining" information. I think this simply needs to be fixed to remove the time estimation if the device doesn't provide it. Knowing that my mouse battery is at 10% remaining before going on a trip is useful to know.

Matthew Paul Thomas (mpt) wrote :
description: updated
Changed in indicator-power:
status: New → Triaged
Furkan (falaca) wrote :

@Matthew

I don't think disabling the power menu is an acceptable solution for those of us who are using laptops, since I would still like to see my laptop's battery status. It would be better if there was a way to remove the mouse status from the power menu.

Needless to say, Logitech is a huge vendor, so this bug probably affects a lot of people.

Changed in indicator-power (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Changed in hundredpapercuts:
status: New → Triaged
importance: Undecided → Low
Reece (reece) wrote :
Download full text (4.2 KiB)

Same problem here.

Screenshot attached. upower -d below.

This laptop has a logitech unified receiver attached. There are multiple mice and keyboards because the receiver is reporting all registered devices, even if unavailable.

snafu$ upower -d
Device: /org/freedesktop/UPower/devices/line_power_ACAD
  native-path: ACAD
  power supply: yes
  updated: Sun 17 Nov 2013 10:28:53 AM PST (750 seconds ago)
  has history: no
  has statistics: no
  line-power
    online: yes

Device: /org/freedesktop/UPower/devices/battery_BAT1
  native-path: BAT1
  vendor: Simplo
  model: PABAS0241231
  serial: 41167
  power supply: yes
  updated: Sun 17 Nov 2013 10:28:58 AM PST (745 seconds ago)
  has history: yes
  has statistics: yes
  battery
    present: yes
    rechargeable: yes
    state: fully-charged
    energy: 64.98 Wh
    energy-empty: 0 Wh
    energy-full: 64.98 Wh
    energy-full-design: 69 Wh
    energy-rate: 2.698 W
    voltage: 16.657 V
    percentage: 100%
    capacity: 94.1739%
    technology: lithium-ion

Device: /org/freedesktop/UPower/devices/keyboard_0003o046DoC52Bx000D
  native-path: /sys/devices/pci0000:00/0000:00:14.0/usb3/3-1/3-1:1.2/0003:046D:C52B.000B/0003:046D:C52B.000D
  vendor: Logitech, Inc.
  model: K520
  serial: 009A3D0E
  power supply: no
  updated: Sun 17 Nov 2013 10:41:02 AM PST (21 seconds ago)
  has history: yes
  has statistics: no
  keyboard
    present: no
    rechargeable: yes
    state: unknown
    percentage: 0%

Device: /org/freedesktop/UPower/devices/mouse_0003o046DoC52Bx000C
  native-path: /sys/devices/pci0000:00/0000:00:14.0/usb3/3-1/3-1:1.2/0003:046D:C52B.000B/0003:046D:C52B.000C
  vendor: Logitech, Inc.
  model: T650
  serial: 2A8C575E
  power supply: no
  updated: Sun 17 Nov 2013 10:41:02 AM PST (21 seconds ago)
  has history: yes
  has statistics: no
  mouse
    present: no
    rechargeable: yes
    state: unknown
    percentage: 0%

Device: /org/freedesktop/UPower/devices/keyboard_0003o046DoC52Bx0010
  native-path: /sys/devices/pci0000:00/0000:00:14.0/usb3/3-1/3-1:1.2/0003:046D:C52B.000B/0003:046D:C52B.0010
  vendor: Logitech, Inc.
  model: K520
  serial: 61EC17CC
  power supply: no
  updated: Sun 17 Nov 2013 10:41:02 AM PST (21 seconds ago)
  has history: yes
  has statistics: no
  keyboard
    present: yes
    rechargeable: yes
    state: discharging
    percentage: 90%

Device: /org/freedesktop/UPower/devices/mouse_0003o046DoC52Bx000E
  native-path: /sys/devices/pci0000:00/0000:00:14.0/usb3/3-1/3-1:1.2/0003:046D:C52B.000B/0003:046D:C52B.000E
  vendor: ...

Read more...

Matthias Gehre (m-gehre) wrote :

For me, it would suffice to see the battery state in the (collapsed) indicator. (I.e. in the top row).
Currently the mouse is in the top row, showing nothing but "(estimating...)", which does not help at all.

The mouse can stay in the power menu, (the menu that opens after clicking on the indicator),
but please make the laptop battery the first row.

Eugene Romero (anakondarh) wrote :

+1 for this bug.

Seems like a bug that has been around for ever...
Fully agree with the proposed solutions. Either 1) have a choice of which devices to track battery level for or 2) be able to choose which device to always show in the panel.

As it is right now, seeing "estimating..." in the panel for my wireless keyboard is not very useful.

Mindaugas Jakutis (la-mj) wrote :

if you think two months for a bug is forever, you clearly haven't seen that many

+1 for disabling devices

MEB (mysticeyeblink) wrote :

+ 1 for disabling devices from me,
because I'm using Solaar for Logitech Unifying Reciver and I don't need it in this shape

Jon Champagne (jayseejc3191) wrote :

+1 for disabling devices here too

maxwellcom (ndmaxwell) wrote :

Similar to #21 (m-gehre), I think rather than being able to disable items, a better design would be to enable users to select a "default" display device. That way everyone has access to the panel's information, but each individual can determine the most important device to display.

Charles Kerr (charlesk) on 2014-03-13
Changed in indicator-power:
status: Triaged → In Progress
Changed in indicator-power (Ubuntu):
status: Triaged → In Progress
Changed in hundredpapercuts:
status: Triaged → In Progress
assignee: nobody → Charles Kerr (charlesk)
Changed in indicator-power (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
Changed in indicator-power:
importance: Undecided → Low
Dan Herman (dan-herman) wrote :

+1 for "make the laptop battery the first row."

And perhaps just change the word "estimating" to a ~ (tilde) to represent an approximation.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+14.04.20140314-0ubuntu1

---------------
indicator-power (12.10.6+14.04.20140314-0ubuntu1) trusty; urgency=low

  [ Charles Kerr ]
  * Change the implementation of the title text / title accessible text
    / menuitem text to follow the spec changes in
    https://wiki.ubuntu.com/Power?action=diff&rev2=44&rev1=43#Title and
    update the tests accordingly. (LP: #1234458)
 -- Ubuntu daily release <email address hidden> Fri, 14 Mar 2014 14:14:07 +0000

Changed in indicator-power (Ubuntu):
status: In Progress → Fix Released
Jochen Fahrner (jofa) wrote :

IMHO this bug is NOT fixed. When laptop battery is fully charged the indicator shows a mouse icon. I'm never interested in mouse battery status. The more useful information is always the laptop battery. Is laptop on AC? Is it charging? How long does it take? Is it fully charged? This is what I need to know. Not the mouse battery.

Please let users disable mouse battery status in the indicator. This must not be in the normal settings app, its sufficient to have a dconf setting.

Marc Deslauriers (mdeslaur) wrote :

@Jochen:

Displaying the mouse only takes priority if the battery is fully charged and not in a state where it's discharging. When that is the case, it's no longer worth displaying it to the user.

Marc Deslauriers (mdeslaur) wrote :

Actually, you're right. When my battery is plugged in and charging, it is showing the mouse icon.

The spec says:

"If anything is discharging, the menu title should represent the component (not battery, but component) that is estimated to lose power first. For example, if your notebook battery is estimated to discharge in 1 hour 47 minutes, and your wireless mouse battery is estimated to discharge in 27 minutes, the menu title should represent the mouse. "

In this case, my mouse does not provide an estimated time remaining, so it should not be displayed in preference to the battery.

Marc Deslauriers (mdeslaur) wrote :

I've opened bug 1315434 to track that particular issue.

Jochen Fahrner (jofa) wrote :

Having mouse battery status in the indicator is a nice feature, but laptop battery should always be on the top of the list.

I changed the sorting algorithm in service.c so that laptop battery has always the highest precidence.
If others wish this to be the same, and want to recompile indicator-power, I attach a patch.

Jochen Fahrner (jofa) wrote :

@Marc:

>In this case, my mouse does not provide an estimated time remaining, so it should not be displayed in preference to the battery.

The current logic is, that discharging has precedence over charging. But this is useles, sind mice normally have primary cells that cannot be charged. And I#m not interested in their status because they run monthes, even with a low status. The current logic is absolutely nonsens and not practical!

Marc Deslauriers (mdeslaur) wrote :

@Jochen: this bug is closed, please comment and send your patch to bug 1315434

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers