power indicator shows a mouse battery as a laptop battery

Bug #1066208 reported by gpothier on 2012-10-13
248
This bug affects 52 people
Affects Status Importance Assigned to Milestone
indicator-power
Fix Released
High
Charles Kerr
indicator-power (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

Impact:
some devices are displayed with the wrong icon

Test Case:
use a bluetooth mouse on a laptop, see if each device has the current icon displayed

Regression potential:
the update tweak the primary device selection and the icons to use, check that devices are correctly listed and that their icons match, check also that the primary icon (the one in the panel) is also the most important one

---

This occurs on an up to date (13 Oct 2012) 12.10 install. The battery indicator at the top of the screen displays the status of my bluetooth mouse's battery instead of the notebook's battery. Clicking on the battery icon shows that there are two batteries. Clicking on one of them brings the Power Statistics window, where two batteries are also listed, both as Laptop batteries. The one corresponding to the mouse says:
Device: battery_hid_00o08o76o30oE9o6B_battery
Type: Laptop battery
Model: Targus Soft-Touch Bluetooth Mouse

(and some more data)

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gnome-power-manager 3.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
Date: Sat Oct 13 00:09:35 2012
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-power-manager
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

gpothier (gpothier) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed
Matt (drmattp) wrote :

Also affects me with a Sony VGP-BMS10 bluetooth mouse.

gnome-power-statistics shows this battery as being a "Laptop battery" with device code battery_hid_00o02o76o30o26oAA_battery

Matt (drmattp) wrote :

Actually - I'm finding this quite useful. Since my last restart the battery manager is showing both the actual laptop battery, and the bluetooth mouse battery. Maybe this isn't a bug after all?

Matt (drmattp) wrote :

(although, the indicator applet in gnome-classic is prioritising the bluetooth battery because it is low, so at first glance to the indicator bar it always looks like my laptop battery is empty)

gpothier (gpothier) wrote :

I guess at least the fact that the mouse's battery is listed as laptop battery is a bug.
Now, while it is indeed useful to be able to know the state of the mouse's battery, showing it on the panel by default is couterintuitive. There shoule be a mouse icon right next to the battery, or some other visual cue to indicate that the battery currently shown is not the laptop's.

Ondrej Kubik (ondrak) wrote :

Not exactly this bug, but potentially related.
Since mouse battery is shown as default, it raised interesting question, what is active power mode "On Battery Power" or "When Plugged in"?

Charles Kerr (charlesk) on 2012-10-25
Changed in indicator-power:
status: New → In Progress
assignee: nobody → Charles Kerr (charlesk)
Charles Kerr (charlesk) wrote :

wrt comment #6, showing the mouse battery as a laptop battery is definitely a bug. :)

Charles Kerr (charlesk) wrote :

Regarding the other half of this ticket: showing the mouse battery instead of the notebook battery /might/ be correct, but it depends on the state of the two batteries. The spec at https://wiki.ubuntu.com/Power#Title states the decision should be based on "what you need to know most: what device will lose power soonest (and optionally when), or otherwise which device will take longest to charge".

I've filed bug #1071645 to cover the other half of this bug separately.

summary: - Battery indicator shows mouse battery instead of notebook battery
+ power indicator shows a mouse battery as a laptop battery
Changed in indicator-power:
importance: Undecided → High
Charles Kerr (charlesk) on 2012-10-26
Changed in indicator-power:
status: In Progress → Fix Committed
affects: gnome-power-manager (Ubuntu) → indicator-power (Ubuntu)
Changed in indicator-power (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in indicator-power (Ubuntu Quantal):
importance: Undecided → High
status: New → Triaged
Changed in indicator-power (Ubuntu Quantal):
status: Triaged → In Progress
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.4-0ubuntu1

---------------
indicator-power (12.10.4-0ubuntu1) raring; urgency=low

  * New upstream release.
    - Show the proper icon for mice and ups devices. (LP: #1066208)
 -- Sebastien Bacher <email address hidden> Mon, 05 Nov 2012 12:41:37 +0100

Changed in indicator-power (Ubuntu):
status: Triaged → Fix Released
Gregor Riepl (onitake) wrote :

Thanks for the fix.
Will this fix be backported to quantal?

I'm affected by the bug, and I also get the wrong battery indicator when the interfering HID device is not connected - albeit only when the computer is charging. During discharge, the indicator correctly displays laptop battery status.

kenburgi (kwburgi) wrote :

I installed indicator-power_12.10.6 from the Indicator Staging PPA. Seems to pick the correct battery to display, until I turn off the bluetooth mouse, then it shows the icon for a low battery connected to AC power. When I click to display the menu, it shows the laptop battery charged, and the mouse battery as "(not present)". Also it still refers to the mouse as a "Battery" or "Laptop Battery" depending on where you look.

I would prefer it if I could select a default, because I really don't care about the battery status of my bluetooth mouse.

Warren Baird (wjbaird) wrote :

I'm having a very similar problem on 12.10, but with a bluetooth keyboard (logitech K810). I've also tried the indicator-power_12.10.6 from the staging PPA and it doesn't seem to fully fix the issue. My experience is similar to kwburgi indicated, I think it does a better job of picking which battery to show some of the time - but there is still no indication in the notification widget which battery is the laptop battery and which is the keyboard battery - and the keyboard battery is still shown in the list (as 'not present') even when my laptop is at work, and the keyboard is at home...

In the "Power Statistics dialog, both are listed as 'laptop battery'.

Basically, I don't really consider this issue fixed. Should I open new bugs for these other issues, or would you like to re-open this one?

Matthew Paul Thomas (mpt) wrote :

Please do report separate bugs. Which icon is shown in the menu title is a separate issue from which icons are used for items inside the menu.

mpw (matthiaspeterw) wrote :

I have the same problem in 12.04 LTS, too. Are there any fixes planned?

James M. Leddy (jm-leddy) wrote :

I can definitely reproduce this issue if anyone needs help.

James M. Leddy (jm-leddy) wrote :

It does not look like precise was targeted, but at the same time I do not see my mouse battery involved anymore.

Charles Kerr (charlesk) on 2013-07-01
Changed in indicator-power:
status: Fix Committed → Fix Released
Rayner Pires (raynermp) wrote :

I still have this problem. I say problem because it also affects my mouse pointing function. Every time indicator-power access my bluetooth mouse battery level it stops pointing and moving. I have to disconnect and reconnect it many times until it gets moving again.

It seems the function of pointing device is overlapped by the battery level property.

Anyone under the same trouble? Did you get the solve for this???

Thanks in advance!

Matthew Paul Thomas (mpt) wrote :

Rayner, that is a different problem. Please report it separately, by entering "ubuntu-bug upower" in a terminal.

Shih-Yuan Lee (fourdollars) wrote :

Hi,

I am working on a patch post on http://lists.freedesktop.org/archives/devkit-devel/2013-August/001416.html .
It might be relative to this issue.
The patch is for upower.

Shih-Yuan Lee (fourdollars) wrote :

BTW, I have made the Debian packages of Ubuntu 12.04 at http://people.canonical.com/~sylee/1153488/ for Bug #1153488.
Maybe you can try it, too.

Martin Pitt (pitti) wrote :

This is ultimately an upower bug, so I'm duplicating to bug 1153488.

Martin Pitt (pitti) wrote :

Sorry, unduplicating as this seems to be an active SRU. The indicator should check the "PowerSupply" property of upower devices, True == powering computer, False == wireless input devices

Martin Pitt (pitti) wrote :

For developing a test case for upower for this bug (properly classifying the device type of input device batteries) it would be really helpful if you could copy&paste the output of this command, with wireless mouse and/or batteries attached.

  grep -r . /sys/class/power_supply/*hid*

Thanks!

Download full text (6.4 KiB)

When i wrote
     grep -r . /sys/class/power_supply/*hid*
I got this when laptop ux31e is connected to energy and connect my bluetooth keyboard device:
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/type:Battery
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/power/control:auto
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/power/runtime_active_time:0
grep: /sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/power/autosuspend_delay_ms: Error de entrada/salida
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/power/runtime_status:unsupported
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/power/runtime_suspended_time:0
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/scope:Device
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/capacity:47
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/online:1
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/status:Discharging
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/uevent:POWER_SUPPLY_NAME=hid-cc:c5:0a:05:02:87-battery
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/uevent:POWER_SUPPLY_PRESENT=1
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/uevent:POWER_SUPPLY_ONLINE=1
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/uevent:POWER_SUPPLY_CAPACITY=47
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/uevent:POWER_SUPPLY_MODEL_NAME=Bluetooth Keyboard
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/uevent:POWER_SUPPLY_STATUS=Discharging
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/uevent:POWER_SUPPLY_SCOPE=Device
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/model_name:Bluetooth Keyboard
/sys/class/power_supply/hid-cc:c5:0a:05:02:87-battery/present:1
/sys/class/power_supply/hid-f4:1b:a1:31:34:fc-battery/type:Battery
/sys/class/power_supply/hid-f4:1b:a1:31:34:fc-battery/power/control:auto
/sys/class/power_supply/hid-f4:1b:a1:31:34:fc-battery/power/runtime_active_time:0
grep: /sys/class/power_supply/hid-f4:1b:a1:31:34:fc-battery/power/autosuspend_delay_ms: Error de entrada/salida
/sys/class/power_supply/hid-f4:1b:a1:31:34:fc-battery/power/runtime_status:unsupported
/sys/class/power_supply/hid-f4:1b:a1:31:34:fc-battery/power/runtime_suspended_time:0
/sys/class/power_supply/hid-f4:1b:a1:31:34:fc-battery/scope:Device
/sys/class/power_supply/hid-f4:1b:a1:31:34:fc-battery/capacity:73
/sys/class/power_supply/hid-f4:1b:a1:31:34:fc-battery/online:1
/sys/class/power_supply/hid-f4:1b:a1:31:34:fc-battery/status:Discharging
/sys/class/power_supply/hid-f4:1b:a1:31:34:fc-battery/uevent:POWER_SUPPLY_NAME=hid-f4:1b:a1:31:34:fc-battery
/sys/class/power_supply/hid-f4:1b:a1:31:34:fc-battery/uevent:POWER_SUPPLY_PRESENT=1
/sys/class/power_supply/hid-f4:1b:a1:31:34:fc-battery/uevent:POWER_SUPPLY_ONLINE=1
/sys/class/power_supply/hid-f4:1b:a1:31:34:fc-battery/uevent:POWER_SUPPLY_CAPACITY=73
/sys/class/power_supply/hid-f4:1b:a1:31:34:fc-battery/uevent:POWER_SUPPLY_MODEL_NAME=Apple Wireless Trackpad
/sys/class/power_supply/hid-f4:1b:a1:31:34:fc-battery/uevent:POWER_SUPPLY_STATUS=Discharging
/sys/class/power_supply/hid-f4:1b:a1:31:34:fc-battery/uevent:POWER_SUPPLY_SCOPE=Device
/sys/class/power_supply/hid-f4:1b:a1:31:34:fc-batte...

Read more...

Martin Pitt (pitti) wrote :

Thanks Diego!

I started seeing this on my 12.04.3 LTS system after I upgraded the kernel and the X packages to the LTS Enablement Stack versions as per https://wiki.ubuntu.com/Kernel/LTSEnablementStack with the commands:

sudo apt-get install linux-image-generic-lts-quantal
sudo apt-get install xserver-xorg-lts-quantal

This is on a *desktop*, not a laptop, so it is especially frustrating when the system decides to power down because my bluetooth keyboard battery is low.

When the bluetooth keyboard is turned off, I see no battery indicator on status bar, or have any battery issues. When bluetooth keyboard is on, its battery is treated as a system battery.

The bluetooth device in question is a Lenovo Thinkpad Bluetooth keyboard.

The output of grep -r . /sys/class/power_supply/*hid* is attached.

Francisco Lopes (oblita) wrote :

Should this be already fixed on 13.04, because I suffer the same issue since I connected a magic mouse to the system. I've already disconnected the mouse, and turned off bluetooth, but the another "laptop" battery is still listed.

Francisco Lopes [2013-10-09 14:32 -0000]:
> Should this be already fixed on 13.04

No, it got fixed in 13.10. There is an update being prepared for 12.04
LTS, but not for 12.10/13.04.

Ralph Meijer (ralphmeijer) wrote :

@pitti: Why is that? The original issue was filed against 12.10, deemed high priority, and I suspect that many people affected by this are running 13.04. Couldn't this be in -proposed?

Francisco Lopes (oblita) wrote :

Also, after reboot the extra battery has gone. But I think it'll come back after the mouse gets connected again till a new reboot.

Bob Englert (rjenglert) wrote :

I see this same problem on my 13.10 install when using several newer models of Logitech wireless mice. The mouse battery charge status is displayed in the notification area instead of the laptop battery.

krozin (krozin) wrote :

I've see this issue in Ubuntu 14.04

My laptop is rebooting randomly due to mouse battery is low

$ upower --dump
Device: /org/freedesktop/UPower/devices/line_power_ACAD
  native-path: ACAD
  power supply: yes
  updated: Ср. 23 дек. 2015 18:44:56 (498 seconds ago)
  has history: no
  has statistics: no
  line-power
    online: yes

Device: /org/freedesktop/UPower/devices/battery_BAT1
  native-path: BAT1
  vendor: COMPAL
  model: PABAS0241231
  serial: 41167
  power supply: yes
  updated: Ср. 23 дек. 2015 18:53:02 (12 seconds ago)
  has history: yes
  has statistics: yes
  battery
    present: yes
    rechargeable: yes
    state: charging
    energy: 95,6016 Wh
    energy-empty: 0 Wh
    energy-full: 99,5652 Wh
    energy-full-design: 95,04 Wh
    energy-rate: 14,2452 W
    voltage: 12,502 V
    time to full: 16,7 minutes
    percentage: 96%
    capacity: 100%
    technology: lithium-ion
  History (charge):
    1450885982 96,000 charging
  History (rate):
    1450885982 14,245 charging
    1450885952 14,602 charging
    1450885922 14,926 charging
    1450885892 15,282 charging

Device: /org/freedesktop/UPower/devices/battery_hid_6co5do63o00o3eod5_battery
  native-path: hid-6c:5d:63:00:3e:d5-battery
  model: Rapoo 6610
  power supply: no
  updated: Ср. 23 дек. 2015 18:53:06 (8 seconds ago)
  has history: yes
  has statistics: yes
  battery
    present: yes
    rechargeable: yes
    state: discharging
    energy: 0 Wh
    energy-empty: 0 Wh
    energy-full: 0 Wh
    energy-full-design: 0 Wh
    energy-rate: 0 W
    percentage: 6%
    capacity: 100%

Daemon:
  daemon-version: 0.9.23
  can-suspend: yes
  can-hibernate: yes
  on-battery: no
  on-low-battery: no
  lid-is-closed: no
  lid-is-present: yes
  is-docked: no

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers