indicator-network-secret-agent crashed with SIGSEGV in do_lookup_x()

Bug #1632275 reported by Dave Morley on 2016-10-11
38
This bug affects 18 people
Affects Status Importance Assigned to Milestone
indicator-network (Ubuntu)
High
Pete Woods

Bug Description

Live session on i386 has an issue immediately which reports that network-manager indicator crashed

On the installed version it is impossible to connect to the net via wifi

Will check on amd64 but as far as I can tell it is fine there.

ProblemType: Crash
DistroRelease: Ubuntu 16.10
Package: indicator-network 0.8.0+16.10.20160930.5-0ubuntu1
ProcVersionSignature: Ubuntu 4.8.0-21.23-generic 4.8.0
Uname: Linux 4.8.0-21-generic i686
ApportVersion: 2.20.3-0ubuntu7
Architecture: i386
CasperVersion: 1.379
CrashCounter: 1
CurrentDesktop: Unity
Date: Tue Oct 11 10:17:39 2016
ExecutablePath: /usr/lib/i386-linux-gnu/indicator-network/indicator-network-secret-agent
ExecutableTimestamp: 1475255305
LiveMediaBuild: Ubuntu 16.10 "Yakkety Yak" - Alpha i386 (20161008)
ProcCmdline: /usr/lib/i386-linux-gnu/indicator-network/indicator-network-secret-agent
ProcCwd: /home/ubuntu
ProcEnviron:
 PATH=(custom, user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xb779ceba <do_lookup_x+42>: mov 0x4(%eax),%ebx
 PC (0xb779ceba) ok
 source "0x4(%eax)" (0x000003eb) not located in a known VMA region (needed readable region)!
 destination "%ebx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: indicator-network
Stacktrace:
 #0 do_lookup_x (undef_name=0x0, new_hash=1, old_hash=0xbfacd72b, ref=0x0, result=0x644, scope=0x3e7, i=3807944636, version=0xb779d529 <do_lookup_x+1689>, flags=5, skip=0x1, type_class=-1226258504, undef_map=0xd62) at dl-lookup.c:361
         n = <error reading variable n (Cannot access memory at address 0x3eb)>
         list = <optimized out>
 #1 0x00000000 in ?? ()
 No symbol table info available.
StacktraceTop:
 do_lookup_x (undef_name=0x0, new_hash=1, old_hash=0xbfacd72b, ref=0x0, result=0x644, scope=0x3e7, i=3807944636, version=0xb779d529 <do_lookup_x+1689>, flags=5, skip=0x1, type_class=-1226258504, undef_map=0xd62) at dl-lookup.c:361
 ?? ()
Title: indicator-network-secret-agent crashed with SIGSEGV in do_lookup_x()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
upstart.indicator-network.log: indicator-network stop/pre-start, process 5765

Related branches

Dave Morley (davmor2) wrote :
information type: Private → Public
description: updated

Stacktrace:
 #0 do_lookup_x (undef_name=0x0, new_hash=1, old_hash=0xbfacd72b, ref=0x0, result=0x644, scope=0x3e7, i=3807944636, version=0xb779d529 <do_lookup_x+1689>, flags=5, skip=0x1, type_class=-1226258504, undef_map=0xd62) at dl-lookup.c:361
         n = <error reading variable n (Cannot access memory at address 0x3eb)>
         list = <optimized out>
 #1 0x00000000 in ?? ()
 No symbol table info available.
StacktraceSource:
 #0 do_lookup_x (undef_name=0x0, new_hash=1, old_hash=0xbfacd72b, ref=0x0, result=0x644, scope=0x3e7, i=3807944636, version=0xb779d529 <do_lookup_x+1689>, flags=5, skip=0x1, type_class=-1226258504, undef_map=0xd62) at dl-lookup.c:361
   [Error: dl-lookup.c was not found in source tree]
 #1 0x00000000 in ?? ()
StacktraceTop:
 do_lookup_x (undef_name=0x0, new_hash=1, old_hash=0xbfacd72b, ref=0x0, result=0x644, scope=0x3e7, i=3807944636, version=0xb779d529 <do_lookup_x+1689>, flags=5, skip=0x1, type_class=-1226258504, undef_map=0xd62) at dl-lookup.c:361
 ?? ()

tags: added: apport-failed-retrace
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-network (Ubuntu):
status: New → Confirmed
Lukáš Tinkl (lukas-kde) wrote :

Happens here as well, amd64, xenial.

The result is activating an AP from either the indicators or system settings is impossible.

Iain Lane (laney) wrote :

You can reproduce this in a unity 7 live session on the current yakkety daily, for an easy way to poke

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1632275

tags: added: iso-testing
Dave Morley (davmor2) wrote :

Seems easy to reproduce on i386 but not so easy on amd64

After UEFI installation alongside W, indicator-network shows ethernet connection instead of Wi-Fi on first boot, however internet works fine. Tested on amd64 laptop intel+intel graphics+intel wireless 3160

HW Amd+Nvidia graphics+Ralink RT2561.

When installing Yakkety adm64 and just after clicking next from Download updates+Install 3rd party drivers screen, Wi-FI icon gets blank and installation options appear. There is no internet connection. Additionaly, Wi-Fi seems to be unable to reconnect the previous Wi-Fi network

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-network - 0.8.0+16.10.20160930.5-0ubuntu2

---------------
indicator-network (0.8.0+16.10.20160930.5-0ubuntu2) yakkety; urgency=medium

  * data/indicator-network-secret-agent.conf.in: Only start on Unity 8. We
    only start the indicator there; do the same for the secret-agent too. This
    works around a crash on i386 (by not running the code) - the crash is
    still pending investigation. (LP: #1632275)

 -- Iain Lane <email address hidden> Tue, 11 Oct 2016 17:26:36 +0100

Changed in indicator-network (Ubuntu):
status: Confirmed → Fix Released
Iain Lane (laney) wrote :

Reopening, since the crash still needs to be fixed; it just doesn't get run on U7 all the time any more so we don't see it so much.

Changed in indicator-network (Ubuntu):
status: Fix Released → Triaged
Pete Woods (pete-woods) on 2016-10-13
Changed in indicator-network (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Pete Woods (pete-woods)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-network - 0.8.0+17.04.20161109-0ubuntu1

---------------
indicator-network (0.8.0+17.04.20161109-0ubuntu1) zesty; urgency=medium

  * Try again to make the tests more reliable (LP: #1632275)

 -- Pete Woods <email address hidden> Wed, 09 Nov 2016 10:04:06 +0000

Changed in indicator-network (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers