[phone] [ubuntu touch] indicator-network-service fail to start

Bug #1626244 reported by quent57 on 2016-09-21
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
indicator-network (Ubuntu)
Undecided
Unassigned

Bug Description

When I start my BQ Aquaris 4.5, I see a gear with "indicator-network" written with nothing in the panel instead of the real indicator menu.

The settings are also buggy :
Wifi : I see only saved networks
Phone network : I cannot enable data.

I do not know much about ubuntu touch, I tried the following command, and I get an error :

root@ubuntu-phablet:/# ./usr/lib/arm-linux-gnueabihf/indicator-network/indicator-network-service
Error getting the bus address: Cannot autolaunch D-Bus without X11 $DISPLAY
(process:8397): GLib-GIO-CRITICAL **: g_dbus_connection_get_unique_name: assertion 'G_IS_DBUS_CONNECTION (connection)' failed
terminate called after throwing an instance of 'std::logic_error'
  what(): basic_string::_S_construct null not valid

Aborted (core dumped)

Before the bug, I activated simultaneously :
 - 3G
 - wifi
 - VPN

I turned wifi hotspot on, and a bit later the phone froze on a black screen. I turn it off with power button for 5 seconds.

On reboot, the indicator-network show a gear with empty menu.

3G + wifi hotspot + vpn worked many times before.

I run last update : OTA 13.

quent57 (quent57) wrote :
quent57 (quent57) wrote :
quent57 (quent57) wrote :
quent57 (quent57) wrote :
quent57 (quent57) on 2016-09-22
tags: added: touch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-network (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers